Jump to content
Covecube Inc.
  • 0
Sign in to follow this  
joe_m

Scanner Scheduling?

Question

I have Scanner running on  WHS2011 server which is also running the add-in LightsOut.  I have the server scheduled in LightsOut to awake for a few hours in the morning to perform the server back-up and then again later at night to back-up client PCs and shut them down.   Except for the scheduled back-up times, the server is usually in hibernation (sleep not available on HP EX495) The server is occasionally awakened by the clients to access shared files.  When Scanner runs in this use case it appears to start over every time the server awakens from hibernation but is usually suspended by the drive activity of the backups.  There is never enough awake time to complete a single HDD so Scanner keeps starting over with the same drive. 

 

I would like to schedule Scanner to run on a specified schedule - say the first of the month and set-up a schedule in LightsOut to keep the server awake in the early morning hours so Scanner can perform uninterrupted.  Unfortunately, I can't determine how to configure Scanner to a specific calendar date.   Any ideas or suggestions?  Maybe I am missing something obvious/simple?  Thanks!!

Share this post


Link to post
Share on other sites

18 answers to this question

Recommended Posts

  • 0

Joe,

 

There should be an option in Scanner to "wake for scan". Though, that may not work with Hibernate, depending.

 

However, could you not use LightsOut to schedule the server to wake up for an extended period, to make sure scanner is run

 

However, scheduling on a specific date (or maybe even adding a command line util to initiate a scan) is a good idea.

Share this post


Link to post
Share on other sites
  • 0

Also, if you don't mind the performance hit, you could disable the "Do not interfere with disk activity" option. Also, you may definitely want to disable the "Do not interfere with other disks on the same controller" option.

 

You may take a performance hit for doing so, but it would make sure everything got scanned.

Share this post


Link to post
Share on other sites
  • 0

Thank you for the replies and suggestions Drashna!

 

I do have "wake for scan" selected but it is NOT waking the server from hibernation.

 

I don't think I want to disable the "interfere" options as I am concerned that Scanner will have an impact on client PC access to shared files including videos.  

 

I like the idea of a command line that would initiate the scan on a set schedule.  If that would work I could schedule LightsOut to awake the server on the command date and time and stay awake long enough to complete the full scanning.

 

Can you help me with the command?  I would like the scanning to take place one a week or once a month let's say on Sunday @ 0200 ?

 

Thanks

 

Share this post


Link to post
Share on other sites
  • 0

Well, I would recommend disabling the "disks on the same controller" part. That, and you can change the sensitivity threshold for the disks. I think you should at least change that and see how it affects the system as well.

 

 

As for the command line, doesn't exist (yet). I've forwarded the idea to alex,  because it a good idea, and shouldn't be too difficult to implement.

Share this post


Link to post
Share on other sites
  • 0

Thank you again! I will give your suggestions a try.

 

My ask would be to please add an option within the settings > Work Window to specify a day of the week (Monday, Tuesday, etc.) and/or day of the month. (1st, etc..)

 

I look forward to the update.

 

Thanks.

Share this post


Link to post
Share on other sites
  • 0

Joe,

 

I'll try to add the ability to limit automatic scanning to days of the week or days of the month in a future build.

 

Thanks for the suggestion,

Share this post


Link to post
Share on other sites
  • 0

Joe,  

 

I was just reminded/remembered:

Scanner has the option to create a file while it's actively scanning. It's made for stuff like LightsOut.  Enable the setting, and enable the option in LightsOut, and it should prevent the server from sleeping while it is actively scanned. Works great for "in the mean while", but it sounds like you really want to have more control than just that.

 

http://wiki.covecube.com/StableBit_Scanner_Advanced_Settings

And the setting is "Scanner_RunningFile"

 

 

Regards

Share this post


Link to post
Share on other sites
  • 0

Great idea!   so I have tried to make it work....  i have changed the settings file:

 

 <setting name="Scanner_RunningFile" serializeAs="String">
                <value>true</value>

 

I have restarted the service and started a scan but I can't find the "Scanner_RunningFile" anywhere on the server.

 

What am I missing?

Share this post


Link to post
Share on other sites
  • 0

I have been reading this thread with interest as I also want the Lights-Out Addin to keep the server running whilst a scan is active.

As suggested above, I amended the settings file [ C:\Program Files (x86)\StableBit\Scanner\Scanner.Service.exe.config_default ] as follows:

 

            <setting name="Scanner_RunningFile" serializeAs="String">
                <value>C:\ProgramData\StableBit Scanner\RunningScan.txt<value />
            </setting>
 

I did this after stopping the service. I then restarted the server to be on the safe side.

 

The scanner (v. 2.4.0.2929) is now running scanning a disk as shown in the WHS2011 dashboard.

 

However, the RunningScan.txt file is not present in C:\ProgramData\StableBit Scanner folder.

Not sure what I have done wrong here?

Share this post


Link to post
Share on other sites
  • 0

Logbit, copy the config file to your desktop, edit it there, and then copy it back. 

Some times it does this. I believe it's an NTFS permission/security related issue, (as those can act funny some times). 

If that still doesn't work, I'll see about uploading a copy of the modified file.

Share this post


Link to post
Share on other sites
  • 0

Answering my own question - Yes is the answer! Thanks Doug :D

 

It works fine now, especially after I corrected my xml typo error <value /> = </value> (as originally posted by Drashna)

Not sure how I managed that but as I said it's working well now.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...