Jump to content
Covecube Inc.
  • 0
JulesTop

Frequent I/O Error - Cloud Drive xxxxx is having trouble downloading data from google drive

Question

Hi,

I get this error frequently... I'm not sure if it's because my cloud drive has been uploading for about 1.5 weeks so far and I am also downloading from it periodically for use with Plex... but I do get this error frequently enough. It seems to happen with all my cloud drives... I've detached and re-attached, but that doesn't seem to work... I suspect it might be my cache (SSD shared for all 4 cloud drives which is also being used for Windows OS), but I would like to have a way of making sure it's the SSD before I go out and by another one.

image.png.b234b02c82a7fb639cf7d21cf028e748.png

 

Thanks!

Share this post


Link to post
Share on other sites

15 answers to this question

Recommended Posts

  • 0

Those are generally network errors, not I/O errors in the traditional sense. Something is probably interfering with your connection to Google's servers. You'll need to troubleshoot the network connection. Logs might help to pin down exactly what is happening. 

Share this post


Link to post
Share on other sites
  • 0

More than likely, you're being throttled by Google, and this is causing issues. 

Try reducing the number of download threads for each drive.  Set it to 3-5, and see if that helps. 
Also, you may need to reduce the prefetch forward, if you do so. 

Share this post


Link to post
Share on other sites
  • 0

I have this problem too with GDrive. But the drive also disconnects often and very fast... Even when there is no download. Download threads are set to 4 and prefetch forward to 150MB.

Share this post


Link to post
Share on other sites
  • 0

I seem to still have this as well. I watched it happen yesterday where 1 thread seems to hang. I just see the thread count at 1 but nothing is downloading.

It caused my Plex stream to stop, which is why I went to look at it.

I adjusted my settings but didn't quite go as low as Christopher recommended as I was losing some performance. I may go that low now and see.

 

My settings are as follows right now.

DL threads: 7

UL threads: 5

Download size: 20MB

Prefetch Trigger: 10MB

Prefetch Forward: 250MB

Prefetch Time Window: 30sec

Share this post


Link to post
Share on other sites
  • 0

Hi,

Is it possible that someone can help diagnose this issue...

I have witnessed the problem occur a few times. What happens when I'm watching a movie or TV show via Kodi is it just stops playing... and then closes the stream.

 

When I watch the downloads, I usually see the threads is x1 but nothing is downloading... so the download hangs. (It doesn't seem to abort or retry fast enough)

When I go to the service log I see the following. (Not sure why the time is way off, not close to my PC clock time)

10:06:30.3: Warning: 0 : [IoManager:236] Error performing Read I/O operation on provider. Retrying. The read operation failed, see inner exception.
10:06:30.4: Warning: 0 : [IoManager:236] Error processing read request. Thread was being aborted.
10:06:30.4: Warning: 0 : [IoManager:236] Error in read thread. Thread was being aborted.

I then go to my Google Drive API Dashboard and see that everything seems OK on that front. (The issue occurred around 18:44 based on the last image)

image.thumb.png.974c0d4f1c8e1995311bd9d231029e7b.png

image.thumb.png.ec9d9f9b649e2722b72a588efa497f22.png

image.thumb.png.88495356219bb58fcf894adffe64a797.png

image.thumb.png.536fc290fde98fabac2f9e0265c6b158.png

Any help would be super duper appreciated!!!

Share this post


Link to post
Share on other sites
  • 0

Just an FYI, I enable Drive Tracer while this particular event happened in anticipation of it happening at some point.

I uploaded all the data via the troubleshooting tool and used this thread number (4398) as the ID.

It seems to happen every 1-2hrs of watching media.

Share this post


Link to post
Share on other sites
  • 0
On 6/2/2019 at 1:48 AM, JulesTop said:

Has anyone experienced this ... Or any ideas?

Has anyone seen these IO Errors... I get them a few times a day.

I've also started getting these. It's very annoying.

Share this post


Link to post
Share on other sites
  • 0

Started to get these recently too, not sure it's related to Google's outage yesterday (Sunday June 2) but after the data loss episode that happened a couple of months ago, I'm starting to lose faith in the whole thing. My drive keeps through mounting/unmounting cycles too.

Share this post


Link to post
Share on other sites
  • 0

Hi @Christopher (Drashna),

Are you able to comment or have Alex review my troubleshooting upload? I still get this issue daily... I have my own Client-ID, and I don't see errors on Google's end. I'm hoping that the logs, or information I uploaded can provide some answers. 

I'm really hoping to be able to set this and forget it. But I want to make sure it's stable.

Thanks,

Jules

Share this post


Link to post
Share on other sites
  • 0

Hi @Christopher (Drashna) and @Alex,

Just an FYI that I can easily reproduce this if it will help in troubleshooting.

I'm currently re-duplicating from one google drive to another as one of them went corrupt for some reason. (And I'm pretty sure I made it worst when I tried to recover it)

Since I'm re-duplicating, it is download from one google drive around 70Mbps 24/7, and uploading to the other. This results in a critical error every hour or two. These critical errors don't cause any dismounts or anything... but ideally they do get resolved.

If you'd like, I can turn on drive tracing again for a few hours and then upload from the troubleshooter again.

Let me know.

Thanks!

Share this post


Link to post
Share on other sites
  • 0

Google seems to have big problems at the moment. I still have problems too while downloading data from gdrive. For the last three days i didnt had a forced unmount, but i got a lot of red errors...

Today i saw a lot of "Service unaivable" errors in the log. I found a post from a german guy, who could be part of the problem (his own words). He forked rclone and made some changes for using multiple service accounts and bypassing quotas, so he could transfer with 14Gbit/s and he know others who made it faster... He also wrote about 503 errors and an overloaded google backend.

Share this post


Link to post
Share on other sites
  • 0
7 hours ago, schudtweb said:

Google seems to have big problems at the moment. I still have problems too while downloading data from gdrive. For the last three days i didnt had a forced unmount, but i got a lot of red errors...

Today i saw a lot of "Service unaivable" errors in the log. I found a post from a german guy, who could be part of the problem (his own words). He forked rclone and made some changes for using multiple service accounts and bypassing quotas, so he could transfer with 14Gbit/s and he know others who made it faster... He also wrote about 503 errors and an overloaded google backend.

I hope this doesn't result in google restricting accounts even further... or anything even more drastic from them.

Share this post


Link to post
Share on other sites
  • 0

So, it looks like my issue wasn't a clouddrive issue after all.

I seem to have had windows stability issues. I decided to clean install windows and restore the individual programs that I wanted to keep. The drive has been up for 24 hours without any errors.

Everything is normal now! :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...