Jump to content
Covecube Inc.
  • 0
FirstAidPoetry

Stablebit Scanner loses all settings on unexpected shutdowns.

Question

I know it makes sense to check drives after a dirty reboot/crash, but Scanner loses _all_ settings every time this happens.

Temperature overrides: Gone.
Surface scans get set to "Last scanned: Never"
Status: "not checked"
Drive specific Ignore Warnings: Gone.

I thought this might just be a bad install because it's happened numerous times, but I just set up a fresh install of Win 10 Pro x64, and it did the same thing again when my GPU driver tanked.

 

Share this post


Link to post
Share on other sites

16 answers to this question

Recommended Posts

  • 0

Yup, and we absolutely appreciate all the help finding this issue! 

Alex has pushed out a fix for this:

http://dl.covecube.com/ScannerWindows/beta/download/StableBit.Scanner_2.5.4.3246_BETA.exe

Specifically, the issue was:

Quote

.3246
* DiskIds were being updated too frequently (every second).
    - If your system crashed during a DiskId write, there was a chance that the DiskId file would get corrupted which 
      would lead to a settings loss for that disk (scan history, disk name / location, etc...).

Share this post


Link to post
Share on other sites
  • 1

Make sure that you're on the latest beta.  There are some fixes that should hopefully prevent this from happening in the future.

http://dl.covecube.com/ScannerWindows/beta/download/StableBit.Scanner_2.5.4.3220_BETA.exe

If it's still happening on that version, let us know. 

Share this post


Link to post
Share on other sites
  • 1

To keep everyone up-to-date:

With the help of Alex I've identified the root cause of the issue. The LastSeen variable inside the DiskId files is changed literally every second. This means that the DiskId files are constantly being changed and in the event of a crash there is a high chance that it crashes while the new file is being written thus the DiskId files get corrupted.

The LastSmartUpdate variable inside the SmartPersistentInfo files is updated in a more reasonable one minute interval so I'm hoping it is a quick fix to simply adjust the write interval of the LastSeen variable.

Besides changing the interval there would have to be backup diskid files to completely eliminate the issue. So instead of creating new DiskId files when corrupt files have been detected it should copy over an older backup file of the DiskId file(s) in question. Or the LastSeen value gets completely eliminated from the DiskId file and moved somewhere else to avoid changing the DiskId files at all.

Share this post


Link to post
Share on other sites
  • 0

What is really strange is this:
1. I had a few unexpected shutdowns (no UPS).
2. Scanner had forgotten everything about scan history, ignored SMART warnings etc.
3. I just swapped a backup HDD and of the now inserted backup HDD, Scanner does remember that its last scan was 13 days ago...

Share this post


Link to post
Share on other sites
  • 0
On 2/18/2019 at 9:01 PM, Christopher (Drashna) said:

Make sure that you're on the latest beta.  There are some fixes that should hopefully prevent this from happening in the future.

http://dl.covecube.com/ScannerWindows/beta/download/StableBit.Scanner_2.5.4.3220_BETA.exe

If it's still happening on that version, let us know. 

I'm on this exact version and unfortunately this Wednesday after a reboot all my drive scan status is once again gone. So far it has happened eight times to me (over a year so on many different versions). I can tell because all the old json files are still there under C:\ProgramData\StableBit Scanner\Service\Store\Json. For whatever reason the drives get completely new ids thus losing all their status.

Let me know what I can do to help troubleshoot this.

Share this post


Link to post
Share on other sites
  • 0
On 3/2/2019 at 8:27 AM, Wiidesire said:

I'm on this exact version and unfortunately this Wednesday after a reboot all my drive scan status is once again gone. So far it has happened eight times to me (over a year so on many different versions). I can tell because all the old json files are still there under C:\ProgramData\StableBit Scanner\Service\Store\Json. For whatever reason the drives get completely new ids thus losing all their status.

Let me know what I can do to help troubleshoot this.

Please open a ticket at https://stablebit.com/Contact

 

On 3/2/2019 at 8:38 AM, FirstAidPoetry said:

I''m also on this beta and while it now remembers the heat override setting for one of the drives, they're all back to believing they have never been scanned.

Please open a ticket at https://stablebit.com/Contact

Share this post


Link to post
Share on other sites
  • 0

I now have some more time and by chance Scanner lost all scan data again after a crash today.

I've opened ticket 7381541 and attached the full Service folder to help troubleshoot.

Share this post


Link to post
Share on other sites
  • 0

I just want to chip in and say, thank you guys! Thank you for taking the time and effort chasing down this bastard of a nuisance!

I just got a new server motherboard so my frequent crashes are history, but if I do crash I'll make sure to report how it works out!

Share this post


Link to post
Share on other sites
  • 0

Thanks, @Wiidesire!  Your discovery looks like it might solve the this CDIDW (constant Diskid write) root problem for a number of threads, including the ones I've enumerated below.

A useful new Scanner feature, now that the program has effective settings backup and restore, would be automatic backups, for example, weekly. That way, a backup that would more accurately reflect the scanned state of drives might exist when needed. (Manual backups are less likely to have been made within the last scheduled scan window; thus, even though disk names and other settings can be restored, scan history may be older causing new scans of all disks.)

https://community.covecube.com/index.php?/topic/3831-scanner-lost-all-data/

https://community.covecube.com/index.php?/topic/4099-stablebit-scanner-loses-all-settings-on-unexpected-shutdowns/

https://community.covecube.com/index.php?/topic/4265-scanner-2543216-upgrade-loses-my-setups/

https://community.covecube.com/index.php?/topic/3707-bug-prior-scan-data-and-settings-not-preserved-on-update/

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...