Jump to content
Covecube Inc.
  • 0
cocksy_boy

Scanner UI Frozen / Crashed WHS 2011

Question

Hi All,

I installed Scanner to check my drives on my WHS last night and set it off when i went to bed. This morning I RDP'd in and its completed a couple of drives and has a few more to go, however the UI appears to have completely frozen / crashed. The Server is still functioning OK, but none of the buttons / interface / scanner screen seems to do anything, and I can't minimise / maximise / close the window. Looking at Task Manager, it says the scanner is "running" and not crashed / not responding.  Looking at resource monitor, Scanner.Service.exe is doing lots of disk reads so appears to be going OK, but I can't do anything in the interface / window at all. Any ideas?

It's probably worth mentioning that WHS is running in a VM on ESXi, and some of the drives are passed though and some are virtual drives. Some of the drives scanned are virtual (so pointless to scan), and some are passed through. The reason I want to use the interface and stop the scan is to stop scanning the virtual drives, and tell it to only scan the actual physical drives that are passed through!

Share this post


Link to post
Share on other sites

20 answers to this question

Recommended Posts

  • 0

Know nothing about VMs bit could you simply reboot WHS? Scanner will be closed and resume where it left after boot ( it may say 0% but thatiis because Scanner expresses as part to be done when restarted. You can look at the disks' map to see this).

Share this post


Link to post
Share on other sites
  • 0

Same thing mine is doing.  To clarify - you mean the DASHBOARD GUI is frozen right?  Mine finally finished the 2 x 4TB drives it was scanning.  The Resource monitor now shows the 2 Scanner.service.exe items actively scanning 2 different disks - but the Dashboard is still stuck where it's been since Friday night.

Note: I'm logging into the desktop on the server directly - and all else is working fine - IE: WHS is not locked up.  I was able to watch a few movies last night w/o any issues as well - so I'm going to let it run.  I'm wondering if I kill the Dashboard in task manager - and start that program again, if it will then show the status updated in the Scanner tab?

Share this post


Link to post
Share on other sites
  • 0

I would suggest, again, a reboot.

I am pretty sure you can kill the Scanner GUI through task manager. Scanning is a background process run by a service and should continue (check with ResMon). Then restatrt the Gui. My guess is it will be responsive.

Share this post


Link to post
Share on other sites
  • 0
15 hours ago, Umfriend said:

Know nothing about VMs bit could you simply reboot WHS? Scanner will be closed and resume where it left after boot ( it may say 0% but thatiis because Scanner expresses as part to be done when restarted. You can look at the disks' map to see this).

yeah - i ended up rebooting and it all seemed fine afterwards - it showed that all the discs had been scanned, so not sure what caused the GUI to crash.

Share this post


Link to post
Share on other sites
  • 0
14 hours ago, puulima said:

Same thing mine is doing.  To clarify - you mean the DASHBOARD GUI is frozen right?  Mine finally finished the 2 x 4TB drives it was scanning.  The Resource monitor now shows the 2 Scanner.service.exe items actively scanning 2 different disks - but the Dashboard is still stuck where it's been since Friday night.

Note: I'm logging into the desktop on the server directly - and all else is working fine - IE: WHS is not locked up.  I was able to watch a few movies last night w/o any issues as well - so I'm going to let it run.  I'm wondering if I kill the Dashboard in task manager - and start that program again, if it will then show the status updated in the Scanner tab?

yeah - that's exactly how mine was. After a reboot, it seems absolutely fine - I didn't kill the scanner dashboard in task manager, I just rebooted the WHS.

Share this post


Link to post
Share on other sites
  • 0

Odly, the UI on the stand alone app has crashed again in WHS 2011. However, if I go to the WHS dashboard, the UI screen is duplicated in one of the tabs, and it works correctly there, with no issues at all. I wonder if there is some kind of issue with the WHS "server" dashboard, and the main UI for the app?

Share this post


Link to post
Share on other sites
  • 0
19 hours ago, Christopher (Drashna) said:

Are you using 2.5.6.3336 for StableBit Scanner? 

If not, please install this version.   If you are, could you run the StableBit Troubleshooter on the system in question?
https://wiki.covecube.com/StableBit_Troubleshooter

Hi @Christopher (Drashna), yeah its version 2.5.6.3336. I've done it and added the hyperlink to this thread as the request link / ID.

Share this post


Link to post
Share on other sites
  • 0
On 4/24/2020 at 6:26 PM, Christopher (Drashna) said:

Are you using 2.5.6.3336 for StableBit Scanner? 

If not, please install this version.   If you are, could you run the StableBit Troubleshooter on the system in question?
https://wiki.covecube.com/StableBit_Troubleshooter

My scanner is 2.5.3062 and in the Addons tab of WHS 2011 it notes "Update Available".  So do I just download and install the latest?    Also - in the Addons tab - it notes DrivePool has an update.  I'm still on 1.2.7226 and have been operating on the "if it ain't broke, don't fix it" theme.  Should I be updating it?  If so, should I be sticking with version 1?  Would like to read up/understand what the pros/cons are of updating to version 2 - and is that even possible licensing wise?  Much thanks

Share this post


Link to post
Share on other sites
  • 0

Latest release of StableBit Scanner is 2.5.6.3336.  Though, you may have to uninstall your current version and install the new one directly on the server. 

For StableBit DrivePool, yes, we do recommend upgrading to the 2.x version, and yes, the license is valid for the new version.  However, you'd need to uninstall the 1.x version, reboot and then install the 2.x version. 

As for pros and cons, the 1.x version hasn't been updated in a long while, since WHS2011 left mainstream support.  So, the 2.x version is much more up to date, and includes a number of newer features.
However, the 2.x version isn't integrated as tightly into WHS2011, though it still has a dashboard tab. 

Share this post


Link to post
Share on other sites
  • 0
12 hours ago, Christopher (Drashna) said:

Latest release of StableBit Scanner is 2.5.6.3336.  Though, you may have to uninstall your current version and install the new one directly on the server. 

For StableBit DrivePool, yes, we do recommend upgrading to the 2.x version, and yes, the license is valid for the new version.  However, you'd need to uninstall the 1.x version, reboot and then install the 2.x version. 

As for pros and cons, the 1.x version hasn't been updated in a long while, since WHS2011 left mainstream support.  So, the 2.x version is much more up to date, and includes a number of newer features.
However, the 2.x version isn't integrated as tightly into WHS2011, though it still has a dashboard tab. 

Ok.  So no issues uninstalling the existing for each, then installing the new versions sounds like?  So do both the new versions have "stand alone" programs to run for managing/viewing vs. the current integrated Dashboard tabs?  Anything else I need to know before doing these "upgrades"?  Thanks much.

Share this post


Link to post
Share on other sites
  • 0
22 hours ago, Christopher (Drashna) said:

Both versions have a stand alone version, yeah.  And if installed on a system that has the Dashboard, will install a tab for the dashboard.  So you can access the UI in either way. 

 

I also have the DrivePool Plug-in: Disk Space Equalizer (version 1.04) - assuming I should uninstall that also?  Should that be uninstalled first or does it matter?   And just realized it looks like I can unistall both DrivePool, the space equalizer & Scanner - all from within the WHS 2011 Dashboard (remove the add-ins) OR from the standard Windows programs/features - does it matter where I do the uninstall?

And I'm searching for this so might find it before you respond - but where/how to do I locate my license numbers?  Since I'm uninstalling the old ones, sounds like I'll need to re-enter the licenses once the new versions are installed.  I'm assuming I may have them in an archived email somewhere...or can I submit a formal request to have them resent to me?

Huge thanks!

Share this post


Link to post
Share on other sites
  • 0

Yeah, you will want to uninstall that too, and ideally first. 

And it does matter, Uninstall them from the Dashboard, or it won't remove the entries from there. 

 

For the Activation ID:

  • StableBit DrivePool 2.X/Stablebit CloudDrive: Open the UI on the system that the software is installed on, click on the "Gear" icon in the top, right corner and select the "manage license" option.
  • StableBit Scanner: Open the UI on the system that Scanner is installed on. Click on "Settings" and select "Scanner Settings". Open the "Licensing" tab, and click on the "Manage license" link.

This will open a window that shows you the Activation ID, as well as a big button to "Deactivate" the license. 

 

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, Christopher (Drashna) said:

Yeah, you will want to uninstall that too, and ideally first. 

And it does matter, Uninstall them from the Dashboard, or it won't remove the entries from there. 

 

For the Activation ID:

  • StableBit DrivePool 2.X/Stablebit CloudDrive: Open the UI on the system that the software is installed on, click on the "Gear" icon in the top, right corner and select the "manage license" option.
  • StableBit Scanner: Open the UI on the system that Scanner is installed on. Click on "Settings" and select "Scanner Settings". Open the "Licensing" tab, and click on the "Manage license" link.

This will open a window that shows you the Activation ID, as well as a big button to "Deactivate" the license. 

 

ok, found the "manage license" areas in the WHS 2011 Dashboard - but both are the exact same license code?  Does that make sense?  I see the Deactivate buttons in each - but it notes "it must be deactivated before using on a new PC - but I'm planning to install the latest (including the 1.x to 2.x upgrade for DP) on the same WHS 2011 PC - so I read somewhere that the new installations should "see" the existing licenses? Or maybe I misread.  If I have to re-enter, doesn't look like there's a way to copy/save to a text file...not a huge deal - but more concerned as the license code is the same for both?

 

UPDATE: I dug up the original emails for the purchase of DrivePool & Scanner - the License/Activation codes are indeed different.  DrivePool was in 2014, Scanner in 2017 - it's the license/activation code for the SCANNER that shows up for BOTH the Scanner & DrivePool when I make my way into the "Manage License" areas in the WHS 2011 Dashboard.  I can click the deactivate button for each, but assuming I should go back to the ORIGINAL license code for Drivepool when I reinstall?  Weird...

Share this post


Link to post
Share on other sites
  • 0
On 4/29/2020 at 5:10 PM, Christopher (Drashna) said:

Yeah, you will want to uninstall that too, and ideally first. 

And it does matter, Uninstall them from the Dashboard, or it won't remove the entries from there. 

 

For the Activation ID:

  • StableBit DrivePool 2.X/Stablebit CloudDrive: Open the UI on the system that the software is installed on, click on the "Gear" icon in the top, right corner and select the "manage license" option.
  • StableBit Scanner: Open the UI on the system that Scanner is installed on. Click on "Settings" and select "Scanner Settings". Open the "Licensing" tab, and click on the "Manage license" link.

This will open a window that shows you the Activation ID, as well as a big button to "Deactivate" the license. 

 

Any feedback on my last questions re: license number?

Share this post


Link to post
Share on other sites
  • 0

I'm going to go ahead and to the uninstall - new installs later today likely.  I'll use the 2 unique activation codes...and see what happens.  I'm thinking somehow they got bundled together when I added Scanner - but guessing the code is NOT the same for both.  Thanks for the feedback on what/how to do the uninstall.  

Share this post


Link to post
Share on other sites
  • 0
On 4/29/2020 at 3:00 PM, puulima said:

ok, found the "manage license" areas in the WHS 2011 Dashboard - but both are the exact same license code?  Does that make sense? 

Yup.  You can have multiple products and multiple licenses of each product attached to a single Activation ID. 

On 4/29/2020 at 3:00 PM, puulima said:

but it notes "it must be deactivated before using on a new PC - but I'm planning to install the latest (including the 1.x to 2.x upgrade for DP) on the same WHS 2011 PC - so I read somewhere that the new installations should "see" the existing licenses? Or maybe I misread.  If I have to re-enter, doesn't look like there's a way to copy/save to a text file...not a huge deal - but more concerned as the license code is the same for both?

If it's the same installation, then it should, yes.  But just in case, you can deactivated it.  Either option is fine. 

As for the license, if you want a copy of it, open a ticket at https://stablebit.com/Contact and we can send the Order Completion email to you. 

On 4/29/2020 at 3:00 PM, puulima said:

UPDATE: I dug up the original emails for the purchase of DrivePool & Scanner - the License/Activation codes are indeed different.  DrivePool was in 2014, Scanner in 2017 - it's the license/activation code for the SCANNER that shows up for BOTH the Scanner & DrivePool when I make my way into the "Manage License" areas in the WHS 2011 Dashboard.  I can click the deactivate button for each, but assuming I should go back to the ORIGINAL license code for Drivepool when I reinstall?  Weird...

This can happen too,  Either way is fine. Though it may be simpler to have the same Activation ID on the same hardware, just from a management point of view. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...