Jump to content
Covecube Inc.
  • 0
Kevin Bree

Windows 10 update - hard drives in pool disappeared from Drivepool.

Question

My PC did a Windows 10 update today and now my Z drive (Pool) and all the hard drives that were in the pool have disappeared from Drivepool.

All the drives are showing in File Manager. The boot drive C: and 2 non-pooled drives I: and D: are showing in Drivepool.  As I said none of the pool drives F: G: H: and K: are listed in Drivepool...

I have the latest Version 2.2.3.950 Beta version of Drivepool. I downloaded it again and selected "REPAIR" but no change.  I am unsure what I should do to restore the system.

The Service Log:
0:00:21.1: Information: 0 : [Main] StableBit DrivePool 2.2.3.950
0:00:21.1: Information: 0 : [Main] Microsoft Windows NT 10.0.18362.0
0:00:21.2: Information: 0 : [Main] Loading settings...
0:00:21.2: Information: 0 : [Main] Checking StableBit CloudDrive start status...
0:00:21.2: Information: 0 : [Main] Not waiting for the StableBit CloudDrive system service. Service CloudDriveService was not found on computer '.'.
0:00:21.2: Information: 0 : [Main] Loading lifetime statistics...
0:00:21.2: Information: 0 : [Main] Starting remote control...
0:00:21.2: Information: 0 : [Main] Starting running file...
0:00:21.2: Information: 0 : [Main] Starting user feedback...
0:00:21.2: Information: 0 : [Main] Starting root tasks...
0:00:21.2: Information: 0 : [Main] Enumerating disks...
0:00:21.2: Information: 0 : [Disks] Updating disks / volumes...
0:00:21.4: Information: 0 : [Main] Starting disk metadata...
0:00:21.5: Information: 0 : [Main] Starting CoveFs...
0:00:21.6: Information: 0 : [CoveFs] Waiting for pools to mount...
0:01:21.6: Warning: 0 : [CoveFs] Timed out waiting for all pools to finish mounting. Continuing startup...
0:01:21.6: Information: 0 : [CoveFs] Waiting for pool parts to arrive...
0:01:21.7: Information: 0 : [CoveFs] All known pool parts have arrived. Continuing startup...
0:01:21.7: Information: 0 : [Disks] Updating disks / volumes...
0:01:22.5: Information: 0 : [Main] Updating free space...
0:01:22.5: Information: 0 : [Main] Starting notifications...
0:01:22.6: Information: 0 : [Main] Starting performance samplers...
0:01:22.6: Information: 0 : [Main] Starting notification tasks...
0:01:22.6: Information: 0 : [Main] Service started.

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

My two pools have also disappeared strangely. My drives are still there but just my two pool drives are now gone. Tried the reset setting option in troubleshooting and that did nothing. 

 

Tried doing the repair which OP did and got the following errors: 

Quote

2EC4:2EA8][2019-07-03T23:43:30]i323: Registering package dependency provider: {43053F4F-87D0-4459-A600-03896AC6F486}, version: 2.2.950, package: DrivePoolApplication
[2EC4:2EA8][2019-07-03T23:43:30]i301: Applying execute package: DrivePoolApplication, action: Repair, path: C:\ProgramData\Package Cache\{43053F4F-87D0-4459-A600-03896AC6F486}v2.2.950\StableBit.DrivePool.msi, arguments: ' ARPSYSTEMCOMPONENT="1" MSIFASTINSTALL="7" LAUNCHUI="1" INSTALLLOCATION="C:\Program Files\StableBit\DrivePool\"'
[2EC4:2EA8][2019-07-03T23:43:41]e000: Error 0x80070643: Failed to run maintanance mode for MSI package.
[2EC4:2EA8][2019-07-03T23:43:41]e000: Error 0x80070643: Failed to execute MSI package.
[3734:370C][2019-07-03T23:43:41]e000: Error 0x80070643: Failed to configure per-machine MSI package.
[3734:370C][2019-07-03T23:43:41]i319: Applied execute package: DrivePoolApplication, result: 0x80070643, restart: None
[3734:370C][2019-07-03T23:43:41]e000: Error 0x80070643: Failed to execute MSI package.

Restarted and still got the same message. 

I am unsure whether I had a recent Windows update or not but it could very well be the case. 

 

Also looked at the installation option in the wiki, however the covecube disk eumlater and covecube disk device is no where to be seen in device manager. 

Share this post


Link to post
Share on other sites
  • 0

Thanks for that.

When I checked Stablebit Scanner it said that the disks had never been scanned. (Of course they had been checked regularly)

I decided to do do a scan of all drives and its still in progress so I'll do as you suggest when that's finished. 

Thanks again.

Share this post


Link to post
Share on other sites
  • 0

Yeah, it was likely the upgrade that caused this, due to issues with the driver. 

As for StableBit Scanner, there is a know issue with that happening.  We would recommend installing the latest beta version:
http://dl.covecube.com/ScannerWindows/beta/download/StableBit.Scanner_2.5.4.3259_BETA.exe

Share this post


Link to post
Share on other sites
  • 0

I have been experienced this same issue for the last couple of days. All the drives are missing.

 

Is there a fix? Since this is the second time of this week it happened.

Share this post


Link to post
Share on other sites
  • 0

The fix is, as suggested by Chimera is:

Uninstall Drivepool, reboot and re-install Drivepool. 

I previously had a Beta version installed but replaced it with the Stable version just to be sure.

That fixed it for me. 

Good luck, Kevin

Share this post


Link to post
Share on other sites
  • 0

First time, a few days ago, Uninstall Drivepool, reboot and re-install Drivepool worked.

Now, the same sequence does not work anymore as I tried multiple times. Chris mentioned Windows upgrade might have caused issues with the driver. My pool has 28 drives and it shows:

image.thumb.png.76f6ed0ad6b8602dc2258614e2b55525.png

 

I need some helps ASAP please...

Thanks

 

Share this post


Link to post
Share on other sites
  • 0

Okay folks, I believe I have solved my own issue.

Apparently since all of my pool drives have no letters and whatever latest Windows updates may have caused all the drives to dismounted. My many attempts to uninstalled/reinstalled Drivepool could not bring the pool drives back. The way to fix my issue of missing drives is:

- Diskpart

- Enable Automount

- Reboot

All the drives magically came back YAY!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...