Jump to content
Covecube Inc.
Spider99

M.2 Drives - No Smart data - NVME and Sata

Recommended Posts

With the latest Scanner update i was looking forward to seeing SMART data for my NVME drives and my M.2 Sata card - but no luck

Both NVME drives are Samsung 950Pro's the Sata is a WD Blue 1TB M.2 drive

The 950's have no SMART/NVME details option in the UI only Disk details, Disk Control, Disk Settings and NO temp data

The WD has Smart details but has virtually no info but does show temp data in the main UI

Capture1a.thumb.JPG.be1f128bd30853a90e10793213391b07.JPG

Both Samsung Magician and CrystalDiskInfo see all three drives and can read the Smart data/temp data

This is on 2012r2 and Scanner 3190

For Info - on my win10 machine Scanner 3190 can read a 950 Pro's Smart Data fine

 

Any suggestions?

Share this post


Link to post
Share on other sites

Just because it's M.2 doesn't mean that it's NVMe, unfortunately. And it sounds like that's the case with the WD drive. It's probably running on AHCI still. 

 

Looking at BitFlock, yeah, the WDC WDS100T2B0B-00YS70 drive (your WDC shows up as SATA, which means it's using AHCI, not NVMe. 
if you could use the DirectIO Test tool to see if it gets any SMART data from any of the methods? 

And yeah, it's SATA, not NVMe. :(
https://www.wdc.com/products/internal-ssd/wd-blue-3d-nand-sata-ssd.html#WDS250G2B0B

 

But yeah, the Samsungs just aren't getting NVMe health info (not SMART).  Not sure why

Ah, they are NVMe 1.1, not 1.3 (which is what we support.  

https://www.samsung.com/uk/memory-storage/950-pro-nvme-m-2-ssd/MZ-V5P512BW/#specs

 

I've flagged the issues regardless:
https://stablebit.com/Admin/IssueAnalysis/27872

Share this post


Link to post
Share on other sites

Chris

I think you miss read my post

"Just because it's M.2 doesn't mean that it's NVMe, unfortunately. And it sounds like that's the case with the WD drive. It's probably running on AHCI still. "

Thats why i stated its a SATA drive and as an ACHI device should be readable for SMART - never said the WD was a NVME drive.

"Ah, they are NVMe 1.1, not 1.3 (which is what we support. "

Well you do support 1.1 or the 950 on my win 10 machine would not show NVME Health info etc data as i posted

So why does it work on one machine and not the other for the 950's?

Share this post


Link to post
Share on other sites

Sorry, I missed that.  It's been super hot here, and I don't deal well with the heat.  I'll try to make sure I'm better.

Also, I did pass this information on to Alex.  The NVMe 1.1 may or may not be the issue.  Eg, we may want/need to implement it as well, or it may be a red herring. 

As for the SATA based one, if you use the DirectIO Test tool, see if any of those actually get the SMART Attributes for the drive:

 

Share this post


Link to post
Share on other sites

Okay, the NVMe spec is a red herring.  It supports "up to" 1.3 (and 1.4, actually).  So it should be getting the info.

Alex is updating our tools to work with NVMe, and so that the StableBit Troubleshooter will actually run it's own version of the DirectIO Test and log that information, as well. 

This way, we can get to the bottom of this issue and get it working. 

I will update you when I have more information for you.

Share this post


Link to post
Share on other sites
On 7/8/2018 at 4:01 PM, Spider99 said:

With the latest Scanner update i was looking forward to seeing SMART data for my NVME drives and my M.2 Sata card - but no luck

Both NVME drives are Samsung 950Pro's the Sata is a WD Blue 1TB M.2 drive

The 950's have no SMART/NVME details option in the UI only Disk details, Disk Control, Disk Settings and NO temp data

The WD has Smart details but has virtually no info but does show temp data in the main UI

Capture1a.thumb.JPG.be1f128bd30853a90e10793213391b07.JPG

Both Samsung Magician and CrystalDiskInfo see all three drives and can read the Smart data/temp data

This is on 2012r2 and Scanner 3190

For Info - on my win10 machine Scanner 3190 can read a 950 Pro's Smart Data fine

 

Any suggestions?

As per your issue, I've obtained a similar WD M.2 drive and did some testing with it. Starting with build 3193 StableBit Scanner should be able to get SMART data from your M.2 WD SATA drive. I've also added SMART interpretation rules to BitFlock for these drives as well.

You can get the latest development BETAs here: http://dl.covecube.com/ScannerWindows/beta/download/

As for Windows Server 2012 R2 and NVMe, currently, NVMe support in the StableBit Scanner requires Windows 10 or Windows Server 2016.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×