Jump to content
Covecube Inc.
  • 0
disposablereviewer

VM Windows 7 drives no longer appearing in DP 'non-pooled' list

Question

Before I start, let me say that I did my best due diligence and read through and utilized these three related forum posts but none of them helped me resolve my issues:

 

http://community.covecube.com/index.php?/topic/92-some-drives-not-recognized-by-drivepool/

http://community.covecube.com/index.php?/topic/1061-some-external-usb30-drives-not-recognized-by-drivepool/

http://community.covecube.com/index.php?/topic/1112-usb-hdds-no-longer-showing-in-drivepool-ui/

 

 

I am running the trial and doing extensive testing in a virtual machine before spending the money on a license for the DP software.  I initially had no issues getting set up and running and it was a smooth process.  However, I started playing around removing drives, deleting and re-adding vdi's in virtualbox, etc and now I am having issues with drivepool.

 

 

Here is my current state after trying everything else I could think of including the suggestions from the above threads.  My attempt here was to start with a clean slate:

 

1. I removed all drives in DP.

2. I uninstalled DP completely including deleting the associated appdata and programdata folders for DP.  I also searched the entire registry and removed any references to DP or stablebit.

3. rebooted.

4. ran DISKPART clean on all test vdi drives to wipe them clean and not initialized.

5. shutdown.

6. In virtualbox, I removed all the vdi drives and deleted them completely off the host machine.

7. booted up, verified all the drives are gone, shutdown.

8. In virtualbox, I added all new vdi drives with new names/IDs to my virtual machine similar in size to what I did originally when things worked the first time.

9. booted up, computer management, storage, initialized all drives as GPT (note that I did all these steps with the drives MBR and had same results).

10. installed the latest beta of DP (I've gone through this whole process several times and did this all with the stable version as well, but had same results).

11. loaded up DP with the computer management in background (screenshot 1.jpg).  Note that there are 7 "VBOX HARDDISK" options to choose from in non-pooled.

12. clicked add on the first "VBOX HARDDISK" in list (screenshot 2.jpg). New drive E created, new "drivepool" G created as expected.

13. click to remove E from pool (screenshot 3.jpg)

14. After removal, drive E no longer appears in the non-pooled list of drives as expected and there's 1 fewer drive to select from (6 instead of 7) (screenshot 4.jpg).  I cannot get drives to reappear in DP one they've been formatted and are available for use in the O/S.

15. Use computer management to reformat E as "M" and format all the other drives "G" through "L."  (screenshot 5.jpg).  The only drive that appears in the non-pool list is L and all the others are still missing.

 

 

Additional thoughts:

- The first time through when it worked for me I was only using 6 drives instead of 7.  It could be that L is only appearing because it's the 7th drive and therefore "new" to DP.

- The first time through, I gave the drives a letter and everything worked.  I removed them all and decided to use mount links instead to hide the drives in 'My Computer'.  This also worked without an issue.

- The problem may have come from the fact that I was reformatting, reinitializing, DISKPART cleaning, deleting and readding vdi's in virtualbox, etc without removing drives from DP pools first.  I did receive some missing drive errors before doing the above clean slate steps above.

 

 

Other things I've tried:

1. DISKPART cleaning and uniqueid of the drives.

2. Using mount links instead of drive letters.

3. Reset all settings in DP.

4. Nuking all drives from Virtualbox and adding new ones.

 

 

Obviously something is funky/buggy with DP here since the drives all work just fine within windows after formatted.  I am doing this testing in a VM specifically to try to break it or find issues.  I don't know if it's only a virtual machine issue, but this isn't filling me with a lot of confidence for use with my real data and drives on my main box.  I obviously won't be able to even do most of the steps above with real data without losing everything.

 

I have attached a log that I ran while doing some of the above (no errors so not sure how helpful that will be).

 

I have a drivepoolservice.dmp as per the suggestion in another thread, but apparently it's huge so I can't upload here...

I will try to upload it using this link:  https://stablebit.com/contact

EDIT:  The dumpfile zipped with 7z is still over 50MB and the filesize limit on the contact page is 10MB.  Not much I can do.

post-3974-0-14900100-1486065064_thumb.jpg

post-3974-0-91761500-1486065066_thumb.jpg

post-3974-0-73342900-1486065069_thumb.jpg

post-3974-0-94721000-1486065076_thumb.jpg

post-3974-0-89475800-1486065082_thumb.jpg

DrivePool.Service-2017-02-02.log

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Hi

 

have you tried re creating the VM

 

99.99% its a VB issue with DP - not seen this in real world

 

try it with some real disks - i guess you can pass thru in VB?

Share this post


Link to post
Share on other sites
  • 0

Share this post


Link to post
Share on other sites
  • 0

Sorry to bring this thread up from the stone age but I found it while trying to figure out the same problem I had.

What you want to do is close StableBit and run DISKPART

Then type LIST DISK

Then type SELECT DISK (choose a  disk number but dont end up selecting anything with important data because you will erase it)

Then type CLEAN

Then open StableBit again.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...