Jump to content
Covecube Inc.
  • 0

Some drives not recognized by DrivePool


Question

So I decided to do some more testing of DrivePool again in a Windows 7 VM and I noticed an issue.

 

My Windows 7 VM has 5 virtual disks attached (in addition to the boot drive).

Each drive is formatted as basic disk containing a single NTFS volume (partition).

 

I installed the latest 2.0 beta and the first issue I noticed is that not all drives are recognized by DrivePool in the "non-pool" section.

Only three out of five of my hard drives in Windows 7 VM are recognized so there are two drives which I cannot add to a pool.

 

In my attempt trying to resolve the issue, I reformatted all the drives using Computer Admin tool, re-assigned drive letters and even rebooted my Windows 7 VM several times but DrivePool would only recognize three out of five drives.

All five drives are accessible via Windows Explorer and CMD console so I don't know why DrivePool don't see all of them.

 

Finally, I decided to DELETE partitions on those two drives not recognized by DrviePool and RE-CREATE new NTFS volumes.

And THAT finally solved the issue.

 

However, this solution is not feasible in a production environment.

(I would need to backup data and re-create partitions).

 

Does anyone know what would prevent DrivePool from seeing all formatted NTFS volumes?

 

Does anyone ever have such issue in production environment running DrivePool?

 

Thanks.

Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

That's definitely not a normal thing.

If all the disks were definitely basic, NTFS disks, that shouldn't happen.

 

I use HyperV for testing, and have a bunch of different VMs with DrivePool and haven't seen that.

What virtualization software are you using?

 

 

Also, since I'm assuming your using DrivePool 2.x, could you do this:

http://wiki.covecube.com/StableBit_DrivePool_2.x_Error_Reports

And submit the error to http://stablebit.com/Contact/

Link to post
Share on other sites
  • 0

The Error Reports instruction said I'm supposed to zip the content of "C:\ProgramData\StableBit DrivePool\Service\ErrorReports" and send it to the the support contact but that folder is empty on my test system.  However, I do see some log files in "C:\ProgramData\StableBit DrivePool\Service\Logs\Service" directory so I attached the log file from the day this error occurred and submitted the issue to the support contact.

Link to post
Share on other sites
  • 0

Okay.  This problem has occured again.

 

Here are what I have done since last time I reported the problem.

1) I uninstalled DrivePool trial a few weeks ago in my Windows 7 virtual machine.

2) Today I downloaded and installed the latest DrivePool trial version (StableBit.DrivePool_2.0.0.345_x64_BETA.exe)

3) Upon launching DrivePool, I noticed none of those drives which I used successfully with the prior DrivePool installation shows up on the non-pool disk list.

 

I did more testing and here is what I noticed.

 

Tasks which were unsuccessful to make or re-create volume recognizable by DrivePool.

1) If  I simply reformat (quick format) the volume on those drives using Disk Management, the disk is still NOT recognized by DrivePool.

2) If I delete the existing NTFS volume and create a new NTFS volume, the disk is still NOT recognized by DrivePool.

(Unlike last time I reported the problem, deleting and then re-creating an NTFS volume did not make DrivePool recognize the disk).

 

Tasks which were successful DrivePool will recognize the disk volume re-created.

1) If I use DISKPART command line tool to "CLEAN" a disk and the proceed to initialize the disk (choosing GPT) and create a new NTFS volume, Drive pool will show the disk volume in the non-pool list.

2) If I use DISKPART command line tool and use the UNIQUEID option to change the GUID of an existing disk and then re-create an NTFS volume and also using DISKPART RESCAN option, the disk volume immediately showed up on the non-pool disk list.   (Note: I don't remember exactly the detail of what I did in this second step so some detail may have been left out).

 

So eventually I was able to make all; disk volumes recognizable again to DrivePool again but these solutions all means loss of existing data because new NTFS volume need to be created.

 

I'm wondering what is the criteria for a disk volume to show up on DrivePool's list?

 

If I can see disk volumes listed Disk Management GUI or using DISKPART command, I would assume those disks should also show up on DrivePool's list.

 

It seems to me there must be some kind of metadata (such as GUID) on the disk or volume which was used by the prior DrivePool installation and some how prevented the new installation of DrivePool from recognizing those same disk drives.

 

I have not submitted any support ticket yet since I don't have any log files to show.

(I don't see any logs or error reports in "C:\ProgramData\StableBit DrivePool\Service" folder showing anything strange).

 

May be this problem only occurs in a VM environment?   (I Win 7 VM is running using VMPlayer).

Link to post
Share on other sites
  • 0

Saiyan,

 

Thanks for going to all the trouble to track down the issue.  

DrivePool does use the uniqueID to track the disk, IIRC.  

 

I'm flagging this for alex, to let him know about it. (though, yes this could be an issue with VMPlayer, but I'm not sure about that).

Link to post
Share on other sites
  • 0

DrivePool does use the uniqueID to track the disk, IIRC.  

 

Drashna,

 

I think using uniqueID to track hard drives may be partially responsible for this problem.

 

I did few more tests and here is what I noticed.

 

Test #1:

1) Install DrivePool and add hard drives to a pool normally.

2) Uninstall DrvevPool without removing hard drives from the pool.

3) Don't do anything to the hard drives.  (e.g don't reformat or delete hidden pool directories).

4) Re-install DrivePool

 

After re-installing DrivePool I see existing hard drives automatically show up in the same pool I created in the previous installation. And because existing hard drives are already part of a pool, they are not listed under the list of non-pool hard drives.   This is good and I guess this is the result of tracking uniqueID of hard drives.

 

 

Test #2:

1) Install DrivePool and add hard drives to a pool normally.

2) Uninstall DrvevPool without removing hard drives from the pool.

3) REFORMAT existing partitions on the hard drives (without deleting partition or clean hard drive).

4) Re-install DrivePool.

 

After re-installing DrviePool, I do not see the pool I created previously.  This makes sense because because I reformatted those hard drives.  However, those hard drives also do not show up under the non-pool disk list.  

 

I guess this is where tracking uniqueID is causing the problem.  Most likely DrivePool still think those hard drives still belong to a pool based on the uniqueIDs and therefore don't show them under the non-pool list.  But because those hard drives have been reformatted (or the hidden pool directory are deleted), they don't show up on any pool either.

 

Now that I think I know what is happening, I don't think this is a big problem. 

If I want to reformat a hard drive previously used in a pool, I will just need to remember to "clean" the disk, re-initialize and create new partitions or be sure to remove hard drives from a pool first.

Link to post
Share on other sites
  • 0

Yes.  Clearing DrivePools settings worked.

 

I just stopped the DrivePool service first, delete content of "C:\ProgramData\StableBit DrivePool" directory and restarted Drvive pool services.

Afterward when I re-open DrivePool dash board, all my hard drives showed up under non-pool disks.

 

Thanks.

Link to post
Share on other sites
  • 0

I had this same issue. I changed the partition size of one of my SSD disks, and then DrivePool thought it was another DrivePool disk (i.e. I had two drive pools showing). I formatted the SSD partition and restarted Windows, which stopped the disk showing as a drive pool, but I could not get it to appear in "Non-pooled".

But after clearing the settings it appeared again, and i was able to add it back to the DrivePool.

Thanks

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...