Jump to content
Covecube Inc.
  • 0
jjbrunton

Google Drive uploads/downloads stopping completely

Question

First off - thanks for an amazing piece of software, it's great to be able to upload encrypted stuff to Google Drive like a real hard drive. Fantastic.

 

I am having an issue at the moment where Cloud Drive stops after a while of uploading and just sits with no activity permanently until I restart the machine. It still has data in the 'To Upload' part of the storage but nothing happens, no uploads.

 

I am on build 597.

Share this post


Link to post
Share on other sites

14 answers to this question

Recommended Posts

  • 0

It looks like it is being limited on rate. Essentially it sometimes just sits with things waiting to be uploaded for a long time.

 

I've uploaded logs through the Wiki, let me know if you need any more info.

Share this post


Link to post
Share on other sites
  • 0
9:40:00.7: Warning: 0 : [IoManager:17] Error writing range: Offset=523,648,368,640. Length=10,485,760. Thread was being aborted..
9:40:00.7: Information: 0 : [IoManager:17] [W]   Offset:0x00000079F8600000 Length:10,485,760
9:40:02.3: Warning: 0 : [IoManager:83] Thread abort performing I/O operation on provider.
9:40:02.3: Warning: 0 : [IoManager:79] Thread abort performing I/O operation on provider.
9:40:02.3: Warning: 0 : [IoManager:83] Error writing range: Offset=523,669,340,160. Length=10,485,760. Thread was being aborted..
9:40:02.3: Warning: 0 : [IoManager:79] Error writing range: Offset=523,658,854,400. Length=10,485,760. Thread was being aborted..
9:40:02.3: Information: 0 : [IoManager:83] [W]   Offset:0x00000079F9000000 Length:10,485,760
9:40:02.3: Information: 0 : [IoManager:79] [W]   Offset:0x00000079F9A00000 Length:10,485,760
9:40:04.0: Warning: 0 : [IoManager:67] Thread abort performing I/O operation on provider.
9:40:04.0: Information: 0 : [GoogleDriveIoProvider:86] [R] Reading chunk 25,815 (0x00500140 - 0x007001BF).
9:40:04.0: Warning: 0 : [IoManager:67] Error writing range: Offset=523,679,825,920. Length=10,485,760. Thread was being aborted..
9:40:04.0: Information: 0 : [IoManager:67] [W]   Offset:0x00000079FA400000 Length:10,485,760
9:40:05.2: Warning: 0 : [IoManager:37] Thread abort performing I/O operation on provider.
9:40:05.2: Warning: 0 : [IoManager:37] Error writing range: Offset=523,690,311,680. Length=10,485,760. Thread was being aborted..
9:40:05.2: Information: 0 : [IoManager:37] [W]   Offset:0x00000079FAE00000 Length:10,485,760
9:40:06.2: Warning: 0 : [IoManager:43] Thread abort performing I/O operation on provider.
9:40:06.2: Warning: 0 : [IoManager:43] Error writing range: Offset=523,700,797,440. Length=10,485,760. Thread was being aborted..
9:40:06.2: Information: 0 : [IoManager:43] [W]   Offset:0x00000079FB800000 Length:10,485,760

It has completely stopped with the following being spammed in the service log.

Share this post


Link to post
Share on other sites
  • 0

It looks like it is being limited on rate. Essentially it sometimes just sits with things waiting to be uploaded for a long time.

 

I've uploaded logs through the Wiki, let me know if you need any more info.

Thanks!

 

I've flagged the issue and the logs for Alex, and he'll take a look into it when he has a chance.

https://stablebit.com/Admin/IssueAnalysis/27056

 

 

Brilliant, Thankyou!

 

 

Sent from my iPhone using Tapatalk

 

Just keep in mind that  the updated builds can have problems.

 

The general rule of thumb is to check the change log (the changes.txt in that link), and grab the second numbered build. 

 

Right now, that would be .599 rather than the .605.  

 

Unless otherwise instructed by Alex or myself. 

Share this post


Link to post
Share on other sites
  • 0

I'll try to update the post here, once Alex posts a reply. 

 

 

 

Also how am I hitting a userRateLimit with just 20mbit upload?

it depends on the context. Google Drive has API limits, and we could be hitting that, or something else could be going on here.  The logs provided should indicate what is going on here.

Share this post


Link to post
Share on other sites
  • 0

After reinstalling it appears as though the app is in a state where it can no longer upload at all. Each request it sends is hit with a userRateLimit:

 

clouddrive.png

 

I'm going to remove it for the moment and keep an eye on the update notes.

Share this post


Link to post
Share on other sites
  • 0

Does the 624 build help with this issue?  (note: this *will* dismount the drive if it runs into too many issues, like this)

 

Also, from the logs, it looks like the software is experiencing network connectivity issues. 
Are you using any sort of firewall (or even antivirus) on the system?  

 

And I'm curious about the results of this:

http://netalyzr.icsi.berkeley.edu/

(it's a fairly indepth connectivity test, basically, speedtest on crack). 

Share this post


Link to post
Share on other sites
  • 0

I'm not sure if its related but today and yesterday I have been having issues like this with a new drive created in BETA .621 where data will just sit in the "To Upload" section with no activity.  When this is occurring, download stuff from the drive is very slow.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...