Jump to content
Covecube Inc.
  • 0

Directory is corrupted and unreadable - 8.6 TB of lost data (a Christmas present)


cryodream
 Share

Question

So, DrivePool just gave me a really shitty Christmas present.

 

I just noticed that Sonarr was giving errors. I checked the pool on my server and the TVShows folder was fucked. I was unable to copy files onto it or create folders. I always got this error (Directory Opus on the left, windows file explorer on the right):

2jDv2xl.png  d2fpr5L.png

 

DrivePool showed nothing wrong, except "File distribution not optimal" and "Re-balance" option. I tried to re-balance. Which completed in like 10 seconds and did not help at all. Then I tried to "Re-measure". It finished in a minute or so, but the "Statistics are incomplete" pac-man icon did not went away, as it usually did, after re-measure completed. I thought...wtf...

 

I checked Scanner and that one also showed nothing wrong - no file system failures either.

 

At this point I already had a very bad feeling and decided to run a check with WhereIsIt. I use WhereIsIt to automatically scan the Pool every 6 hours and write results to a time-stamped file. I compared yesterdays 7pm file with todays 7pm file.

Mo*******er... 8684 files missing from the TVShows folder alone! In that single folder there was 8.6 TB of files missing! Thats only one folder. I haven't checked others yet.

 

That is not funny at all. The largest drives on the server are 6TB. So it's at least 2 or more drives have gone bad or what? Why Scanner shows no errors? Why DrivePool shows no errors?

What the f*** happened, anyway?

 

Please, tell me it's some drivepool bug and it lost it's mind, and that the files are actually not lost. Because if not - that is just plain ridiculous and the biggest file loss I have ever had. On f***in Christmas Eve, no less.

 

And, once again, because DrivePool does not keep the files in the same folder together, but rather scatters them around on random drives, I've lost almost 9000 random episodes from pretty much all the shows, probably. Shit.

 

The irony is, I bought a bunch of 6TB drives on BF, and now the second to last is finishing the full format. I was about to add them to the pool and set duplication probably tomorrow.

 

 

Thanks in advance for any help.

 

OS: win 8.1 x64

Scanner: 2.5.1.3062

DrivePool: 2.2.0.659 Beta

Link to comment
Share on other sites

8 answers to this question

Recommended Posts

  • 0

Did you have duplication enabled for your folders if not I hope you have a backup its not the softwares fault if a drive fails scanner helps if a drive starts to show errors but drives do just fail instantly.

I have 30tb's of data duplicated x2 with my most important stuff set to 3x and I use crashplan to backup all the important stuff too I also always leave enough free space in my pool to reduplicate the largest drive so in my case that is 4tb that way if a drive does fail drivepool will automatically reduplicate the data.

 

If you can identify which drive you have lost try it in another machine and navigate to the pool parts folder and get everything off 1 file at time any read errors should show up then it might help identify what files you have u lost.

Link to comment
Share on other sites

  • 0

I think I just had something very similar happen and I have lost about 6.5TB of data.  I have been formatting drives and adding them to the pool and then copying data into it.  I had just added a new 4TB drive to the pool (total 2x 3TB and 1x 4TB) and I was copying data in from another 4TB drive.  The files were not yet duplicated and balancing was turned off as I did not yet have enough capacity to do it.  Sometime during the night the copying stopped due a "permissions" issue.  When I checked it this morning I saw the copy had failed and the Pool was now empty!  The three disks that made up the pool were all mostly empty.  Trying to access the pool folders on them resulting in access denied errors.

 

I have run some drive recovery software on the drives and most is unrecoverable as it says the data is no longer on disk.  Some can be recovered but recovering them appears to strip the directory structure and so I'll just have all my files in a single place.  Plus it doesn't recommend recovering them to the same drive.  I do have some of the data in another place because I was in the process of putting it all in the pool and removing duplicates before enabling pool duplication.  Luckily I hadn't managed to finish or I could have lost the whole lot.

 

I need to know why this happened because at the moment I have lost all faith in the software which is a shame because other than this it appeared to do exactly what I wanted!

Link to comment
Share on other sites

  • 0

Two people reporting the same problem above... Just to state a commonality between the two:

 

They were both 'formatting' drives at the time they report errors/lost data.

 

Maybe related?

 

Does seem scary.  You shouldn't have to; but, I personally install all new drives in a separate machine first to format them (at 64KB clusters, because almost all are movies/tv).  Once formatted, I move them to the server.  I do this mostly from habit of back in the NT days when random $&@# happened when formatting one drive and accessing another.

 

Absolute guess here... But, perhaps DrivePool constantly scans for new drives to add to the pool.  And during the format, something may crash in that scanning - crashing the pool.  A reboot should resolve that I think though.

Link to comment
Share on other sites

  • 0

Sorry, just to clarify: I wasn't formatting a drive at the time that I lost the data.  In general the process I have been using is: format a drive so it is fresh, add it to the pool (without duplication or scheduled balancing) and then copy data into the pool from another drive, freeing that drive up in the process.  I would then format that drive and add it to the pool etc.

 

I had just added the third drive to the pool and was copying data from a fourth drive (not in the pool) into the pool and that is when I appear to have lost all of the data.  The Folders that I had inside the PoolPart folders are now reporting Owner as "unable to display current owner".  So something strange has completely ripped the pool apart here.  I'm still struggling to put together the pieces.  Windows may have also downloaded/installed some Windows Updates during the night (great Windows 10 feature that I can't seem to prevent) but somewhere along the way the combination of that, the copy process and the pool it has managed to wipe 6.5TB of data.  I really want to use this product but I need find out what happened here and make sure it doesn't happen again.

 

Out of interest does anyone have any experience of some good free data recovery tools for files larger than 4GB?  I have used Recuva to scan the drives but it reports all files over 4GB as unrecoverable.  This seems to be a limitation with the way that the NTFS deletes files over 4GB but there must surely be a tool out there that can recover them.

Link to comment
Share on other sites

  • 0

Despite the similaries, these issues really are different.

 

But more on point, it sounds like both are caused by issues with the underlying disks.

 

 

That said, data loss is always horrible. And we are looking into the issue, to see if there is anything we can find or do to help here.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...