Jump to content
Covecube Inc.
  • 0

Wrong HDD size detected


Question

Hi,
I have some strange problem with my drivepool that one of the 7 HDDs get detected with a wrong size.
The disc is new and I added it yesterday and did some special placement rules so that this and the two IronWolf HDDs are the only ones which have duplicated data on it.
When I added the disk, the size was shown correctly, only after the files were placed on it this happend.
There are no files on the HDD, only the Drivepool hidden folder and the disk was empty for adding.

The disk has a size of 18TB and gets correctly detected from windows but the drivepool shown it as 21,3TB Disk.
I tried an update from 2.2.3 to the latest 2.2.5 and also did several reboots but still the same problem.

Any idea how I can start a kind of rescan for that disk?
I'm kind of worried about my files at the moment.
Using Drivepool for years now and swapped at least 3 times my complete HDD array and never have seen any problems like that.

OS is an Windows Server 2019 installation... sorry for the german windows language. ;)

Thanks for any help

1.png

2.png

3.png

Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Hmm. I vaguely recall this has come up before. Basically the "total" (unduplicated + duplicated + free remaining) in DrivePool's gui is based on the file sizes rather than the size they take up on the disk, which aren't necessarily the same due to the way NTFS works. DrivePool is still (as you can see from the top left of the tooltip) aware of the actual size of the physical drive. Aha, found it:

TLDR the DrivePool uses "file size" rather than "size on disk" for some of its calculations, and this is reflected in the GUI.

If you want DrivePool to recalculate these just in case, you can use the GUI's "Manage Pool" -> "Re-measure..."

Link to post
Share on other sites
  • 0

Hi,
thanks for the help, the re-measure button did the job, now the disk is shown with the correct size.
Don't know why I was that blind, was looking for exactly this option but only checked the top right troubleshooting menu with cheching duplication etc...

File size and size on disc is nearly the same, no filesystem compression or dedup enabled.

Btw the Onedrive sync has some serious problems when you remove/add disks, looks like every file which will be transfered to another disk is triggering the Onedrive check.
So Onedrive is syncing like hell and sucking CPU usage all the time.
Maybe that was the problem that the pool was showing more file size than really on the disk.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...