Jump to content
Covecube Inc.
  • 0

SSD Optimizer and v2.3.0.1144 Beta


Question

Maybe I'm missing something, or just challenged...

I'm running v2.3.0.1144 BETA due to some issues that I had with the pool randomly deciding that I didn't actually want some folders duplicated - it would just go from x2 to x1 with no input from me, then take a significant amount of time to reduplicate once I noticed and turned it back on. That seems to have gotten better, as it has not happened for months now with this version.

Aside from that, I am preparing to move DrivePool to a new box and thought it would be a good time to install the SSD Optimizer, since I will have ports and drives available.

Except, no.

I downloaded the .msi for the SSD Optimizer v1.0.5.12 (Win10 20H2 currently) and have tried just running it, closing DrivePool and running it, opening an elevated command prompt and running it...  no joy - I can't get the SSD Optimizer to even show up as installed. It flashes a window on the screen very briefly, which then closes, and nothing else seems to happen.

In Event Viewer, I get four entries:

1. Beginning a Windows Installer Transaction...

2. Ending a Windows Installer Transaction...

3. Product: StableBit DrivePool Plug-in - SSD Optimizer -- Installation failed, and

4. Windows Installer installed the product. Product Name: StableBit DrivePool Plug-in - SSD Optimizer. Product Version: 1.0.12. Product Language: 1033. Manufacturer: Covecube Inc.. Installation success or error status: 1603 (which, in theory, means it is already installed).

But it does not show as an option anywhere in the 'Balancers' tab. What am I doing wrong?

Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 1
14 hours ago, AK96SS said:

But it does not show as an option anywhere in the 'Balancers' tab. What am I doing wrong?

Try this:
Get hold of "Geek Uninstaller" here: https://geekuninstaller.com/download
Use that to a) see if the plugin is in the list and b) remove all trace of it if it's there.
Then disable your AV software and re-install SSD Optimizer, and reboot. (This particularly applies if you use Windows Defender, as W10 20H2 has some significant security changes that have caused issues for many non-Microsoft programs.)

Link to post
Share on other sites
  • 1

If it's installed, it should show up in "C:\Program Files\StableBit\DrivePool\Plugins\Balancing".  There should be folders here, and a dll in the folder. That should be a "CovecubeInc.SSDOptimizerPlugin.dll" file there.  If that's there, then it's installed.    Re-open the UI and see if that helps.

Link to post
Share on other sites
  • 0

It was not in there at all - the Balancing subdirectory was empty.

Turning off A/V seems to have fixed it - once I clicked through all the Sky-Is-Falling notifications, tried the installer again, worked immediately.

It has been quite some time since I've had to do that - I'd forgotten it was a thing, honestly.

 

Thanks!

 

 

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...