Jump to content
Covecube Inc.
  • 0
jsunjones

Drive Sleep

Question

New to StableBit DrivePool, how do I ensure drives will sleep when unused.  I have a basic setup and drives are not sleeping according to smartctl.  I do not have BitLocker enabled.  Note: this is something I want to validate before buying

Windows 10 Pro
Power Profile - Balanced -  has 5 min Drive Sleep enabled
Drives are Internal SATA (5 x 8TB WD, 3 x 6TB WD)

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Hi,

I have decided to post as a reply and not a new question.

I have the same problem as some people: with DrivePool Service running my external USB drives don't sleep. Looking at drive activity in Resmon I can see regular access every second to all my three external USB disks (drive letters D, E and F). As soon as I stop the DrivePool Service such access ceases. And my disks will spindown after the amount specified in the active Power plan. The second image was captured just a few seconds after stopping the service to still show the past access activities. My Pool is not yet setup - no pool disk created.

And yes I have set the BitLocker_PoolPartUnlockDetect setting to False.

My Windows is Win10 1909 build 18363.815 and DrivePool version is 2.2.3.1019

How can I allow my drives to spin-down?DrivePool_Service_running.PNG.3e42bdc2e5b25eec40f1a54e8e70a102.PNGDrivePool_Service_stopped.PNG.a4cfb6479d06939f31fadc39cd15f179.PNG

Share this post


Link to post
Share on other sites
  • 0
14 hours ago, Christopher (Drashna) said:

If you have StablEbit Scanner installed as well, make sure that you enable the "throttling" option in the SMART settings tab.

Yes I do have StableBit Scanner and yes the throttling is enabled and set to 60 minutes.

Share this post


Link to post
Share on other sites
  • 0

To make sure, you have the bitlocker detection disabled, and the SMART queries throttled? 

Do you have CloudDrive installed?  If so, it has a similar bitlocker detection option, and may be worth disabling. 

And do you have the drives configured to idle/sleep in the Windows power settings? 

Otherwise, if you're still seeing the drive being kept awake, it may be worth checking something like process monitor or process explorer to see what is accessing the drive in question, to see what is keeping it awake. 

Share this post


Link to post
Share on other sites
  • 0

Hello again Christopher,

On the machine in question only DrivePool and Scanner are installed. I have CloudDrive but I use it on a different PC on a different LAN.

I have verified thrice just to be sure and here is my setup and observations:

- PC setup: Win10 1909 build 18363.815, DrivePool version is 2.2.3.1019 , Scanner version is 2.5.6.3336

- Three USB disks attached (drive letters D, E and F) (TerraMaster D5-300C enclosure)

- Scanner has under SMART throttling set to 60 minutes, "only query during the work window or if scanning" set and "do not query if the disk has spun down" also is set.

- DrivePool is not configured for any pool disk, as if just installed. DrivePool has "BitLocker_PoolPartUnlockDetect" set to "false" (both Default and Override)

- the DrivePool Service is Stopped

- the active power plan of Windows has disk spindown set to 3 minutes. All three disks are not spinning.

- Procmon64 shows abolutely no processes accessing the D, E or F disks

- Resmon (disk tab) shows absolutely no activity for disks D, E and F

Now as soon as I enable the DrivePool Service the disks wake up and never again go to sleep. You can see in the Resmon that every second there is access to all three disks. In the image in my previous post accesses to disk D are obvious, but if look with attention, every second there are very subtle marks also for disks E and F (very small peaks). Procmon continues to show that nothing is accessing disks D, E and F.

If I stop the DrivePool Service I stop seeing in Resmon disk access for these three disks and after three minutes (whatever is set in the power plan) the go to sleep.

Once again if I restart the DrivePool Service the disks wake-up and I start seeing the same every second disk access activity in Resmon. Again the disks will never spin-down. Not until I stop the DrivePool Service.

 

Now I do not want to say that the DrivePool service is the culprit but it took me a very long time to narrow down what is causing my external USB drives not to sleep. Because Procmon was useless (no process was accessing the disks) I started stopping different services and have observed the above described behavior with the DrivePool Service.

As the authors of DrivePool I am kindly asking for suggestions what to do to have my external disks spin-down or how to continue investigating. It might be a Microsoft Windows or USB driver problem or other but I would like some help or directions with the next steps. Thanks in advance. Cheers.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...