Jump to content
  • 0

It appears my boot sector is corrupted



I have a pool of 13 drives and I had an unexpected nearby lightening strike. I have surge protection and nothing seems damaged but my Drivepool drive is now reporting a bad boot sector and that seems to be preventing all duplication actions. several files/folders lost their rights/owners and I tried to fix all the errors I found using "Takedown" and the followups and all the problem files/directories i found became accessible after i fixed them but i seem to not be able to do that for the boot sector and I may have missed a few files/folders.

My dirvepool drive is fully accessible but I cannot get any duplication to run on it. I had duplication enabled but i have gone in and disabled it every where but "metadata" and the option does not exist for that one object. it seems that even though the duplication is now turned off nothing has changed. 

I tried running chkdsk /f on the pool and I get an error saying that the boot sector is invalid/bad/corrupted. The operation of the pool seems fine and I can add/delete/modify files just fine but Drivepool reports problems with duplication and it will not run the check duplication feature at all. I click the little down error and it acts like it is going to start but it just returns to the main screen with the progress bar and a report of "Duplication inconsistent. I want to fix this someway but I was wondering something:
All my drives are fine. I wonder if I can somehow force the pool to be recreated without losing the data in the poolpart... directories and i wonder, if i did that, would the data be retained. I am even willing to manually move data from one poolpart folder to another if that is what is required. Also i would like detailed instructions but i am quite willing to work with some general directions. 

I downloaded and ran Wss.Troubleshoot_1.0.0.165.exe and I managed to get some info but it never actually seemed to do anything other than report. 

I just want the DrivePool drive to operate as it did and IREALLY do not want to lose any data. 

I tried to ask a question about this last week and received a response and did as suggested but no improvement. I posted back and reported that nothing worked but I have received no further messages. The request is: https://stablebit.com/Contact/1194079 

I need to know a few things as well:
Is there any danger to using the drive as it is?

One more thing: I am quite computer literate but i am also elderly and, sometimes, I have problems organizing, my actions and that is why I would like some detailed help.

Of all the questions I have the most pressing one is the one about any dangers. I have a lot of very hard to duplicate data in the pool and i know i can copy it out is needed but I do not want to lose any of it so knowledge about the dangers would be much appreciated.   

Link to comment
Share on other sites

11 answers to this question

Recommended Posts

  • 1

Note that the linked thread's linked SetACL utility will automatically use \\?\P:\ internally (as can be seen in its console output) if P:\ is supplied. A useful tip for other CLI tools though!

Link to comment
Share on other sites

  • 0
14 hours ago, Shane said:

Hi, do you still need help with this or did Stablebit get back in contact with you?

Well StableBit did get in touch wtih me and we tried several things and they answered a bunch of my questions. However the problem is still there but I have narrowed it down to some kind of permission/ownership issue as i get errors on some files when I try to access then. The error DrivePool shows is "Duplication inconsistent" but when I try to recheck duplication it simply returns to the same error after much less than one second. 

I try some things virtually every day but it takes time and my health is not good (I am an old guy) so I can only do a limited amount each day. 

If anyone has ideas that might allow me to fix my pool I will be grateful but I cannot test thoroughly or make large changes most days.

StableBit believes that it is something with the underlying drives but, right now, I cannot take the time to test each one outside the pool as that takes time I do not, presently, have.

I hope that running the pool as I am right now with no duplication working will not cause any additional problems but I have little choice.


Link to comment
Share on other sites

  • 0

Folks, thank all for the ideas. I am not neglecting them but I have some health issues that make it very hard for me to do much of anything for a while. I will try the more promising ones as my health permits but it will take some time. From operation and the lack of errors during writing/reading it seems that I am in no danger except duplication won't work. I can live with that for a while.

Keep the ideas coming and, maybe, I can get this mess fixed and report back which tools worked for me.

I am making one pass through my pool where I remove a drive from the pool, run full diagnosis and file system diagnosis on that drive then I re-add it back to the pool. When completed that will assure that there are no underlying drive problems and I can proceed from there.

Thanks to all who tried to help this old man. ;) 

Link to comment
Share on other sites

  • 0

A final, I hope, follow-up to this. I have fixed the problems by simply going to the OS level and going to each drive and making "Everyone" the owner, with full rights, to each of the PoolPart... directories on the drives. That seems to have cleared everything up and the duplicating functioning is restored. 

I probably made this more trouble than it needed to be but I plead age and poor health that influenced my decisions to the more complicated side.  I lost a few files but at least i did not need to rebuild my entire pool.

I wish there was a tool available that will fix this kind of issue automagically but doing it manually is not too bad as long as the correct choice is made early on. Unfortunately some of my early decisions led me down the wrong path so it took me several times longer than it should have.
Again, I plead old brain syndrome.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...