Jump to content
Covecube Inc.
  • 0

Drive pool losing assigned letter when adding drive


Question

I was having a problem with my 2TB green drives and the head cycle count, so I started pulling out drives out of my pool, and replacing them with a spare, one at a time, so I could remove the timer in the firmware.

The first one removed no problem, drivepool removed the data from the drive, I put in a new 3TB red, and added it to the pool. No issues.

A couple of days later, I do the same thing, but I put in the green I pulled out. This time though, when I rebooted the server, errors started popping up, and the drive pool had changed from F: to L:, so all my shares disappeared, including my NFS shares.

I pulled out the new drive, rebooted, same issue.

I had to go into the "Manage", and reassign the drive from L to F, and reboot, then re-add the shares.

Anyone else seen this?  I had added other drives in the past, with no issues, the pool stayed at F:, for some reason today, it changed.

Mark

Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

This is unfortunately a Windows problem - sometimes it will "bump" a drive letter to a different letter when you add a drive while the system is powered down or a drive is/was missing (e.g. you have C, D, E, F; F is your pool; you shut down the OS to add a new drive, but rather than call it G, Windows may decide to call it F and bump the previous F drive to the next available letter).

 

I recommend setting the drive letter(s) of your pool(s) close to the end of the alphabet (e.g. P, Q, etc) to reduce the risk of this happening.

Link to post
Share on other sites
  • 0

It's a combination of drive, controller/motherboard and operating system. In theory, if you have a SATA drive with AHCI enabled for it on the motherboard and you are running Vista or later, you should be able to hot-swap the drives - typically via the "Safely Remove/Eject" tray icon. If you can't see your drive in the icon's list, it isn't in a hot-swappable configuration.

 

Warning: if your Windows boot drive is set to IDE, changing it to AHCI without editing the registry first will cause it to BSOD: http://support.microsoft.com/kb/922976 (not that you can hotswap the Windows boot drive anyway, but some motherboards don't allow you to change IDE/AHCI settings just for the non-boot drives).

Link to post
Share on other sites
  • 0

Shane is dead on. 

Most onboard controllers you can only set the mode for the controller, and not individual drives. 

 

There is a registry hack to allow you to change the mode of the boot drive, but it's a hack... and may cause issues. 

Basically, it's best to set it first and then install WIndows.

 

 

Also, if you're using SSD, you absolutely must have AHCI enabled, as without it you won't get TRIM support (IIRC). 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...