Jump to content
Covecube Inc.
  • 0

SSD usage with more than one SSD as cache


Question

I am not 100% sure of that but with 3 SSDs as cache (since I have some folder duplicated x3) when I write to the pool into a folder without duplication then this is always the same SSD that is used.

If I am correct then it would be better if write could be randomly done on one of the 3 SSD and not always the same one.

Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

That may be the case.  Specifically, the drive with the most available free space is selected. It may be that this one drive has slightly more free space than the others. 

 

If that's not the case, then it may be just how it's selected. And if that's the case, let us know.

Link to post
Share on other sites
  • 0

I have recreated partition on the 3 SSDs so they have now the exact same space avaible.

I have made other write tests and it realy looks like the same SSD is always used when duplication is x1 so no duplication.

 

An other thing I did noticed is that when writting to a x3 folder, so basicaly to the 3 SSDs at the same time, then in main DrivePool disk perfomance windows, only one SSD write is shown. We should normaly have 3 bars since 3 SSDs are being written.

Link to post
Share on other sites
  • 0

I have recreated partition on the 3 SSDs so they have now the exact same space avaible.

I have made other write tests and it realy looks like the same SSD is always used when duplication is x1 so no duplication.

 

An other thing I did noticed is that when writting to a x3 folder, so basicaly to the 3 SSDs at the same time, then in main DrivePool disk perfomance windows, only one SSD write is shown. We should normaly have 3 bars since 3 SSDs are being written.

I've actually noticed the same. So there is definitely a bug there. 

 

However, this is a performance UI bug.  When I've seen this, I've manually confirmed that all copies are created properly. So it's definitely a UI bug.

 

Flagged for Alex (the developer).

https://stablebit.com/Admin/IssueAnalysis/20843

 

However, could you enable file system logging, reproduce it and upload the logs? 

http://wiki.covecube.com/StableBit_DrivePool_2.x_Log_Collection

Link to post
Share on other sites
  • 0

I am uploading the logs.

Here is what I did :

- started DrivePool log

- copied 18GB movie to a x1 DrivePool folder

- waited for SSD cache to write it to HD

- copied the same movie from the same source to a x3 DrivePool folder

- waited for SSDs cache to write it to HDs witch took longer since SSDs are emptied one by one.

 

I hope it could help.

 

 

EDIT : uploading done.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...