Jump to content
  • 0

File placement rules being ignored



Hey, I have 12 drives, 10 archive HDDs, 1 SSD cache landing drive and 1 SSD archive for millions of tiny files for fast access.

I have a few dozen file placement rules set for various file extensions (eg. .MKV) so that tiny files are always on the SSD archive and big files like videos are never on that drive. It worked fine for a while but now it doesn't and the archive SSD is being filled with media files and the HDDs with tiny files.


The only plugin enabled is SSD Optimizer with 98% fill options and each file placement rule is set to "never allow files to be placed on any other disks" which is being violated. The drives are between 92%-95% full but even if I get a drive to like 85% and balancing after re-measuring still doesn't respect the file placement rules and doesn't move anything. The files are not locked.


"Allow balacing plug-ins to force immediate balancing";

"File placement rules respect real-time file placement limits set by the balancing plug-ins";

"Balancing plug-ins respect file placement rules" are all enabled.


But it all worked flawlessly in the past, not sure what changed, other than the drives being more filled but now it doesn't work.

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Sort of solved it; since the file placement rules are a priority list, stuff closer to the bottom gets ignored. After removing and readding and moving several rules to the top, after about a dozen of balancing passes, it finnally moved all the files. It still for some reason at first only moved to files to the cache and the next balancing put them to their place but whatever.


It seems that after like a year or so stuff always gets wonky with DrivePool and I have to reset settings to get it working flawlessly again but resetting is a major PITA.

Link to comment
Share on other sites

  • 0

Yesterday I added a SSD(2TB) and HDD(16TB) to my pool. I set the SSD as SSD in the "SSD Optimizer" plugin and chose to only allow the "Downloads" folder to be placed on the SSD. The "SSD Optimizer"- and "StableBit Scanner"-plugin is activated. As of typing this post, Drivepool is moving files from the "Downloads" folder to my new 16TB HDD. This is just stupid. Thought it was supposed to obey the placement rules no matter what. What am I doing wrong?

"File placement rules respect real-time...." is unchecked


Roger J.

Link to comment
Share on other sites

  • 0

@Roger79 If the SSD Optimizer counts as "emptying" the SSD drives into the Archive drives, you might need under Balancing -> Settings -> File placement settings:

  • (uncertain) File placement rules respect...
  • (ticked) Balancing plug-ins respect file placement rules
  • (unticked) Unless the drive is being emptied.

The other possibility is that File Placement being told "use drive X as permanent storage" isn't compatible with the SSD Optimizer being told "use drive X as temporary cache".

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...