Jump to content
Covecube Inc.
  • 0
mvd

Ordered File Placement plugin: possible bug

Question

I'm having some problems with the Ordered File Placement plugin.  The following is based on testing with ONLY the Ordered File Placement plugin, no other plugins enabled. 

1) OFP plugin seems to ignore "Or this much free space" GB value under "Do not fill drives above".  I've tested this many different ways.   If I set Do not fill drives above=99% and Or this much free space=500GB, and I have only 100GB free on that disk, balancer will still place files on that disk even though it shouldn't because <500GB of space is free.

2) If Disk1 exceeds Do not fill drives above=90%, and OFP begins to place files on Disk2, then if I delete 200GB of files from Disk1 and it is back below free space threshhold, OFP will not switch back to Disk1 dynamically when placing new files - it just keeps filling Disk2.  Only if I manually I restart the Stablebit Drivepool service will it switch back to Disk1.

3) If I change the "Do not fill drives above" percentage from the default 90% to any other value and click SAVE, the little orange arrows on the dashboard for each pooled disk stay stuck at either 90% or 0%, they dont reflect the saved value.  This may or not be limited to a GUI/cosmetic issue, as I've been trying to figure out if the balancer is using the new value internally despite what the GUI shows.

post-317-0-54071700-1374295011_thumb.jpg

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0

Tested my install (v2.0.0.320), exhibits same behaviour as yours. Please do submit the ticket.

 

I have a ticket open concerning a different behaviour of that plugin (new disks not always being added to the bottom of the OFP's drive list as claimed by its info tip).

Share this post


Link to post
Share on other sites
  • 0

Thanks Shane, glad I'm not the only one. 

 

I've noticed the "new disks not being added to bottom of OFP drive list" as well now that I've played with it a bit.

Share this post


Link to post
Share on other sites
  • 0

just a question if you uncheck "or this much free space" set to 100gb seems to me that checked would override the percent scale and use the gigabyte scale

Share this post


Link to post
Share on other sites
  • 0

just a question if you uncheck "or this much free space" set to 100gb seems to me that checked would override the percent scale and use the gigabyte scale

 

Except it doesn't.  Still stuck at 90% with or without "or this much free space" checked. 

Share this post


Link to post
Share on other sites
  • 0

try setting the gigabyte to 50gb see what happens should move the scale percentage higher I would think. if not it's guess it's broke at 90%.

Share this post


Link to post
Share on other sites
  • 0

try setting the gigabyte to 50gb see what happens should move the scale percentage higher I would think. if not it's guess it's broke at 90%.

 

Yes, I tried that a long time ago.  Believe me, I've screwed around with different settings for hours trying to make sense of it.  Seems hardcoded at 90% no matter what

Share this post


Link to post
Share on other sites
  • 0

mvd, do you have any other balancers enabled? 

If so, try disabling those (especially "prevent drive overfill"). 

 

Nope, no other balancers enabled -- as you can see in my screenshot.  I wouldn't be bothering you guys had I not already tried every avenue to get it to work :)

 

And if you read post #2,  Shane was also to reproduce as well.

Share this post


Link to post
Share on other sites
  • 0

Silly question time: after moving the slider, did you click the "Save" button?

 

Excerpting from Alex's response to my ticket on another issue with the OFP balancer, with emphasis mine, "So if you add more than one new drive to the pool, all of those new drives will be added to the bottom of the existing list that you've Saved, but sorted by percent used. And more importantly, if this is a new pool and you've never clicked Save to commit your drive order, then there really is no order that you've defined for the balancer and the list is just built by percent used."

 

Alex went on to say that the drive order issue will be fixed in a new build, but when I tested with Save-ing the order to see the difference, I also tested your slider issue and noticed that, while the main status screen did not alter its markers to anything other than 0% or 90%, clicking Save did change those markers from 90% to 0% or vice versa corresponding to whether the changes in the OFP list should affect the balancing for those drives!

Share this post


Link to post
Share on other sites
  • 0

Yep, definitely always click Save. Here are a few more idiosyncrasies I've discovered in further testing:

1) What orange arrows indicate and balancer actually does are two different things, so if you change "do not overfill past" slider from 99% to 10%, the orange arrows will change position (either 0% or 90% as you said), but balancer won't respond to the change unless the service is restarted.

 

This is bad because let's say I set Disk1 and Disk 2 to not overfill past 90%.  Disk 1 fills up to 90%, then balancer switches to Disk 2.  However let's say I delete 500GB from Disk1 and now there's space to fill it back up to 90% -- balancer doesn't care, it'll keep filling Disk 2 until 90%.

 

2) OFP Balancer seems to ignore "Or this much free space (in GB)" value.  I can set Disk1 to not overfill past 99%, and set "Or this much free space" to 1TB, and balancer ignores it even after a service restart.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...