Jump to content
Covecube Inc.

otispresley

Members
  • Content Count

    111
  • Joined

  • Last visited

  • Days Won

    8

Everything posted by otispresley

  1. otispresley

    Confused

    I stream 4k Blu-Rays fine from my DrivePool using Kodi on my Shield TV box. The issue you run into is that even though you have multiple disks that are the same manufacturer and model, their performance may vary. Make sure your 4k streaming files are on your fastest disks in the pool by doing file placement rules. The other factor in streaming is network. You will definitely want to do Gigabit Ethernet rather than wireless when you want to stream 4k Blu-Rays. If you have duplication enabled on you pool, make sure Read Striping is enabled. You will need to test your Ethernet network using iPerf or something like that to ensure that it is actually doing wire speed. Some home routers have Gigabit Ethernet but are not actually capable of Gigabit throughput. DrivePool is not intended to be a NAS application, so there is no way for you to use USB to expose it as a disk, unless there is some special USB driver software out there that I don't know about. You could potentially use USB networking, but you would have to have some way to convert it to Ethernet, because the Shield TV boxes and TV's only use USB for storage and charging. Streaming is definitely the easier choice since you only have provide the network rather than trying to run thick HDMI 2.0 video cables everywhere. If you must run video though, you may want to look into devices that can run the video signal over wireless or Cat6/7 cables; you would need Cat7 to do it in a single cable, since HDMI 2.0+ has an 18 Gbps bandwidth. I hope this helps!
  2. Those are exactly the same drives I had, and I had 20 of them! They were horrible for me. I have 0 left. Out of the 20, I maybe pulled 3 from the system that didn't at least have SMART warnings. Over the years, I submitted RMA's and over time, the RMA's started to have problems. Since then, I have been buying Toshiba 3TB and HGST 6TB NAS drives and have never had to RMA one. They have been running perfectly with no issues whatsoever. Because of my experience, I will probably never buy a Seagate desktop drive again. I would assume that their Enterprise drives are still solid though.
  3. Well, I really have 25 drives. 4 are SSDs sitting inside the case (1 SSD for the OS and 3 in a RAID0 for VM storage), one is in a drive dock for backups, and the 20 in hot swap bays are in DrivePool. 9 of my drives are still 3TB and 11 are 6TB. Once I get one more 6TB, I do plan to start a RAID50 and expand it over time as I upgrade the remaining 3TB drives.
  4. Here is some stuff from a search on Newegg: Cases RAID Cards Server Motherboards My setup is not as big as what you want. It is 20 drives, but I am currently using an ASRock EP2C602-4L/D16 Motherboard with two E5-2680v2 CPUs and 256 GB DDR3-1866 Registered ECC Memory. I hope this helps!
  5. I believe it is still the case that Hyper-V does not support passing of SMART data, so you cannot get it with disk pass-through. You would have to use Christopher's solution of running Scanner on the host and in the VM, which is what I did with Hyper-V 2012 R2 as well. My setup on Server 2016 is different as I am running the Standard version with Essentials enabled with DrivePool and Scanner running on the host. I have VM's for everything else with mounts to the pool.
  6. Wow! How do you ever find anything to watch?
  7. I have not tried since Tech Preview 4. I had tried passing through my Highpoint RR 2760A, but it did not work. It is quite a process as seen here: https://docs.microsoft.com/en-us/windows-server/virtualization/hyper-v/plan/plan-for-deploying-devices-using-discrete-device-assignment and here https://blogs.technet.microsoft.com/heyscriptingguy/2016/07/14/passing-through-devices-to-hyper-v-vms-by-using-discrete-device-assignment/ This article shows how it is done for a graphics card: https://docs.microsoft.com/en-us/windows-server/virtualization/hyper-v/deploy/deploying-graphics-devices-using-dda
  8. I encoded all of mine to HEVC video in an MKV container with no perceptible loss in quality. Choosing MKV was due to a bug with FFMPEG and copying PGS subtitles as binary data in the M2TS container. BUT, MKV does not support LPCM audio, so I had to convert those tracks to PCM at whatever bit depth and endian the source had. Overall, it resulted in just over 50% space savings. Here is what I have using less than 24 TB on the pool and being served by Emby: Movies Episodes unkown 0 0 < 480P 0 0 480P 149 39 720P 0 24 1080P 1889 236 1440P 0 0 4K 0 0
  9. Yeah, you definitely didn't have to go through all that trouble. There are 2 options with ESXi...pass through the individual disks, or if all drives on your controller are for DrivePool, then you can pass through the entire controller. See here: RDM (In the GUI client) Pass-Through controller
  10. I can confirm that this issues is now fixed for me in the newest beta. Both drives are now reporting Healthy after a rescan.
  11. Ahhhh, nice! Thanks Christopher!
  12. I am just following up to see if Alex has had a chance to look into this one. Just let me know if you need more information from me.
  13. LOL! Nobody even uses it anymore since I stopped playing all the MMORPG games. I don't know why I am still keeping it around. Yes, this is certainly possible. You will have to allow VPN passthrough at your router in order to do it, and you will need to enable split tunneling so all the servers traffic doesn't go across the tunnel. My router supports site-to-site VPN, so I just connect to a couple of my friends that way instead. Whether a physical machine or a VM, they are just hosts on the network, so nothing changes with RDP or the way you do it. I RDP into my work machine from my desktop as well. As long as your traffic is local, it does not go though NAT/PAT, even if it is a different network. The only time NAT/PAT are used is when the traffic goes out to or comes in from the internet. Yes, all the data is stored in a .vhdx file. There are other files in another directory that store the VM configuration data and temporary files. You can allow communication between the VM's and the host. This is called a Private newtork/vSwitch type. You would have another NIC to configure on the host, and then add another NIC to each VM to facilitate this communication on any network range you would like. This traffic does not go outside of Hyper-V. Yes, and I am also doing Active Directory and NPS on it. Yes, you will need a license key for W10 the same as always. Microsoft actually stopped doing the free W10 upgrades last year I think it was. This is why my NextPVR VM is actually Windows 8.1. Yes, building the hardware is definitely the easy part. Once you get into installing and configuring the software, you will see that it gets to be a lot! My wife gets upset when I tell her I need to do an upgrade or update something because to her, that means that something isn't going to work. She has to have her TV, and downtime is not acceptable!
  14. @Umfriend I have this same setup at home. Here is very briefly how it is done: Install Server 2016 Standard on your server hardware as normal (USB key, DVD, etc) Once it is up and running, go to Server Manager and install the Hyper-V role A Hyper-V option will then appear in Server Manager where you can right-click on your server and start Hyper-V Manager to configure networking and create/manage virtual machines. When creating a VM, it takes you through a wizard where you configure its characteritics, the most common being CPU, RAM, Disk, and Network You have a few options when it comes to networking in Hyper-V. You can just use your existing NIC as a bridge to carry both host and VM traffic, meaning that all your VM's will be on the same network as the server. You can also configure the NIC as a trunk with your switch to carry traffic for multiple networks on separate VLAN's, meaning your VM's can be on different networks from your host. You can also install a router VM in Hyper-V and use that to route between the VM's and the bridge NIC on your host, meaning your VM's can be on different networks, that do not exist outside of Hyper-V, from your host. In the most simple setup, you would just bridge your NIC and install whatever VM's you want. Hyper-V uses the concept of vSwitches internally. You create a vSwitch if there isn't one by default, allowing the management operating system to share it. Then you just pick that vSwitch for the NIC on all the VM's you create. In my case, I have a trunk between the server NIC and my switch so I can pick the vSwitch for my VM NIC's and then assign a VLAN ID to it that tells it what network (VLAN) it is in. I am running Essentials and Hyper-V on mine against @Christopher's warning, but I do not use the VPN function...that is on my router. I have a VM for Emby, one for NextPVR, and one that runs Apache, ISC DHCP Server, Bind9, MRTG, and TeamSpeak. I hope this helps!
  15. It is very possible, but I had been using pass-through disks for years under both ESXi and then under Hyper-V with no issues until I started trying to record multiple live TV streams at once (only on Hyper-V). All my file transfer speeds from my desktop to the server were always around 112 MB/s, which is about max sans overhead for Gig-E. It would likely have been the same thing transferring multiple files simultaneously, but I rarely ever did that. I was leaning toward drivers under Hyper-V Server because I had just switched to it from ESXi because my HighPoint card was not supported, and I didn't really see any other users here reporting the same issues.
  16. Hmmm, this is starting to look like the same thing we have going in the other thread: http://community.covecube.com/index.php?/topic/1019-damaged-file-system-error-will-not-clear/
  17. The larger disk finally finished scanning and now shows File System Damaged too. I have used the troubleshooter to upload all the logs. Please let me know if you need anything else. ***UPDATE*** When I choose the option in Scanner to repair the disk, I get the following Exception: Task Failed Exception of type 'ScannerCom.Info.TaskStates.Exceptions.ChkdskExce... was thrown
  18. I did try this first, but it complained that there was no mount point...maybe something new in Server 2016. Done! I marked unchecked and was able to get both disks to scan again. The smaller one finished and is reporting File System Damage again, and this one had no issues found on the chkdsk /f /r that ran when I rebooted. I will upload the logs when the larger disk has finished scanning.
  19. Thanks for the tip! I have always used the VPN on my router instead.
  20. I would like to thank everyone for the suggestions here. What I ended up doing was the following: Installed Windows Server 2016 Standard bare metal Installed the drivers for the HP RR Installed DP and Scanner Installed the Hyper-V and Essentials roles to get support for VM's and Client Backups again All seems to be working as expected now. Emby is running on an Ubuntu 16.04 VM and NextPVR on a Windows 8.1 VM. All paths for media, transcoding, timeshifting, and recording pointed to the DrivePool, and it is working great!
  21. Welcome back Christopher! I too am having this problem. It just started out of the blue. Here are my specs: Scanner 2.5.2.3124 BETA DrivePool 2.2.0.742 BETA Windows Server 2016 Standard bare metal install HighPoint RocketRaid 2760A Scanner is now reporting that my system drive and one of the pooled drives have file system damage. I have scheduled the C: drive to be scanned on the next restart with /f and /r options. Here are the chdsk results from the pooled drive: PS C:\Users\Administrator> mountvol F:\ "\\?\Volume{c36115c7-9b09-4dcc-a6eb-e00483938a84}\" PS C:\Users\Administrator> chkdsk /f /r f: The type of the file system is NTFS. Chkdsk cannot run because the volume is in use by another process. Chkdsk may run if this volume is dismounted first. ALL OPENED HANDLES TO THIS VOLUME WOULD THEN BE INVALID. Would you like to force a dismount on this volume? (Y/N) Y Volume dismounted. All opened handles to this volume are now invalid. Volume label is HGST 6TB C1R4. Stage 1: Examining basic file system structure ... 7168 file records processed. File verification completed. 838 large file records processed. 0 bad file records processed. Stage 2: Examining file name linkage ... 12344 index entries processed. Index verification completed. 0 unindexed files scanned. 0 unindexed files recovered to lost and found. Stage 3: Examining security descriptors ... Security descriptor verification completed. 2588 data files processed. Stage 4: Looking for bad clusters in user file data ... 7152 files processed. File data verification completed. Stage 5: Looking for bad, free clusters ... 273236166 free clusters processed. Free space verification is complete. Windows has scanned the file system and found no problems. No further action is required. 5723036 MB total disk space. 4655460 MB in 3439 files. 1792 KB in 2590 indexes. 0 KB in bad sectors. 252179 KB in use by the system. 65536 KB occupied by the log file. 1092944668 KB available on disk. 4096 bytes in each allocation unit. 1465097471 total allocation units on disk. 273236167 allocation units available on disk. PS C:\Users\Administrator> mountvol F:\ /D PS C:\Users\Administrator> Once chkdsk started, I removed the disk from the pool. All of the pool data is duplicated, so I just forced damaged disk removal. It still took a long time trying to remove the poolpart from the disk due to the dismounted state, but the removal process eventually completed. The duplication from that is still running, BUT DrivePool no longer sees the disk at all now that the chkdsk is done, for some reason. I will wait and see if that changes once the duplication is finished. I went to the disk in Scanner and clicked "Start Scan" and now the Scanner UI is Not Responding, and it has been 20+ minutes so far. ***UPDATE*** Scanner started responding after about an hour, and the disk is scheduled for scanning. DrivePool now sees the disk again, but I cannot add it to be pool because it says it cannot be added twice. I will have to reboot or restart the DP service when I can to get the disk back in the pool. ***UPDATE2*** After rebooting the server for updates, the disk is back in DrivePool. Clicking Start Scan on the 2 reported damaged disks does nothing at the moment. No drives are being scanned. I will wait a while to see if that changes.
  22. I had a similar issue that I wrestled with for months. It turned out that the path was too long for the recycle bin. In the end, it was the very simple <shift>+delete under Windows to skip the recycle bin and permanently delete that did it. ***NOTE*** I had tried forcefully taking ownership, changing security permissions, and forcefully deleting, but none of it worked.
  23. The Seagate desktop drives were terrible for me. I now have all Toshiba 3TB and HGST 6TB NAS and have had no failures or SMART warnings since the first Toshibas were installed 2.5 years ago. I had 20 of the Seagate 3TB Desktop drives for which a lot of RMA's had to be submitted prior to the 2 year warranties running out...sometimes multiple drives at once. There are only 2 left in my server now... both RMA'ed units. I have been replacing them as they fail or as they develop SMART warnings. There are only 3 of the 20 that didn't have any issues when they were replaced. If WDC has a higher failure rate than Seagate, then I feel sorry for the people who bought them.
  24. Ok, thanks! I will do some testing per feedback. The only thing I have running on Hyper-V that is not default is Scanner. The only things not default running on the WS2012E VM is DrivePool, Emby, NextPVR, and the HDHomeRun software. The VM has 32 vCPU and dynamic memory running with no limits (The host has 128 GB total) and the VM normally has 10-11 GB in use.
×
×
  • Create New...