Jump to content
Covecube Inc.

Mick Mickle

Members
  • Posts

    83
  • Joined

  • Last visited

  • Days Won

    3

Everything posted by Mick Mickle

  1. (Tried to post this as a support contact, but the contact web pages produce only an error right now.) In Essentials Experience VM of Windows Server 2012 R2, the DrivePool drive letter doesn't show up as a location available for indexing in Indexing Options (see attachments). The Pool drive letter (X:) does display in Disk Management and Explorer and Dashboard. As a result, I don't have ability to stream media remotely (yes, I know about Subsonic ) or to add shared folders on the Server drive X: to my HTPC Win 7 libraries ("not indexed" error). I went back to my earlier two VMs with DrivePool installed, WHS2011 (v. 2.1.0.437) and WS2012E (v. 2.1.0.420), and both had the DrivePool letter in the Indexing Options location. So I don't think this has anything to do with the beta DrivePool version, which seems to have been working great since I installed in WS2012R2E, except for this indexing issue. Is there a way to add the Pool drive letter to indexing or Windows Search locations in the registry . . . . or what? (BTW, I take it that the Re-index option is not in v. 2 of DrivePool?) Edit: Since the Contact page is working again today, I just made a ticket on this. Also found that registry entries for Win8.1 (DrivePool not installed) and WS2012R2E have "invalid entries" for DriveTypes in HKLM\SOFTWARE\Microsoft\Windows Search\VolumeInfoCache\. Those invalid entries didn't exist for earlier Windows versions. Could that be a clue?
  2. Mick Mickle

    Scan Schedule

    Agree -- I've had that problem noticing whether it's highlighted, as well. The interface could use a lot more contrast there.
  3. BTW, I recommend Nirsoft's BlueScreenView http://www.nirsoft.net/utils/blue_screen_view.html. It will tell you if you've had a BSOD (listing all of them recorded) and even give you the old BSOD to look at (Options/Lower Pane Mode/Blue Screen in XP Style), for troubleshooting or just for nostalgia. Doesn't matter if headless or not.
  4. The lock-up and reboot issue is a pain and sorry I can't address that. But I'm wondering if you're using the best method to move your server folders if the data is already on a drive that you just added to the pool. Check out http://community.covecube.com/index.php?/topic/297-new-drive-pool-created-what-about-existing-data/ and make sure you can't just move existing folders into the "PoolPart.xxxx" folders with Windows/File Explorer. If that doesn't apply, sorry I didn't understand your situation well enough. Of course, you've still got to copy folders that reside on totally different drives, like your USB backup. But I personally wouldn't use Dashboard to do that. I'd use Windows/File Explorer (or TeraCopy) in the RDP session and copy from the source drive into the appropriate folder in ServerFolders in the drive letter for the DrivePool.
  5. Yeah, the first corrupted install was my fault. I keep my software installation files on a shared folder on the Pool. I installed from there and while that was going on I got ahead of myself and removed the pool drives from the vm to make them available for the host. So the installation failed at first. Duh!
  6. Works now -- got the pool okay. It must have been a corrupted installation of DrivePool. I recall that the installation failed, I had rebooted and successfully installed over the failed installation. Finally, I did a complete uninstallation, then deleted all remnants on the C drive and in the registry, rebooted, and reinstalled. That did the trick.
  7. Roger. And all the drives in the pool are listed as outside the pool in the DrivePool UI.
  8. Christopher, As you know from my new support contact, removing the drive didn't help, and the lockup still happened after duplication completed. So, I decided that one thing I haven't tried yet is too move the pool to the host and see if the problem still exists on the host, as opposed to the VMs. However, I've run into a problem with DrivePool not recognizing the existing pool. (I didn't want to complicate the support contact issue, and this subject is a perfect continuation of this forum thread, anyway.) I installed DrivePool 2.0 current release in 30-day trial mode on the WS2008R2 host and put all the pool drives online (previously in offline pass-through mode to Hyper-V VM). But DrivePool doesn't show the pool or create the new pooled drive. I've tried rebooting and resetting DrivePool according to the wiki. And I can't "add" any of the pooled drives to, because the error detail says can't add the drive twice. (So really, it does know there's a pool!) What now?
  9. I did remove it. DrivePool is now duplicating. So I'll be testing the pool out without that drive for a while, as you suggested.
  10. Yeah, there are 64GB of client computer backup files on the Samsung drive, and duplication is turned on.
  11. Touche on woulda, coulda, shoulda. How would "removing" one drive after unplugging it to get DrivePool running normally affect client backup database? My concern is that the backup service would decide it's corrupted. Of course I could stop the backup service, but then that wouldn't be a full test of DrivePool. (Maybe client computer backups folder isn't on that disk, though. I'll check.) On 255 character path, could you confirm with Alex?
  12. I don't think the PSU cable would have damaged the HDD circuit board. Any cable defect would have only been the mid-cable connector may not have been crimped well enough to keep an intermittent open circuit from occurring. That would have, at worst, been similar to hot plugging a SATA drive. No, I haven't removed the Samsung drive from the pool. If I do, DrivePool will just complain that the Pool isn't intact, so it won't execute measuring, which is when the freeze occurs. (And I hate to migrate everything off an apparently good drive for testing.) I do wonder about DrivePool handling of > 255 character paths and whether that's a factor.
  13. I think you hit on the situation correctly, DrivePool is bringing out an underlying problem. I just can't figure out what it is. I ran memtest86+ on the 12GB of RAM for about 8 hrs yesterday - no problems. All 9 of my HDDs pass all the tests ok except one which has 7 reallocated sectors in SMART, otherwise stable. Because I had one drive drop out apparently due to a faulty intermittent factory power cable connection, I replaced the PSU with a new one today. Still hangs when I run the DrivePool UI! Please do me favor and bump 8209559. I also uploaded a dump on Nov 24 that I forgot to key to that support contact, and I'm not sure the upload completed.
  14. Here's my 2 cents, for what it's worth: My number one choice is TeamViewer. I've been using it on my Android devices for over a year now, and it works great to get to PC desktops. (And it's free for personal use. TeamViewer also has versions for iPhones and Windows 8 phones.) Basically, it's like RDP to the PC of your choice (after you install it on the PC as well). And it has a file transfer mode. If you set up a free optional account with TeamViewer, then you can pick and choose which computers you want to connect to at any time. For some reason -- limited access, I guess -- I haven't installed TeamViewer directly on my server. Instead, I RDP into the server from the client computer that I connect to with TeamViewer. One other nice thing about TeamViewer is that, in some ways, it can subjectively outperform RDP across the Internet when calling home with your laptop. The second thing I've been using is AiCloud, which is embedded in current Asus Routers (RT-N66U/R is the one I have). With AiCloud, you can play music and video files directly from the server to your device, and you can wake any of the computers on the router. There's an iOS version in addition to Android, but I'm not sure about Win8RT. I've also used ES File Explorer around the house to get files from the server to my Samsung Galaxy SIII and Motorola Xoom on the LAN, but not so much anymore after discovering TeamViewer.
  15. I did run sfc /scannow and did have some corrupted system files which were fixed. (I actually have a command file to run the System File Checker with a pause at the end in my "+Utilities" Start Menu /All Programs folder, which I always create with my most important and useful utilities for any OS. But I hadn't run it in many moons.) However, I will need to get the pool back to WHS2011 to test the difference. I would say that wasn't the cause of the problem with the DrivePool service freezing the VM because the problem is also happening on WS2012E. But, SFC also found and fixed a corrupted file(s) there. Nevertheless, that guest still freezes when DrivePool service is measuring.
  16. Why not use the upload link at http://wiki.covecube.com/StableBit_DrivePool_2.x_Log_Collection? I believe the contact form is limited to 10MB attachment.
  17. Ref: Subsonic. I've been using Remote Potato for about 2 years now. Although it's no longer being developed, except for Windows 8 and 8.1 upgrade packs, the 1.06 "stable" version is free and has worked great. Streams movies (including mkv) to my Android devices and computers across the Internet at various levels of quality. Works best with a Silverlight client in Windows. Use free Remote Media Center to connect in Android, and they recommend MX Player -- but I use the stock video player in Android 4 with super results. The only weakness I've found is that, although you can password protect web connections, you can't make an SSL connection.
  18. This thread has split into at least two topics: (1) The original File System Check (or Health) and (2) Disparity between what Scanner is reporting and sector unreadable messages. I'd like to bounce back to the original topic -- After moving a DrivePool pool from WHS2011 to Server 2012 Essentials Hyper-V guest, Scanner is scanning all disks as never been checked as expected. However, after scanning the VHD ("Virtual HD ATA Device") which contains the 160GB C: drive and 350MB System Reserved partition, Scanner won't check the file system. This is the second example on my computers where Scanner won't check a partition's file system. As noted further up this thread, Alex knows some anomaly exists and is checking into it. I'm just reporting another instance.
  19. Hey, no big delay -- you're always on top of things, and I appreciate you taking the time. This is exactly the guidance I was soliciting. It's all pretty smooth, as you said. But also as you said, the NTFS Security permissions is an issue to deal with. On first "import" of the pool from WHS2011 to Server 2012 Essentials, the Security properties has all of the "Account Unknown" user names from WHS2011. So it's apparent that they would be reinstated properly upon the pool's "return" to WHS2011. However, if you allow Server 2012 to touch a folder to share it, either by adding an existing folder as a server folder through the Storage tab of Dashboard or turning the Media Server on in Dashboard (affecting existing Pictures, Music, and Videos folders), I noticed that all the Account Unknown user names are purged. So I assume that when the pool is returned to WHS2011, those folders will need to be re-shared with intended users. I'll say that this exercise of moving the pool is being fruitful, in that I'm not having any of the problems yet that have been long-term issues with WHS2011 VM freezes using DrivePool and Scanner since last Spring. So, while it's too early to know for sure, it's likely a software incompatibility or corruption that got introduced over time into the WHS2011 VM rather than host or hardware problem source, or it could be specific to a WHS2011 idiosyncrasy. Thanks, again.
  20. I went ahead and pulled the trigger. So, I guess I was using the above to think out loud. Looks like no need for step 2, renaming Client Compute Backups folder on the pool. WS2012E doesn't give a whit about that folder since the pre-defined folder for that OS isn't on the pool to start; it would just be another folder with same name on a different drive. Also, no problem with access permissions due to an execution of WSS Troubleshooter a couple months ago, which left "Authorized Users" and "Users" in the security settings for the pool's ServerFolders. (I see you've added the recommendation to remove them in the WSS Troubleshooter instructions to get back full security.) So once WSS Troubleshooter Reset NTSF Permissions on Pool has been used if you make on other permission changes, access should be open on folders in ServerFolders regardless of where you stick the pool, before or after you move it. So far, both WS2012E and DrivePool (with Checking at about 80%) seem happy. We'll see how the measuring and balancing go.
  21. Christopher / Alex, Please comment on the portability aspects of moving a Pool from WHS 2011 to Windows Server 2012 Essentials and back. I'm posting this question here rather than in a support contact because the general information and guidance can also apply to what other users might want to do. Basically, for testing or trial purposes, what steps and precautions should be followed to move a full pool of pass-through disks from a VM with one OS to another VM with a different OS and back again without risking data loss on the pool? I think this would also apply to moving the pool intact between different computers or motherboards or upgrading then reverting OSs. Scenario: As you know from my previous support tickets (640360 & 8209559), I've been having trouble with freezes of my WHS2011 VM (Hyper-V) when the DrivePool service is manually enabled (even running minimal msconfig settings and without the Scanner service). This occurred with the latest v 1.3 and also after I upgraded to the latest release of v 2. Usually the hang will occur at some point during the measuring stage; for some boots, though, the DrivePool service enters a steady state and presumably executes its management tasks okay. I know that I can operate this way indefinitely without data risk if I keep in mind what Alex told me that I've pasted into the end of this post for the benefit of all. But after exhausting much of my hardware and software troubleshooting resources, I'd like to move the full single pool of 7 HDDs (16.7TB) to a VM with Windows Server 2012 Essentials to see if the problem disappears. If it still exists, the root of the problem will probably by the host hardware or software. However, I'm not prepared to commit to that server upgrade change from WHS2011 yet, so I want to be able to reattach the hard drives to the WHS2011 VM. Naturally, I don't want WS2012E to massage the Client Computer Backups folder on the pool and declare the backups corrupt. (The current native WS2012E Client Computer Backups folder is with its other default server folders on the system C: drive now, so I'm thinking that WS2012E won't automatically try to connect to the similar folder on the DrivePool pool. Still, . . . . . .) Here's what I think I need to do. Please correct me where wrong and let me know what pitfalls are in store: Steps: 1. Install DrivePool 2 into WS2012E VM and shut down. 2. In Windows Explorer, rename (slightly) Client Computer Backups folder in the DrivePool drive's \ServerFolders in the WHS2011 VM (will cause a pre-defined server folder missing error and stop the Windows Server Client Computer Backup Service) and shut down. (?? - Not sure this is necessary as a safeguard to keep WS2012E from playing with it after the pool is moved.) 3. Remove the physical hard disks from the WHS2011 VM using Hyper-V Manager. 4. Add the physical hard disks to the WS2012E VM. 5. Start the WS2012E VM. DrivePool should find the full pool intact. 6. Run the WSS Troubleshooter Reset NTSF Permissions on the Pool and Restore DrivePool Shares. (?? - Not sure this is necessary unless the intent is to keep the pool on the new server, particularly if the plan is to return to the old server.) To return the pool to the previous server: 1. Shut down both VMs. 2. Remove the physical hard disks from the WS2012E VM. 3. Add the physical hard disks to the WHS2011 VM. 4. Using Windows Explorer, reverse renaming of Client Computer Backups folder in Step 2 of first move above. 5. Run WSS Troubleshooter Reset NTSF Permissions on the Pool if it was done for Step 6 above. 6. You should be back to where you started. __________________________________________________________ Using DrivePool without the service: In reference to my statement above that the DrivePool service doesn't have to be run in order to use DrivePool (provided you have sufficient free space on all pool disks), I thought I'd include this clarification that Alex provided me in a support contact concerning data risk -- Q. "What are the risks for regular use (of DrivePool with the DrivePool.Service.exe service disabled) until the service is re-enabled?": A. •Risks to data integrity: ◦If you have real-time duplication enabled: NONE. ◦Background (or nightly) duplication will not function. •No pool management. ◦You will not be able to add / remove disks from the pool or perform any kind of pool management. •Risks to running out of disk space: ◦There is a complicated mathematical model that we use to re-balance your pool to provide maximum available disk space for duplicated files. This will not function with the service disabled. A simple example of this (but it can get much more complicated): ◾You add a 100 GB disk (#1) to the pool. ◾You fill that disk up to 90 GB. ◾Then you decide to add another 100 GB disk (#2) to the pool. ◾Your pool is now 200 GB in size with 90 GB used. BUT, you can only copy 10 GB of new duplicated data onto it because disk #1 only has 10 GB free. ◦So if the service is not running, you risk running out of disk space. In short, the service is not involved in reading or writing data to or from the pool. But maintenance and administrative tasks will not function.
  22. Just thought I'd chime in to say I have one IDE drive that Scanner has never checked the file system on, even if you mark all sectors unchecked and rescan. Sure, I can use chkdsk, but the Scanner feature should do it. But I do love Scanner.
  23. Yes, you can use DrivePool and Scanner in a VM, but you'll need a second copy (license) of Scanner on the host to read the SMART information. SMART data doesn't pass through to the Hyper-V guest. See the pinned threads in the Scanner - General section of this forum. (However, I don't really understand why you would be passing through an HDD in a RAW state. I format mine on the host.)
  24. Got it! I recommend that you elaborate a little in the Wiki instructions for the WSS Troubleshooter under the Reset NTSF Permissions section. While the intent of the tool to leave the pool in a fully accessible state is appropriate to restore full capability, the server folders aren't in the secure state they were in when created using Dashboard. Even after you adjust all of the users' folder access levels back to where you want them, "User X", who you don't trust to access anything but a Public folder, will have access to all of them until you delete the "Users" and "Authenticated Users". I like the idea of applying the removal of those two user groups in one sweep at the ServerFolders level on the DrivePool disk. But it requires turning "off the option for inheriting permissions." It looks like that's done under ServerFolders Properties/Security/Advanced/Change Permissions, but unchecking produces a warning box that there could be consequences. So that would need to be explained step-by-step, I think.
  25. Thanks. One point of clarification now, though: At what point do the folders become accessible only according to how users are supposed to be setup in Dashboard? In other words, after the reset of NTFS permissions using WSS Troubleshooter, everyone has effective access -- that's according to design as you explained. But Dashboard says "No access" for all users at that stage. Setting a user to "Read/Write" for all applicable folders will take effect when the changes are applied. However, it would seem that each and every user and folder would need to be "touched" by the Dashboard Shared folders/Users access setting tool in order to restrict access as desired. If you don't explicitly change a user's folder access, does that user still have the "everyone" access even though "no access" is displayed in Dashboard? The behavior of the NTFS permission state after WSS Troubleshooter is important to be clear on, especially if you have lots of users with remote access (or even just a few LAN users but you want to ensure appropriate access).
×
×
  • Create New...