Jump to content

I have to ask, what is the deal with drives and sleep? or lackthereof?


Recommended Posts

Brand new windows install.  drives are sleeping as expected, as they should. 

I install stablebit suite and poof, no more sleep once again.  I can literally watch the light on my single external disk in a dock flicker every 5-6 seconds.   what are these guys doing in that timeframe on repeat?

I have a work window set on scanner.   all my drives are already checked/healthy/not due.  I have SMART set to only query during the work window or scanning of which it is neither.   I dont know what else to do.  on my old windows 10 install i entertained the fact it could have been a combination of any number of things i had running in tandem/under the hood  (even though it was unlikely) but now with a fresh install of windows and watching it happen the second i installed these guys......

anyone able to offer some suggestions/guidance?  I'd already throttled the queries out to 12 hours and it didnt help or change anything.  leads me to believe its not the smart, but something else under the hood. 

is it even scanner, could it be drivepool itself or clouddrive? 

Link to comment
Share on other sites

so just did some more testing.   stablebit installs 5 services.  I disabled them all one by one and watched.  the final one to disable was DrivePoolService.  Voila, perpetual pinging disappeared.

Here the entire time i figured it was scanner, its drivepool itself.   so why is that hammering my drives in perpetuity and how do i fix it?  I have auto balancing off, I have every single plugin disabled except for ordered file placement.

is it some kind of unintended bug or?  Summer is coming and a 10x room with 24 of these 7200rpm badboys spinning next to me is no bueno.  

Link to comment
Share on other sites

okay, did one final test here for posterity.  i did a balancing pass (decided to give up on ordered file placement) and after it was finished a day or two later i disabled automatic balancing.  i disabled ALL plugins.  there was nothing left but drivepool itself running. 

still, pinging and keeping my drives awake every 5-6 seconds (my one, one-thousand, two one-thousand, may not be the most accurate) but on queue i can watch it blip the light on the drive closest to me. 

this speaks to something underlying that drivepool is doing.  i even thought it might be controller based but a drive on a different controller and not in the pool altogether is still being kept awake. 

as a new user im not sure if this is something to manifest itself as of late as i've heard people speak about sleep/spindown in the context of drivepool during my research so assumed it worked.   aka should a ticket be put in or the dev be made aware?

Link to comment
Share on other sites

  • 10 months later...
  • 10 months later...

hi.  this is basically just a repost of one of my earlier posts about stopping DrivePool polling/pinging drives every few seconds...  i too prefer my drives to spin constantly, however if you seek to have your drives sleep, this action must be performed prior to adjusting Windows settings to allow sleep, or else your drives will just spin all the time anyway because of the pings/polls.  cheers


in windows/file explorer enable 'show hidden files and folders.'  then go to:

https://wiki.covecube.com/Main_Page  and bookmark for future reference.  from this page on the left side click StableBit DrivePool > 2.x Advanced Settings. 


if you are using BitLocker to encrypt your drives you will NOT want to do this, and will just have to live with the drive LEDs flashing and disc pings i assume. i don't use it so i don't know much about it.

the given example on this page just happens to be the exact .json setting you need to change to stop DP from pinging your discs every ~5secs.

set "BitLocker_PoolPartUnlockDetect" override value from null to false as shown.

if StableBit CloudDrive is also installed you will need to change the same setting for it also. opening either of these json files, it just happens to be the very top entry on the file.

you may need to give your user account 'full control' on the 'security' tab (right click the json > properties > security) in order to save the changes.

this worked immediately for me, no reboot necessary. YMMV...  good luck :)

Edited by VapechiK
add additional info
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...