Jump to content
Covecube Inc.
  • 0

Removing a nested pool


Question

A bit of an odd issue which will probably be easily resolved, but since I'm not sure how it happened I'm hoping to get some insight before I just start clicking buttons.

I've had a DrivePool with 10 drives as 'DrivePool E:\' for a long time and recently removed a disk due to hardware failure. It was detected by StableBit Scanner and data was moved off, worked nicely. Today I noticed I have a new pool, 'DrivePool D:\' which contains the original drivepool. In DrivePool I can move between the two pools, and on E: it notes 'This pool is part of pool DrivePool'.

Pool E: lists my 9 remaining drives; pool D: lists just the single E: DrivePool virtual drive.

When I view the individual drives there is only a single PoolPart.* folder which is what is confusing me. I was kind of expecting there would be nested folders, since it is a pool within a pool. I didn't intentionally create this so I'm wondering can I just remove the pooled E: drive from the DrivePool D:\ and return to having a single pool or is that going to confuse it and throw everything into disarray. I was browsing the forums and got the impression nested pools weren't supposed to be a thing.

Thanks in advance.

 

pool_d.png

pool_e.png

Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

That is odd. Still, if there's no files in D:\ when you look at it in explorer then you should be able to safely Remove the E:\ "disk" from the D:\ pool and thus delete the D:\ pool without affecting the E:\ pool.

Link to post
Share on other sites
  • 0

Upon further investigation I think this was created, somehow, by StableBit Scanner. When it detected the damaged drive I had it attempt to recover files and the export folder for those was to be the root of E:\Public, but for some reason it may have made an entirely new drivepool. No idea how or why. It didn't put them in E:\Public but created D:\Public.

It does appear the two drives should have the same contents but they don't:

image.png.293319f3248fd794c6de91c2161383f5.png

 

DrivePool(D:) only actually has 7 files totaling 231 GB, which are the 7 files that were restored during the StableBit operation. There are no hidden files, no poolPart folders on this disk. It isn't a physical disk. It is, somehow, a pool that only shows the recovered files and they already also exist on the DrivePool (E:) - I was able to find them in a poolPart folder on one of the disks that make up that pool, with a file modified time from when they were moved off the damaged disk. So, this D somehow contains essentially 7 pointers to files on other disks. There is actual content in the file, so the pool part is pointing to two places? I don't get it. I didn't think a pool worked like this, where a file can be in two different pools simultaneously, or that a pool could contain only 7 files from a disk and not the entire contents of the drive. I'm reluctant to change it since at this point I don't really have a reasonable expectation that simply removing E: from the D: pool will set it back to normal. 

I suppose, worst-case, the pool can be re-created from scratch and the data won't actually be lost. Quite odd.

 

Link to post
Share on other sites
  • 0

For anybody who comes across this thread in the future with a similar issue:

I wasn't able to ultimately figure out how this occurred but I decided to remove the E:\ pool from the D:\ pool using the default removal settings and that removed the extra drive letter. A SnapRAID scan of all the constituent drives that comprise my E: pool didn't find any unexpected changes, so it appears to have been a safe operation given limited testing.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...