Jump to content

Stablebit Scanner makes drives disappear ???


Recommended Posts

Hi! I recently started using Drivepool and I love it. I wish I knew about it sooner.

I have a serious issue with Scanner though, which prevents me from using it alongside DrivePool. For some reason, when I install Scanner, the system seems to do a lot of work in the backgroud, the scanner UI doesn't come up (starting service stuck for ever) and one by one my disks disappear from explorer and from Windows.

The first time I installed it, it was marking my disks as full of errors, basically it was marking every sector as faulty until eventually the disks dissapeared altogether, not only from Explorer but from Disk Management too. I uninstalled, cleaned residual files and re-installed. The same thing happened on my second and third attempt. Uninstalled, cleaned residual files and ran a disk check on all disks that found no errors (Windows command line and HDD Scan). I had to reboot with Scanner uninstalled for the drives to appear on Disk Management. Then I assigned letters to the drives and decided to go without Scanner.

Scanner wouldn't read SMART data, while Crystal Disk Info and HDD Scan would.

Whenever I tried to restart, while Scanner was installed, I was getting a blue warning screen saying that some programs are preventing the computer from shutting down, specifically: "Task Host Window : Task Host is stopping background tasks. (\Microsoft\Windows\International\Synchronize Language Settings.)" plus one more "button" which showed as an empty button below the Task Host. I had to force shut down by switching off power (image attached).

I would love to be able to run Scanner alongside Drivepool, but I'm afraid to install it again. It's very stressing to see my disks marked completely corrupt and disappear all of a sudden, when there seems to be no issue with them.

I also tried Scanner on my laptop with some other external disks I had lying around and it worked fine. Is it a hardware incompatibility issue? I read in other messages in the forum that you ask for a troubleshooter report, but frankly I'm too afraid to install the programme again so I can generate a report.

My PC runs Windows 10 20H2 Build 19042.685 and my Drive Pool disks are:

  • 2x USB 3.0 WD My Book 8T (brand new)
  • 1X USB 3.0 4TB Intenso Memory Center (~3 years old)
  • 1X USB 3.0 WD My Book 3T (~4 years old)
  • 1X USB 3.0 Seagate Expansion External HDD 2ΤB (~3 years old)
  • 1X eSata 4-bay Fantec enclosure with 4X SEAGATE BARRACUDA ST4000DM004 4T (~3 years old)

The rest of the PC specs are as follows:

  • Gigabyte Z77x UD5H
  • Intel i7 3770k (not overclocked)
  • 32GB RAM
  • Nvidia 1070


Any help would be much appreciated.

Thank you!

Link to comment
Share on other sites

That's very, very unusual.

If you could, open a ticket at https://stablebit.com/Contact 

Also, information about what controller card you're using would be very helpful, too.

And are the drives that are disappearing just in the eSATA enclosure having issue?  Or is it ALL of the drives? 


But given what is happening, my guess is the load that StableBit Scanner is producing by attempting to scan the drives is causing the USB controllers to crash.  This isn't typical, but it's not unheard of, unfortunately. 

Link to comment
Share on other sites

I am using the motherboard's USB 3 ports not a separate controller card.

As for the eSATA enclosure, it appears to be the most stable. It is the USB 3 drives that are disappearing and are flagged as bad.

4 hours ago, Christopher (Drashna) said:

But given what is happening, my guess is the load that StableBit Scanner is producing by attempting to scan the drives is causing the USB controllers to crash.  This isn't typical, but it's not unheard of, unfortunately. 

This is what I was thinking too. If I boot up with no drive attached, install Scanner and then start connecting them one by one? To see if they function properly in low load. Do you think it's worth trying that for troubleshooting purposes?

I expect my Pool won't be affected if I do that, right?

Link to comment
Share on other sites

It may be worth trying that, yeah.

And if that works, it may also be worth trying to set the StableBit Scanner Service's startup to "Automagic (Delayed)" and see if that helps. 

14 hours ago, ZagD said:

I expect my Pool won't be affected if I do that, right?

You'll see drives show up as missing, if they're in a pool, but will be detected if they're re-added. 

Link to comment
Share on other sites

I think it's the USB controller of the mpotherboard that is not handling the traffic. Here's what I did.

I booted up the PC with only the internal SSD's, no external drives were connected, nor the eSATA enclosure.

I installed Scanner and let it scan the internal SSD's (not part of any pool). It went without issues.

Then I started connecting one by one the external drives. First I connected the two 8TB My Book drives which were plugged in the front panel. No issues.

Moving to the rear ports, I connected the 4TB Intenso Memory Cente. No issues.

When I connected a second drive to the rear ports (2TB Seagate Expansion), problems started appearing. The drive would show up in Explorer but not in Scanner. Then even though its icon would still be there in Explorer, it would act as if it wasn't. I couldn't open it and the bar that shows how full a drive is would disappear until the drive would dissapear completely.

I stopped there, shut down and disconnected all drives. Booted again, uninstalled Scanner and started connecting the drives again. Everything was fine with the drives and the Pools, except that they had lost their drive letters and I had to reassign them. This issue of losing drive letters had happened in my previous attempts too, I had to go to Disk Manager in order to be able to re-assign a letter.

I guess that's it for this computer for using Scanner, but I'm writing this so maybe others who experience such behaviour would know that this can happen. I am waiting for a powered USB hub to arrive and the last test I will make is with the rear plugged drives to go through the HUB. If it works I'll post an update.

Link to comment
Share on other sites

Fair point. I'll run that test too when the powered HUB arrives and will update you. I want to minimise my attempts for fear of something going wrong with the disks. It's really stressing to see them disappear even if they come back eventually!


Link to comment
Share on other sites

  • 2 weeks later...

So... it appears that the problem is created by the 2TB Seagate Expansion drive. I connected everything, minus the Seagate drive and everything was running smoothly. I left the computer on overnight and forced scan all the drives, no errors were found and no glitches happened.

Then, I added to the pool two more drives I had lying around (2TB Seagate ST2000DM001) using an external double docking station. No issues.

I shut down the computer, disconnected everything and booted up with no external drives. Then, I connected just the Seagate Expansion drive (which I deliberately left out in all previous tests) and voila. Scanner started registering thousands of errors, the drive eventually disappeared and the computer started acting very funky, to the point of freezing and not being able to shut down or restart. This strange message I reported in my original post also appeared during attempted shutdown and restart

"Task Host Window : Task Host is stopping background tasks. (\Microsoft\Windows\International\Synchronize Language Settings.)"

Finally, I disabled the Scanner services, rebooted, reconnected everything, including the Seagate Expansion drive, and all is working fine.

There seems to be some conflict between the drive and Scanner. When scanned with HDD Scan and CrystalDiskInfo, no issues are found.

Link to comment
Share on other sites

  • 2 years later...

I found the reason for this strange behaviour.

I shucked the 2TB Seagate drive that caused the issue and placed it in an external enclosure. It wasn't immediately recognised, because there was some sort of "locking" at the drive's USB controller level, so after removing its controller it would appear as non-initialised in Windows.

I re-connected the shucked drive to its original controller and copied its contents to another drive, then used the clean command in diskpart, re-initialised it, copied back the poolpart folder from the intermediate drive and reconnected it to the pool. Everything went well and the drive was recognised without a glitch.

Now that the drive is in the enclosure and not in its original case with the "locked" controller, Scanner works fine and no more strange disappearing acts occur!

In short... the original drive's USB controller 'dunnit.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...