Jump to content
Covecube Inc.
  • 0
Sign in to follow this  
Bulkhead

LSI00301 9207-8i, SAS2 2308 Mustang HBA Win10 Best Practices

Question

Hello All, new user of the StableBit tools and thus new member of the community facing yet another learning curve (do they ever end in the world of computers?)
 
I recently installed an LSI SAS2 2300 Mustang (2907-8i) HBA into a new build and have 4 drives connected to it. I installed StableBit Scanner but it is not reporting SMART data for any of the drives on that card. It does report data on my drives attached to the motherboard data ports as well as my Nvme drive. 
 
I've poured over forums looking for recent information but cant find anything definitive.
 
I've tried HDSentinel but it couldn't report SMART info either.
 
Is there something I can do to get access this data? I have not checked nor updated the card firmware nor do I yet know how. I have seen conflicting information regarding the need to flash the card and install drivers under Windows 10 Pro.
 
I would greatly appreciate guidance and thanks in advance!

Share this post


Link to post
Share on other sites

24 answers to this question

Recommended Posts

  • 0

So I don;t really know. I have a SAS HBA, an IBM1015 butcalled Dell H310 or somesuch. I never understood the LSI chip/card numbering.

In any case, I did have to get the latest bios for my card, P20* or something. Also, with Scanner, I had to Settings -> Advanced Settings and Troubleshooting -> Advanced Settings -> DirectoIO -> Unsafe check. Never had an issue with that and SMART is read. I would try the Scanner setting first, reboot and see how it goes.

Share this post


Link to post
Share on other sites
  • 0

has the card been flashed to IT mode - if not thats why you cant get smart info - as the card is controlling the disks - which is fine but not what you want in your use case

IT mode - allows the disks to be passed (untouched) to the system and then scanner etc will be able to get the smart info

IT mode info and how to do it is available via your friend called google :)

Share this post


Link to post
Share on other sites
  • 0

Hey thanks for the replies.. I have not made any changes to the HBA whatsoever - so if it is in IT mode then it is so because it was shipped to me that way. I don't know what mode it is in, but I will start the process to figure that out. BTW: I have the 9207-8i which as I understand it and intended, it is not a RAID controller just a simple HBA, so would it still be capable of IR mode or would it by default already be in IT mode?

I had a hard time tracking down the drivers just because my card is difficult to find on the Broadcom site since it appears not to be a current generation card. I finally figured it out I think..

So, stupid question, but I have not found a current answer to this: do I need to BOTH update the ROM on the card (and to what version?) but do I ALSO need to install a driver?

Also on my mind is how do I know if the card is working as it should be and optimally?

thx

Share this post


Link to post
Share on other sites
  • 0

to get IT mode you need to flash the card with the IT firmware when you find it

as to which firmware - go with latest you can find - as the card is old and not that common you might find it a challenge and firmware might not have been updated in a few years but thats not a problem

IT mode basically sets the card to just pass thru the disks to windows - windows will load a driver for your card usually - more likely with windows 10 than older windows versions

 

my 9211-8i drivers in 2012r2 show as from 2014 and are from Microsoft as the card was available straight away after installing OS - i did not load any drivers / firmware is P20 - and in IT mode it just works with 24 drives connected (have a sas expander)

If you cant find firmware for the 9207 - and as they are so cheap on ebay - get a 9211 as they are more common etc and easier to find firmware for etc

Share this post


Link to post
Share on other sites
  • 0

Well, I've been able to locate the firmware and flashing tools but cannot get them to work so still figuring that part out. I'm on a brand new motherboard that may not support so I may have to move the card to another machine to flash it.

However I did see that the card appears to be in IT mode already although on firmware version 18. The most recent looks to be 20.

LSI Corporation SAS2 Flash Utility
Version 20.00.00.00 (2014.09.18)
Copyright (c) 2008-2014 LSI Corporation. All rights reserved


        Adapter Selected is a LSI SAS: SAS2308_2(D1)


        Controller Number              : 0
        Controller                     : SAS2308_2(D1)
        PCI Address                    : 00:04:00:00
        SAS Address                    : 500605b-0-08b4-12a0
        NVDATA Version (Default)       : 11.00.00.05
        NVDATA Version (Persistent)    : 11.00.00.05
        Firmware Product ID            : 0x2214 (IT)
        Firmware Version               : 18.00.00.00
        NVDATA Vendor                  : LSI
        NVDATA Product ID              : SAS9207-8i
        BIOS Version                   : 07.35.00.00
        UEFI BSD Version               : N/A
        FCODE Version                  : N/A
        Board Name                     : SAS9207-8i
        Board Assembly                 : H3-25572-00C
        Board Tracer Number            : SV41229996


        Finished Processing Commands Successfully.
        Exiting SAS2Flash.

My intent has been to install SnapRaid but my understanding is that access to SMART data is important for that tool to perform it's function.

Is there a setting I need to change on Scanner? 

This is what I see when right clicking a disk and choosing Disk Settings for any of the disks attached to the card:

image.thumb.png.acb64663279f91cdf88913fe0faafa09.png

Share this post


Link to post
Share on other sites
  • 0

OK, I've flashed the card to the latest version and it is in IT mode. I also updated the card BIOS to the latest version:

image.png.bc45874569f181268208194941c36331.png

 

The odd thing is it appears I can see the SMART data with CrystalDiskInfo:

image.thumb.png.def6f8762438c6c2a750acc85afeeda9.png

Will StableBit Scanner work for me or is there a setting I need to change?

Thanks again

Share this post


Link to post
Share on other sites
  • 0

do all drive have no smart in scanner?

there are settings to force reading/ bypass so things

cant remember the details but try searching the forum this has come up before

Share this post


Link to post
Share on other sites
  • 0

Umfriend - thx. I had not seen that option before but just found it and will explore using the settings within.
 

Spider - thanks. In the screenclip above you can see that the drives connected to the SATA controller on my motherboard are all showing SMART data and I can read SMART data with the CrystalDisk utility. I can only conclude that it is an issue with StableBit Scanner..

thx for your input thus far. I'll keep searching for an answer

B

Share this post


Link to post
Share on other sites
  • 0

huh - must be missing something

the fact that disks connected to a sata controller on the motherboard give smart info - is not what your OP was about - i would be surprised if they did not

its the disks connected to your sas card we were discussing are did we get this wrong????

Share this post


Link to post
Share on other sites
  • 0

Thanks Umfriend - that got it working. I had missed the "Advanced settings and troubleshooting" option at the bottom of the Scanner diaglog box on the General tab. I think the dialog was not fully expanded and I didn't look down there for it.

Is there a resource that describes the options on this dialog and the tradeoffs with using them? Is it "safe" to have the "unsafe" option checked?

Spider - you are correct I was having issues with the disks connected to the LSI HBA. They were the ones (4) that Scanner was not providing SMART data for. Scanner was functioning correctly on the disks connected to the mobo controller. I have 10 disks in total - 6 on the mobo and 4 on the LSI HBA.  The "unsafe" option got Scanner reporting the SMART data now for those HBA connected drives.

The question is what risk is there to using the "unsafe" option?

thx all!

Share this post


Link to post
Share on other sites
  • 0

even weirder is i dont have that enabled and i can see the smart for all disks connected to my 9211 sas controller

 

question - did use use windows to format the disks via disk manager or some other utility?

Share this post


Link to post
Share on other sites
  • 0

Apologies to any and all for continuing to seek assistance on this issue, but I really like the integration between Scanner and DrivePool (which has worked flawlessly for me in pre-purchase testing), so I want to get Scanner working.

 

Should I reinstall the Scanner software to get it working?  If I do that, I assume it would need to scan all my drives again - is that correct?

I just don't understand why / how it worked and now it doesn't again.. very frustrating and I'd like to resolve the issue so I can buy the software.

Could there be a setting in the BIOS that impacts the way scanner communicates with my drives via the HBA?

Also, as I make changes to settings in Scanner I think I read somewhere that I need to restart the scanner service. If I do that will scanner retain the history of "last scanned" on my drives or will it rescan them all? It seems its behavior is inconsistent in this regard..

Share this post


Link to post
Share on other sites
  • 0

1 if you re-install it might but you can "just" set all the disks to scanned/good - it part of the gui

2 something odd with your setup i think regarding working not working - i wonder if it might be a dodgy card

3 might be in the card bios but not the m/b bios

4 restarting the service will not do that its the "same" as rebooting you PC

Share this post


Link to post
Share on other sites
  • 0

I think it is the Scanner software because I consistently get the S.M.A.R.T. data from CrystalDiskInfo..

I'm going to attempt to uninstall and then reinstall the software.

Where is the scan history is stored so I can attempt to retain it?

Share this post


Link to post
Share on other sites
  • 0
OK - I found the issue (for me). MS Virus & Threat Protection has prevented Scanner from seeing the drives attached to my HBA.
 
At this point I don't even know if any of the Scanner settings changes, including the one documented above, made any difference. I have seen the impact real-time protection has on even my new, pretty robust pc, and have made a habit of disabling the real-time protection. Windows, inexplicably, occasionally re-enables the feature. The result has been that when I made changes that may have resolved the issue with Scanner seeing SMART data on my drives, Windows has prevented me from seeing the correct result because it had re-enabled the real-time protection without my knowledge..
 
Anyway,  in the image below you can see that Win has blocked the scanner service executable. I have add it, as well as the .native Scanner service, to the list of excluded programs and can confirm it has solved the issue following a reboot of my machine upon which Windows automatically re-enables real-time virus protection. I am now seeing all information on the drives on the HBA as I should.
 
For the record my system is currently: 
OS Name    Microsoft Windows 10 Pro
Version    10.0.19041 Build 19041
 
Thanks to Spider99 for hanging in with me!

image.png.98abf7132f64015a3f2719c7e710508c.png

Share this post


Link to post
Share on other sites
  • 0

Indeed - among many other programs. Many of them are Microsoft programs and even system executables. Believe me when I say I have not done anything to set up Antivirus to be more invasive. This is just they way Windows has configured itself for me..

Share this post


Link to post
Share on other sites
  • 0

So I am going to post a follow-up because it may help someone sometime.. 

I was getting an error running chkdsk on a volume today from an elevated command prompt and chkdsk was exiting without finishing with the error below:

An unspecified error occurred (696e647863686b2e 532).
An unspecified error occurred (6e74667363686b2e 1798).

image.png.5b3d58dc803203fd798a4bd2c5a118c5.png

The issue is, again - yep you guessed it: MS Virus & Protection! It blocks chkdsk! 

As soon as I added the blocked executable to the "allowed" list, it works...incredible..
When did Windows Virus get soo invasive? I just built this computer and put a new installation of Win10 on this machine in July. Prior to that, for years.. I had no such issues.

image.png.0535e89cf0148e82d78540360ac4d9a2.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...