Jump to content
  • 0

Drives will not spin down when DrivePool service is running


alexeon
 Share

Question

Hi, I am using a trial of the DrivePool and Scanner software.   I like the software and want to purchase it, but the only problem I am having is the hard drives will not spin down / go into standby mode when the DrivePool service is running.

 

I am using an external enclosure ( Mobius Pro 5C 5-Bay USB-C ) with 2 Western Digital Pro HDDs in it.  In windows settings just for testing I have it set to turn off hard disk after 1 minute.  I have tried various settings in the Scanner software but as long as the DrivePool service is running the hard drives will not go into standby.   When I disable the DrivePool service then they go into standby without any problem.   Any help would be appreciated.

Link to comment
Share on other sites

9 answers to this question

Recommended Posts

  • 1
On 3/23/2021 at 4:28 PM, thebigMuh said:

To circumvent this, I changed the config file (C:\ProgramData\StableBit DrivePool\Service\Settings.json) to disable BitLocker support

Thank you for posting this. :)

I have been using Drivepool for two months now, with one internal SATA disk and two external USB disks in the pool. I too noticed that the USB disks seemed to be accessed continually. They are Western Digital "My Book" disks, and the disk LED:

  • Flashes rapidly when the disk is being accessed.
  • Remains constant when the disk is spinning but not being accessed.
  • Flashes slowly when the disk is spun down.

I noticed that the two USB disks were accessed briefly in unison every 3.5 seconds. After making the change that you suggested and then rebooting (need to "Run as Administrator" to make the change), I am pleased to report that the disks are now no longer accessed every 3.5 seconds -- the LEDs remain constant, or flash slowly. :)

In my experience USB disks don't obey the Windows "spin down" time in the power plan -- the USB disk controller decides for itself when to spin down the disk.

My suggestion: if Drivepool can determine that Bitlocker is not in use, Drivepool shouId automatically use the setting that you suggested.  If Drivepool cannot determine that Bitlocker is in use, the setting should be made available on the Drivepool "Settings" menu.

-- from CyberSimian in the UK

 

Link to comment
Share on other sites

  • 0

Hi!

I had the same problem (currently evaluating DrivePool version 2.2.5.1237).

After watching drive activity with filespy it seems like some interaction between DrivePool and the WMI Provider Host (WmiPrvSE.exe) is keeping the drives awake.

To circumvent this, I changed the config file (C:\ProgramData\StableBit DrivePool\Service\Settings.json) to disable BitLocker support, like this:

  "BitLocker_PoolPartUnlockDetect": {
    "Default": true,
    "Override": false
  },

Now my drives sleep the way they should.

Ciao!

PS: Just noticed that this was quite the necro. It is however one of the top search results when looking for 'drivepool spin down', so I don't feel too bad.

Link to comment
Share on other sites

  • 0

okay, what am i doing incorrectly?  I edited the bitlocker+poolpartunlockdetect in the json from true to false and saved it.   drivepool immediately reverted the change.   I stopped the service and changed it.  upon restarting the service drivepool immediately re applied it to true again.

Link to comment
Share on other sites

  • 0
On 3/13/2022 at 12:49 PM, klepp0906 said:

I edited the bitlocker+poolpartunlockdetect in the json from true to false and saved it.   drivepool immediately reverted the change.   I stopped the service and changed it.  upon restarting the service drivepool immediately re applied it to true again.

This change worked for me. I don't know the specific reason that it did not work for you, but I would suggest trying:

(1) Stop the Drivepool service.

(2) Make the change to the file (using an "Administrator Command Prompt" if necessary).

(3) Reboot without restarting the Drivepool service.

I used this setting for several months before deciding to revert it, for the following reasons:

(1) I use Drivepool on an HTPC, and it was quite annoying to browse to a folder in the pool, and then have to wait while the disk spun up before being able to view the media on that disk.

(2) With the two external USB disks in the pool, I would occasionally find that one of them had disappeared from the pool. I powered off the HTPC, unplugged the USB disks, and CHKDSK-ed them on a different system, but this never detected any errors. My suspicion is that one of the USB disks took slightly too long to spin up when accessed, and Drivepool concluded that the disk was missing. Another way to view this is to say that Drivepool does not wait long enough for a disk to spin up. Since reverting to the original setting, I have not had any occurrences of Drivepool diagnosing a missing disk.

-- from CyberSimian in the UK

Link to comment
Share on other sites

  • 0

ill try editing it and restarting without restarting the service.  perhaps something is cached thats rewriting it or being synced from scanner or something.

youre right, waiting for spin-up can be annoying.   you have to pick your battle i guess.   a lot of disks (27 in my case) is a lot of heat, power etc.  some drives have data that i use once every few days or even less so i think you move beyond the tipping point as far as wear n tear from perpetual spinning vs spinning down.

if nothing else i like things to function as they should and know that i have the option to go back and forth in the future.

of course the other angle is what disabling the setting actually does.  apparently has something to do with detecting encrypted drives which I dont use, but if i did - what would be the result.  error?  crash?  

Link to comment
Share on other sites

  • 0

i may or may not have been editing the non-override portion the first time i gave it a go.  this time i had more time to go through the covecube doc and was made aware of the override section.  convenient and preferred for sure, the setting also held after a restart.   Unfortunately changing it to false had no effect on my drives sleeping.

changed it to false, changed my scanner to have 60min throttle and only check during work window "12am > 12pm" and 24 hours later 0 spindowns on any of my disks. 

disable the drivepool service in services.msc.   down they go as intended.

Link to comment
Share on other sites

  • 0
On 4/22/2022 at 11:12 AM, klepp0906 said:

changed my scanner...

When I purchased the Drivepool licence, I chose not to purchase a Scanner licence as well, so that may be the difference between your system and mine.

I am a novice at using Drivepool, so I regret that I don't have any other ideas as to the cause of the problem.

-- from CyberSimian in the UK

Link to comment
Share on other sites

  • 0

yea im fairly novice myself.  still working my way through trying to get everything functioning in the way i prefer.  mostly there but a few crucial things evading me.  namely the inability to get drives to spin down whatsoever and a constant remeasuring on restart of my pool.

other than that im ready for the long haul.

i did try to disable scanner services entirely as well as clouddrive services entirely.  neither had any effect on my drives sleeping.  The minute i killed the drivepool service they immediately started spinning down though so its exclusively drivepool and drivepool alone.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...