Jump to content

Migrating a drivepool from HDDs to SSDs


Recommended Posts

I just bought several Samsung 2TB 860 EVO SSDs to replace my drivepool HDDs. 

- My pool was originally setup with 3 HDDs and 2x duplication. 

- I removed one of those HDDs (first from the pool, then from the PC) with no problems.

- I installed 2 of the new SSDs onto the PC, formatted them and verified that Windows 10 Pro sees them fine and can read/write to them.

But... when added one of them to the pool... nothing.  The drive is now on the pool but no data is being stored to it.  Worse, if I try to remove one of the remaining 2 HDDs from the pool I get errors about not being able to write because the file already exists and then it rebalances the data/duplication across the two HDDs.

I already upgraded DrivePool to version (the latest) and I saw no difference.   I then tried to increase the duplication to x3 to force a write to the SSD and it quickly got stuck at "Duplicating... (1.2%)".

EDIT:  Given the stuck condition I attempted to remove the SSD for the time being.  I got an error "Error Removing Drive: The directory name is invalid." and it started duplicating again.  I gave up and went on to do my normal work.  Upon looking at Drivepool again I found it at 9.2% and appears stuck again but I'm not positive.  UPDATE... it is very much stuck.  It is more than an hour later and it is still at 9.2%.


I already opened a ticket with support, but as there are only so many support people... I am hoping that someone in the community might have some hints on how to proceed while I wait for support.

Link to comment
Share on other sites

So first, what is the exact composition of the Pool and how much data is stored on it (specify whether it is net or including duplication). Have you tinkered with any DP settings or are they default?

As a tip, I have been impatient at times but I have found that, in my experience, trying to force by doing things you do not actually want (like increasing to x3) hardly ever works. Rebooting and being patient as in have a look the next day work much better. Also, you can open resmon.exe to see if there really is no I/O for a really long time. Sometimes DP is just working out where to place what and yes, when adding/removing or changing duplication and such it *can* take a long time.

Link to comment
Share on other sites

2 hours ago, Christopher (Drashna) said:

If you could, update to the latest beta version. We've ran into a couple of VERY odd issues on Windows 10, and the newer version should help with the issue.


Thank you.  I am currently working with your support department and just uploaded both logs and troubleshooter data.

But I will definitely upgrade from to the Beta version to try it if they can't find another cause.

In the meantime, even though I can't remove the old drives... at least the pool is balanced and has x3 duplication fully completed at the moment and the pool is "functioning" properly as is.  I suspect that applying the Beta and then reducing duplication to x2 *might* let me remove one of the old HDDs, but I'd better wait for your support team's analysis of the data I just uploaded before I try additional things.

Link to comment
Share on other sites

Christopher, I upgraded to the Beta version, but it still gives the

    "Error Removing Drive:  The directory name is invalid" message.

I also got a notification of an available update to version  So I upgraded to that one and tried to remove the V: HDD.  Same thing.  Looks like the "drive remove" bug is still around.

Link to comment
Share on other sites

Sadly, although I had great experiences with support in the past, this time the support team has been very unresponsive.  Maybe this time they are overworked, understaffed or I was unlucky and my case was assigned to an inexperienced support person.  After sending the logs and running the troubleshooter, the next response from support was to... please send the logs and run the troubleshooter (yes, same thing again).  It has been 5 days and so far formal support has not provided a single suggestion on how to solve the problem or given any sign of having done more than just glancing at my case and replying with a cookie-cutter response. 

This forum has been much more useful.


So, for an update on all the things I tried and discovered:

1) For the good news, the pool runs fine when I'm not trying to make a change and I am able to increase the duplication to x3 or reduce it back to x2 just fine, no problems.

2) Every so often I am seeing errors about not being able to access files because they are "in use" even though those files are for applications that were not launched, have no background processes and during those tests I had already shut down any processes (like backups and antivirus scans) that could legitimately lock those files.  I also run MalwareBytes in addition to the very strong antivirus I normally run, with zero threats detected (in other words I am quite confident that there is no virus scanning files either).

3) Every time I try remove a drive through the "Remove" option I get an error telling me that a directory does not exist or that a file already exists.

Given the above precautions, checks and symptoms.... I strongly suspect of a DrivePool bugSpecifically, possibly multiple DrivePool threads stepping over each other.


Possible workaround to remove a drive:

1) Increase the duplication to x3 (with 3 drives present at the time).

2) Remove the drive physically.

3) Remove the missing drive from the pool and reduce duplication back to x2.

4) Allow things to rebalance and add any new drive(s) to the pool.

The workaround should not be needed, but with no hope for a prompt resolution it might be the only way to replace the old drives soon.    I believe that workaround should be safe, but I would really appreciate if someone would confirm that my plan is valid.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...