Jump to content
Covecube Inc.

Question

I came across a USB drive that suddenly bricked itself. So I decided to use Scanner to scan all my other thumb drives as a preemptive measure against future problems. Well...let's just say, I won't be doing that again until I talk to you guys first.

Here's what happened to one drive: It scanned ridiculously slow. I'm talking about >20 hours just to scan an 8GB stick. It also reported 4 bad sectors in the beginning of the scan. At about 86%, I tried to stop the scan but to no avail, it kept scanning. So, I just reboot the system. 

After the reboot, that drive too is now write-protected and appears bricked. The data on it is gone and Windows is prompting me to format the drive, but due to write-protection, it won't format it. The data on it was erroneous, so nothing was lost but I want to know what happened. I scanned other USB drives and they scanned quickly without errors. Is there something going on under the hood of scanner that locks the drive while scanning? Why is that thumb stick rendered useless when it was working perfectly find before?

This...concerns me.

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

We were talking about USB stick longevity in another topic not long ago.  I simply don't trust them as I've had >1 die in the past.  Some people agreed, while others stated they've never lost a USB stick.

I can't provide an answer for you as to what happened though, that'll be up to the gurus (Christopher/Alex).  It does sound like that stick bricked itself due to the stress, or was simply not using the sectors that were tested, which is why it seemed to work normally but choked when they were accessed.

I had a ~6 year old spinner drive start dying a few months ago.  Bad sectors on it produced arm clicking, which Scanner never recovered from (I had to try a graceful reboot to stop the tests).  A similar issue may have made it seem like the drive was locked for you when it couldn't proceed past the damaged area(s).

Share this post


Link to post
Share on other sites
  • 0

Jaga, thanks for the reply. You and Christopher are always on top of things. (thumbs up)

So, you said something interesting. That the thumb drive wasn't using the sectors that Scanner scanned as bad and by accessing those sectors, the drive choked and bricked itself.

You know...I believe that is most likely what happened. From experience, normally, genuine capacity drives don't use compression but I remember reading a long time ago that Chinese manufacturers use compression to make higher capacity cards out of smaller capacity cards by placing compression hardware on the drive and another way is making a partition with a header from a larger than the original size. I know my drive is genuine so, perhaps my drive was just faulty. What's interesting is that the drive took so long to scan...about 18 hours yet an identical drive that I bought at the same time scanned in a few minutes.

So, since my previous post, I did quite a bit of research and finally was able to restore the drive. First off...the drive had a corrupted partition but still showed up in My Computer and it was write-protected. I tried every known technique to undo the write-protection to no avail. Considering that Scanner is non-destructive, I figured, as you mentioned, that accessing those bad sectors or accessing sectors that Scanner thought were sectors, caused the corruption but the data must still be there. Let me digress in saying that perhaps my drive had some funkiness in the original partition? I don't know but the drive worked fine before. Back on track, so the data must still be there. Ok...so, to get data from a corrupted drive isn't quite that simple.

I tried all the common applications for data recovery but most of them only recover deleted files or files wiped from formatting, not many will recover data from write-protected and partition-corrupted USB thumb drives successfully, except for one. EaseUS Data Recovery Pro. That program is impressive...really impressive. It restored everything including what was left of the partition table. That partition didn't matter but the contents of the drive did. Seriously, if you have a thumb drive that took a crap...don't format it. Use this program first.

It turns out the data on the drive was sensitive information bound to the serial number of the drive, so as long as I could get the data back on that specific drive, the data is useable. The problem was that being write-protected, I couldn't partition the drive, let alone format it.

This program reversed it. It's called APACER Restore_v3.21. It looks like a hacking utility. Its GUI only has two buttons. One for Format and the other to Restore. Make sure you have no other USB drives connected and run it. The format module didn't work but the Restore did.

So, my take from all this is...I won't run Scanner on older USB drives or a drive I bought on eBay because if it's counterfeit, accessing sectors incorrectly, apparently, seems to brick drives and locking the drive as write-protected. Christopher? Jaga? Anything to add?

By the way, that drive is long gone now. I'm not using that thumb drive again.

If you do run into the same issue I had and have bricked your thumb drive:

1. Restore the data.

2. Run APACER to remove the write-protection (if you have to use the drive, otherwise trash it)

Share this post


Link to post
Share on other sites
  • 0

Glad to hear you got the data off the drive finally.  The only pearl of wisdom I'd toss out there is that USB drives (the non-premium type) aren't robust and probably shouldn't be subjected to surface testing, unless you actually want to try to produce a failure.  I only use them now for temporary transport of data, and for machines that need temporary file storage or a boot volume (like for a BIOS flash).  If I ever did need to rely on one, I'd do some research and wouldn't spare any expense.  Good sticks do exist, they are just not the everyday ones.

Great to hear about EaseUS and Apacer Restore.  I have used EaseUS products in the past (especially their partition manager) and it is a decent company.

Share this post


Link to post
Share on other sites
  • 0

To be blunt, if it had issues like this (immediate bad sectors, super long scan times, and partition info corruption), then it sounds like the controller on the stick is dying, bad, or corrupt.  AKA, you may not want to use the drive. 

As for fixing the drive, I'd use diskpart's "clean" command, as this wipes out the drive data. Completely. It should let you repartition the flash drive, and get it working.  But you can nuke your data, if you get the wrong disk. So there is that. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...