Jump to content
Covecube Inc.
  • 0

SSD Optimizer not honouring ordered placement




I am in the midst of moving server and I have configured my new target according to attached image. The settings are quite clear an intuitive. My intentions are to fill up the drive sequencially, not in parallel (parralellelly? :rolleyes:). However, as the picture shows the drives are filling in paralell. It feels like the system is putting the files on whichever drive has the most absolute free space. 

There are no strange file placement rules in place.

Any help is much appreciated!

Screenshot (2).png




I activated my license, specified another drive as SSD and rebootet several times (due to something else) and the software now seems to adhere to my requested placement order. I won't touch any settings out of fear (currently still filling drive #1) and if drive #2 starts to fill next i will assume it had fixed itself, update this post and start fiddling with the settings again.

Edited by Strongtrond
Tags, typos and more information
Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0
18 hours ago, red said:

I had a similar problem after adding new disks to my pool yesterday. Today the problem solved itself after I've a couple of re-boots. Curious..

Thank you for replying. I saw your post whilst googling my issue. I've done some changes (activated my license, added another ssd drive and rebootet several times) and the issue seems to be sorted here aswell. I do not trust it however. I will update my initial post and guess i'll just have to see what happens...



Link to comment
Share on other sites

  • 0

Thanks mr. fattipants2016. I turned of that settings and the balancer stopped once it had transferred the data from drives marked SSD into drives marked Archive in the pre-set order. However, once complete, it stopped. It did not "Move the existing files into the predefined order on the archive disk" at all.

I've since put the "SSD Optimizer" at "Leave the files as they are" then re-enabled "Ordered File Placement" and, fingers crossed, I'm experiencing expected behavior.

Files are now being preferably written to drives marked SSD, once the balancer runs it empties the SSD into the predefined order. Additionally it reorders files into predefined order on the balancer passes.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...