Jump to content
Covecube Inc.
  • 0
npopson

Yet Another Balancing/Measuring Question

Question

Hello there,

 

Sorry for asking a question that has almost certainly been solved already on this forum, but I wasn't able to find a solution.

 

Some background: I have a ~20TB pool made up of 3TB and 4TB drives and 2 SSDs (with SSD optimizer) witha  mixture of duplicated and unduplicated data. 

Last week I had a 3TB drive fail. I knew it was on its way out and only had duplicated data on it. It failed by simply disappearing from my system ("Drive Missing"). 

From there I:

  1. "Removed" the missing drive and let DrivePool do its thing.
  2. After a day or more the drivepool was still stuck in a balancing/measuring act. It looked to me like it might be struggling because there simply wasnt enough room to properly duplicate everything again.
  3. I proceeded to disable duplication on a few unimportant folders to free up space. I was running with about 1TB of free space. Things appeared happy although to be honest I wasn't paying much attention to it.
  4. Today I installed a new 8TB drive into the pool. For the next 7 or so so hours it was stuck in a "measuring" loop I will call it. Just when it looked like it was about to finish figuring out what is duplicated and unduplicated, it would start all over again. It did this all day I think. It may have tried to do some balancing as well, but it didn't get anywhere. I tried rebooting. Disabled anti-virus. Disabled anything that regularly accessed the drive.
  5. No data was ever moved to the 8TB drive.
  6. I changed the balancing settings to attempt to force it to balance (Unchecked "Not more often than...", changed balance ratio to 100%). 
  7. For 30 or so minutes it looked like it was balancing (got up to 2.1%). Some data showing up on the 8TB drive. Then it reset and started measuring again.
  8. Now it's just in a measuring loop again where it figures out what all of the "Other" is (Duplicated or Unduplicated) and then it resets and starts figuring it out all over again.

The main concerns I have now is that

  1. The SSDs are completely filled for some reason (refer to first screenshot). The SSD optimizer setting is Fill up to 75%.  They have been filled like this since before I put the new 8TB drive in.
  2. There is 6.10TB of data "Unusable for duplication" and I don't know what that means or why that is?
  3. Every time it starts balancing it goes back to measuring after some time. (refer to second and more recent screenshot)

Will these items resolve themselves or is there something I should be doing to alleviate the issue?

 

Edit: Update: After another 8 hours it is still in a "Measuring" loop and only about 300GB has moved to the 8TB drive. SSDs are still basically full (well, one is, the other is about 85%).

post-9033-0-68697300-1508209910_thumb.png

post-9033-0-16799000-1508210238_thumb.png

post-9033-0-43477100-1508210237_thumb.png

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

I'm not sure why the SSDs got filled, but probably because the other drives were too full at the time.  Pretty much the only reason why that would happen.

 

 

That said, I would highly recommend installing the latest beta version: 

http://dl.covecube.com/DrivePoolWindows/beta/download/StableBit.DrivePool_2.2.0.866_x64_BETA.exe

 

There are a bunch of bug fixes in it, both for the measuring code, but also for the balancing code.  And installing this version will likely outright fix the issues that you're seeing. 

Share this post


Link to post
Share on other sites
  • 0

Hmm, I have had similar, but not exactly the same issues.

 

For the SSD's remove the balance at xx, select balance now option.

 

As for the not available for duplication - I had the same issue, crazy TB of can't be used, now during the current balance its gone. Will need to review when its finished.

 

PS: I'm using 6 and 8 TB drives, with latest beta version.

 

Note: I've been unable to post screen shots, how are you doing it?

Share this post


Link to post
Share on other sites
  • 0

The SSD Optimizer follows the general balancing settings. Tweaking those will change how aggressively it balances. 

 

And as above, it depend highly on what happened here. 

 

 

 

As for the screenshots, click on the "more reply options", and then attach the images. 

Share this post


Link to post
Share on other sites
  • 0

Thanks for the replies. Yep - it has been set to "Balance Immediately" since forever. And as mentioned in my note "6" above, I did uncheck the "Not more often then every:" option under "Balance Immediately".

 

It's now been working for over 36 hours. Every time I check up on it is just "Measuring". It is balancing but it is doing it incredibly slowly.

 

Seems to very, very slowly be figuring out what is "Unusable for duplication" (now that is down to 4.85TB, previously was 6.10TB). At this rate it's going to take a week to resolve itself.....

 

Attached reference screenshots.

 

EDIT: I'm a dumbass and missed the first reply about installing the latest beta. I am doing that now.

EDIT 2: It is now measuring and then hopefully will proceed to balancing properly. Will update with what happens.

EDIT 3: After 8 hours on the latest beta things seem to be going pretty smooth. It is about half done balancing and the SSDs are emptied out. The only issue that remains is "Unusable for duplication: 4.84TB" which may resolve itself after the balancing is complete? Screenshot attached.

post-9033-0-08417200-1508336458_thumb.png

Share this post


Link to post
Share on other sites
  • 0

Not a problem. :)
and yeah, in the beta version, we completely overhauled the measuring code, so it works a lot better, is less prone to get "stuck" and is more accurate, overall. 

 

 

As for the "unusable for duplication", that's because of the way the disks are filled.  This is pretty normal on a two disk pool, since they'll be filled differently, depending.  But in this case, the replacement disk being much higher capacity is why.  It has more free space than rest of the disk combined.  And roubly 5TBs more, in fact. 

 

The "Duplication Space Optimizer" balancer will cause the pool to rebalance until this space is gone (if it can).  And that looks to be what is actually causing the rebalancing currently (based on how the targets for balancing look). 

 

So give it a week, and you should see the "unusable for duplication" space disappear. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...