Jump to content
  • 0

Cannot Repair "File System Damage" on Pooled Drive



Good Morning - 


Wasn't sure if this was to go in the Scanner or Drivepool forum, so please adjust if needed... :)


I've got a 40.3tb drive pool comprised of 11 disks which I've used for the past couple of years.  It's worked great, but do have a small issue.  Alongside using Stablebit DrivePool to manage the pool, all drives are monitored via StableBit Scanner.  Recently, one of the pooled drives (4tb standard disk) started showing a "File System Damage" error.  I think I know what is causing this as recent scans using Treesize indicated 4 folders which couldn't be located and if I try to delete them from Explorer, I get an error.


I tried running the repair via Scanner and it plus the forced repair did not succeed.  I also tried using Windows' native toolset including chkdsk, but they reported no errors or gave the message that chkdsk couldn't be used on a RAW partition.


It seems the next best attempt would be to remove the drive from the pool, scan it as a standard volume with Windows, then rejoin it to the pool.  Unfortunately, I don't have the available space to cleanly migrate all 4tb of data (it's full) when disjoining, so if that would be what you suggest attempting next; please verify the steps to do so to best insure there is no data loss.


Thank You!

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

.... :(


From the sounds of it, the disk has turned up as "RAW".  This means that the file system itself has gotten damaged, and is no longer showing up as NTFS. 


The problem is that if the file system itself is damaged, there may not be much that can be done. In some cases, CHKDSK can correct this issue.  However, if it fails to do so, the only real option here is data recovery. 


If the entire pool was duplicated, then just format the disk, re-add it to the pool, and let it reduplicate the data.  


But if the pool wasn't fully duplicated, there are a couple of additional options. 

  1. Run CHKDSK X: /r" and hope that this repairs the partition. 
  2. 3rd party programs to run partition recovery. 
  3. Data Recovery.  Straight up. 


Since it sounds like you've already tried the first, that let me cover the others.


TestDisk is a good, free utility that may be able to recover the NTFS partition, allowing access to the data.



If that doesn't work, then data recovery programs such as PhotoRec may be able to recover data.


Link to comment
Share on other sites

  • 0

chkdsk /r takes a LONG time, just so you know. Especially if you have sectors that are hard to read.


Yup.  It can take a few hours per TB, in fact.  The larger drives definitely take longer.


But in some cases, is really the best option.


That said, replacing the "/r" with an "/f" instead will complete faster, but it's also, not as in depth of a scan. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...