Jump to content
Covecube Inc.
  • 0

DrivePool 2.2.0.651 - GUI Reporting Inconsistent Between Screens (Duplication)


Question

12 answers to this question

Recommended Posts

  • 0

Have you tried a re-measure to see if it sorts the issue?

 

I did, but no dice.  Please note however I have a large copy still running.  After it finishes I am going to try to upgrade to the latest beta (found a link on the forums), restart my computer, and then remeasure.  Maybe that fixes the issue.  I have around 5 hours left on the copy.

Link to post
Share on other sites
  • 0

do you have real-time dup turned off?

 

No, its on.  That's why i was concerned when files were showing as unduplicated in the main view during the copy.  But the folder view shows 100% duplication, so it is inconsistent.

 

Additionally looking at the logs, I do not see any errors saying expected=2,found=1.

Link to post
Share on other sites
  • 0

Okay, so upgrading to 2.2.0.734 fixed the issue. Is there a reason this beta isn't linked to on the download page?

 

Once I did that, the pool correctly identified their were duplication inconsistencies and allowed me to fix.  This left me with 72B unduplicated and an error message: "System Volume Information\IndexerVolumeGuid file parts different."  I was able to fix this following instructions from previous threads posted to this forum.

 

Now - everything appears to be running smoothly, but I am curious why one disk has such a large amount of "other" files.  E & G are both 8TB drives that I bought expressly for the pool and have no other files on it.  I would have expected similar amounts of "other" allocation on them.  At one point they were close, but G's shrunk considerably.

 

 

post-3424-0-08942500-1484025406_thumb.png

post-3424-0-94824200-1484025406_thumb.png

Link to post
Share on other sites
  • 0

Due to some issues with 2.2.0.734 (background service repeatedly not starting, and "Unable to enumerate folder error" ) I went back to 2.2.0.651.

 

I have actually already fixed the "other" space - turns out the E:\ "System Volume Information" (outside the poolpart folder) was 700GB.  Somehow all the files had no owner and I was unable to take control via Windows 10, so i just deleted that folder through a Linux live CD.

 

Now, everything seems like it is working.  When I first start drivepool, it still warns me of duplication inconsistencies but I am able to resolve it through the software.  I also tried setting duplication to 1x for "System Volume Information" but after my first restart I still received the warning about duplication inconsistencies for that folder. At that point I was out of time, so hopefully my next restart won't have that, but even if it does, it seems DrivePool is able to resolve it without me having to do any more tweaking.

 

I'm running a scan on all my disks right now just to make sure the file system is still intact from the work I did in Linux, and hopefully I can add the remaining 16TB to my pool later tonight.

 

Thanks for your help. :)

 

 

post-3424-0-84146100-1484063891_thumb.png

Link to post
Share on other sites
  • 0

yeah, this needs to be clarified.

 

Specifically, StableBit DrivePool does differentiate "originals" from "copies".  They're all copies and considered this way. 

 

 

The exception here is the folder duplication window.  This shows the "size" as a measure of unduplicated data, and the FIRST copy of duplicated data.  The "duplication" is all extra copies.  

 

So, if you do have roughly 7.7TB of duplicated date, then yes, this will show up as ~15TB on the main window.

Link to post
Share on other sites
  • 0

This shows the "size" as a measure of unduplicated data

 

So why isn't this window reporting size as being 6.12GB larger than the "duplication" figure?  It matches to the byte - when the pool is set to 2x duplication, that would make me think the entire pool is 100% duplicated, but the home dashboard shows that is not the case.  Seems like a bug to me, especially because the pool wasn't attempting to duplicate the missing 6GB until i upgraded to the latest version, which wasn't very stable for me, so I downgraded again (but that could have been related to my System Volume Information troubles).

Link to post
Share on other sites
  • 0

Tracking issues with the measuring code.

 

The folder duplication window is generated in real time (which is why it takes a while to populate.

 

There are a number of tracking and measureing issues with the public beta that work fine in the 2.1.1.561 version but have been fixed and improved in the latest public beta. 

http://dl.covecube.com/DrivePoolWindows/beta/download/StableBit.DrivePool_2.2.0.738_x64_BETA.exe

 

If you install this version , it will remeasure the pool and should display the correct info. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...