Jump to content
StableBit.com Downtime ×

Bitflock Stopped Working


Recommended Posts

Hi Guys 


I have run Bitflock before on my Pc as i have a Nest.

Recently tried to run it, which it does but fails to show report or update.


I then get an error report popup but that fails as well !!!!!!


I have unlocked the file and i run as Admin !!!!


Error here

Link to comment
Share on other sites

Unfortunately, it looks like the app is crashing for some reason.

Could grab the files from "C:\ProgramData\BitFlock.com" (you may need to type it in, or enable "Show Hidden Files" to see the folder).

And then submit them to http://stablebit.com/Contact and use "Scanner" for the product.

Link to comment
Share on other sites

About the error reporting, unfortunately BitFlock is a bit out of date in this regard. Automatic online reporting did not work out as intended. The main issue is that some people have repetitive errors (such as WMI or COM errors and the such) that can clog the automatic reporting system fairly quickly (at you can see).


I'll try to update BitFlock within the next couple of days to stop doing that, and I'll also rebuild it with the latest code. Let me know if the issue continues after that and we can look into it further.

Link to comment
Share on other sites

Ok, I've updated the BitFlock client to write out the error reports, write out an event log entry and show a more informative error message with a link to this forum.


In addition, it is now compiled against our latest disk pass-through code. Give the new build a try and let me know if the problem continues (v.

Link to comment
Share on other sites

Ok, I got your error reports.


It seems like "https://" is not registered on your system, as if you have no default web browser installed. So in that case, just typing in the URL that's on the screen in any web browser's address bar should work.

Link to comment
Share on other sites

I use this well known method to open web links from the BitFlock client:



The error that I'm seeing from your system is:

[system]System.ComponentModel.Win32Exception: Class not registered


The Microsoft article does state that:

"This code is highly dependent on the application-file type associations in the HKEY_CLASSES_ROOT hive of the registry. This can lead to unexpected results and exceptions if the registry is damaged."


So that may be one cause.


However, I do see that over here:



There's a comment to suggest that this has something to do with Windows 8 and some suggestions that it may have something to do with UAC. I just tried it on a fairly clean Windows 8 machine and it seems to be working as intended.

Link to comment
Share on other sites

Just to followup with some more info, I've tested this on Windows 8 with UAC enabled / disabled / completely disabled (via. registry hack) and have tried it with IE and Chrome and I can't reproduce this. It works correctly every time for me.


The error seems pretty clear the "Class", being HTTPS is not registered in the registry. So it can't find the app to open HTTPS links (Chrome in your case).


I was thinking that there might be some combination of browser / UAC settings that would cause this to manifest, but that doesn't seem to be the case. i can't think of another explanation other than the class is really not registered, there is a registry corruption or perhaps a misconfiguration.


Not sure if this is relevant, but here are some people talking about "Class not registered" on Windows 8 with Chrome:



Looks like a bunch of people have something similar, but this was with Chrome 22 which is kind of dated by now.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...