Jump to content
Covecube Inc.
  • 0
Parallax Abstraction

Macrium Reflect Reporting Out of Disk Space Mid-Way Through Backup

Question

Hey all! I'm still on my trial of DrivePool but am overall liking it quite a bit. However, I've run into one major problem I don't know how to solve and I'm hoping someone here knows a solution.

 

I use the paid version of Macrium Reflect to backup my entire gaming PC. It writes a main image that's a full backup (it usually comes out to about 1-1.3TB after compression) and then writes up for 4 incremental backups after that, then rotates those out, always keeping no more than 5 backups. My DrivePool lives on my home server under my desk and I run the Macrium Reflect backup set to a share I have on that server. When I tried to start my backup, my pool looked like the attached screenshot. About 4TB of space left between a few drives. When I execute my Macrium Reflect script, it also reports the same amount of space remaining.

 

However, multiple times today I've tried to run the full backup and it's failed between 20% and 40%. According to the Reflect logs, it's because it...ran out of space. Even without compression, the total backup from my gaming PC is less than 2TB, it most certainly is not running out of space. As you can see from the screenshot, I do have duplication turned on but even with that taken into account, there's still more than enough space available.

 

I'm not sure why this would be happening or what to do about it. I can engage Macrium support as well but I figured someone here might have a better idea. I can set Reflect to split the backup into multiple smaller files and may try that but I'm not sure why that would be necessary. I'm not sure why writing one large file over the network would keep failing this way.

 

Anyone have an idea why this might be happening and if there's some kind of solution? Thanks all!

post-2622-0-26578800-1475116077_thumb.png

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Hi i'm new to this as well - but the thought that comes to mind is that the backup is a single file and you dont have enough space on two drives to hold the single file. So i suspect the out of disk space warning is when one of the drives with very low space fills up as MR probably does not reserve the full file size initially on the system(if it did then the backup would probably fail almost immediately) because it does not know how big the backup is going to be and just incrementally expands the backup file as it goes later it will know when the process nears completion. DP therefore just decides to pick a disk and wait for the process to finish hence why you get variable completions of 20% and 40% as the "primary" or "secondary" DP disk fills up.

 

Drive 6 looks like it has enough space but the others look to have a lot less space.

 

If you can chop it up into more manageable pieces then I would expect it to work. Or just do an image of your system drive and do a file backup of the rest to keep the biggest file size down to something more manageable

Share this post


Link to post
Share on other sites
  • 0

I might be wrong but I thought DrivePool was able to use striping to take ultra big files like this and spread them across multiple disks when writing. Indeed, if I look at my MediaSonic ProBox while running the backup, I can see lights for two different drives flashing. However, if it does do that, maybe it does it after individual files are written, I'm not sure. Oddly though, the WD Black drive in my pool has 1.97TB of free space and that's definitely more than the backup will be. Unless the balancing plugins are causing it to be written elsewhere first. Truth be told, it's not really a big deal if I have Reflect put a hard cap on the file size so I'll try to run a backup that way and see if DrivePool can handle it. I'll set the limit to 500GB per file and report the results. If the devs have any insights though, that's be awesome. :)

 

EDIT: So it turns out, if you're using file splitting in Reflect, you can't use incremental backups. That's a major issue for me as my custom incremental retention settings are one of the main reasons I use this product. :( I'm going to try something else though. Rather than having the entirety of the DrivePool be duplicated, I'm going to switch to folder level duplication and have it exclude the backup folder, which I definitely don't need duplicated anyway. I'll see if that helps.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...