Jump to content
Covecube Inc.
  • 0

Duplication Inconsistant


Question

My pool started to throw this error/warning recently.  The details shows: "\System Volume Information

IndexerVolumeGuid"  Access is denied.   Duplicating now does not resolve the issue.  All drives were checked with chkdsk and no errors found.  Ran the WSS troubleshooter and reset NTFS permissions on the pool to "Everybody"  All were ineffective in removing the error.  As long as the error on the pool exists, my backup program will not use it as a backup destination.  I am currently running Beta v651, but the release version throws the same error.  The pool seems to work fine in all other respects as far as I can tell, just no duplication.  When Folder protection listing is up and show hidden folders is checked, an entry for System Volume Information appears and shows as X1 for duplication.  Otherwise I cannot find this file (hidden or otherwise) on any of the pool drives.  Not sure what DrivePool is having a problem with.  The server is running Windows 10 Pro on an AMD 6 core with 8 gb ram.  The pool is 20 TB with about 10 TB still free.  Any idea what else I should check or try to get rid of this error?  I need to get my backups working again.  Thanks in advance for any help.

Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

The System Volume Information folder is a pain, because of how Windows locks it down...  And because it may be in use, or the permissions set in a way that prevents it from being duplicated properly, it can cause this issue.

 

To fix this, you'll want to change the permissions on the folder, (and delete it if you want). 

To do so:

  1. Open an Explorer window (this doesn't matter where, right now).
  2. Click on the "View" tab at the top of the Window, and enable the "Hidden items" option (far, right side)
  3. Open the pool drive.
  4. You should see the "System Volume Information" folder there.
  5. Right click on the folder and select "Properties".
  6. Open the "Security" tab, and click on the "Advanced" button (at the bottom)
  7. At the top, it should list the owner (as "Unable to display current owner.", right now), click on the "Change" link.
  8. Set the "Owner" to "Everyone", 
  9. Enable the "Replace owner on subcontainers and objects", right under the newly specified owner.
  10. Click on the "Add" button, and add "Everyone" and grant it "Full Control".
  11. Enable the "Replace all child object permission entries with inheritable permission entries from this object" option, at the bottom.
  12. Hit "OK" and accept all the prompts it comes up with. 
  13. Delete the "System Volume Information" folder. 

 

 

However, this shouldn't affect your ability to backup (what program are you using, specifically, though)?

Link to post
Share on other sites
  • 0

I'm running EaseUS Todo Backup Workstation v9.1.  It was working fine even with the network discovery feature in Win 10 borked by the Nov. 2015 update, the program uses an ip address to find it's backup destination. Now it says the destination is unavailable and to retry to connect. The only thing out of normal on my server is the duplication inconstancy error from the pool, I've had times in the past where any error message from the pool seems to prevent backups from starting or completing.  I think if your fix gets rid of that error, everything will be back to normal.  Not sure why the aftermarket backups, tried Acronis and Microsoft's builtin one but I liked this one from EaseUS for the ability to locate the server and backup by ip address as normal name resolution was hit and miss until Microsoft fixed that with the last update.

 

Your fix worked great Christopher, backup works again and life is good.  I even found a way to delete an "untouchable" zero byte file/folder that has been annoying me for weeks.  Two wins in one week, I'm living the life.  Thanks for your help.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...