Jump to content
Covecube Inc.
  • 0
Sign in to follow this  
revnull

Advanced Format Drives

Question

I have a few WD20EARS drives that I was using (jumpered) in my old WHSv1 box. When I upgraded to WHS2011 I removed the jumpers since 4k formatted drives were now supported. I’ve initialized them GPT and make sure they are 4k formatted. They work fine and perform as expected, but StableBit Scanner does not report them as “advanced format” drives. Is this an error or are these drives not really 4k drives?

 

 

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

AFAIR these older EARS-models lie about their true sector size....regardless of the jumper...it'll be dependent of model/size and firmware version..

 

Edit: the jumper sets the offset for sector alignment by 512bytes...it'll not change how the disk reports logical and physical sector size.

Share this post


Link to post
Share on other sites
  • 0

...can't tell..google is your friend...I am still running a couple of the 2TB models in my NAS, on ZFS and forced them to align sectors to advanced format, but I never cared what they show/report as they were/are running fine..

Share this post


Link to post
Share on other sites
  • 0

AFAIR these older EARS-models lie about their true sector size....regardless of the jumper...it'll be dependent of model/size and firmware version..

 

Edit: the jumper sets the offset for sector alignment by 512bytes...it'll not change how the disk reports logical and physical sector size.

 

 

totally agree with the above had 10 x 2tb green ears drives and some reported correctly some didn't

 

 

good excuse to buy some wd 3TB reds :-)

Share this post


Link to post
Share on other sites
  • 0

I chatted with alex a bit about this, and:

It is possible that the firmware on the drive is not reporting Advanced Format properly.

 

On that DirectIO test app, click on the "..." button next to "Identify". Look for "Logical sectors / physical". That is what we look for when reporting advanced format or not. If it's 1 (0x4000), then it's not advanced format (or just not reporting it). If it's 8 (0x5000, or 0x6000) then it means it's reporting advanced format.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...