Jump to content
Covecube Inc.
  • 0
Airshark

NFS not working

Question

Hello Support Forum,

 

according to the last post in the old forum, NFS is working with DrivePool. But I installed the RC version, but I cannot share folders with NFS on the DrivePool drive. 

 

Here is the old posting: 

http://forum.covecube.com/discussion/722/nfs-suport-any-chance-of-it-being-added-to-drivepool/p1

 

Do you have an idea how to solve this issue? Would really like to use NFS with WHS2011 and DrivePool. I installed Version 1.3.2.7553 RC. NFS is working fine on the systemfolder but not in the drivepool drive :( Any ideas? 

 

 

Thanks!
 

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

Same for me.

I worked with 1.3.2.7551 RC and had no trouble with NFS on my pooled drive.

Then I updated to 1.3.2.7553 RC. Since now, I cannot configure a NFS share on my pooled drive anymore.

 

I uninstalled Drive Pool 1.3x and update to the newest 2.0.0.260 x64 BETA.

Unfortunately, I have the same problem with that version.

 

 

Cheers

Share this post


Link to post
Share on other sites
  • 0

@Danfer: the setting required for NFS isn't enabled by default in DrivePool v2. You'll need to manually enable that.

 

Set the "CoveFs_OpenByFileId" value to true:

http://wiki.covecube.com/StableBit_DrivePool_Advanced_Settings

 

Then it should work.

 

Airshark: Try rebooting the system. In my VM, sometimes "something" would crash or happen and DrivePool would lose the NFS sharing tab. Until I rebooted. 

If you reboot and that still doesn't work, let us know. 

Share this post


Link to post
Share on other sites
  • 0

@drashna: Thanks for your help! NFS is working again. Is it perhaps possible to integrate this setting into the option tab? This would make life a little bit easier  ;)

Share this post


Link to post
Share on other sites
  • 0

@danfer and @airshark:

The "CoveFs_OpenByFileId" is enabled by default on the 1.3.x RC version, but disabled by default on the 2.x beta version.

 

@airshark: if you restarted the server, that would be what fixed it. Though, I suspect that restarting the service for DrivePool would work as well. 

So out of curiosity, which did you do?

 

And there isn't a firm release date yet. Alex would rather have it stable, and all the bugs (or as many as he can find) squashed before putting the "Stable" label on to any version of the product.

However, the driver for both hasn't changed significantly in a while (IIRC), so that part should be good.

Share this post


Link to post
Share on other sites
  • 0

The reason why NFS support is not enabled on 2.0 by default is because it has not been tested thoroughly yet on all of the supported operating systems. I don't want to enable it unless I'm sure that it works on every supported OS.

 

From what I understand right now, it does not work with the Microsoft's NFS service on Windows Server 2012.

 

However, I've had great success with haneWIN NFS in the past (which is super fast), so you might want to give that 3rd party solution a try.

Share this post


Link to post
Share on other sites
  • 0

@Alex:

Thanks for letting me know, this now makes sense for me.

I am really looking forward for the final release of Drive Pool 2!

By the way, you are doing a great job on Scanner, too!

 

I have heard from haneWIN NFS.

However the Microsoft internal NFS works perfect on WHS 2011.

So currently I have no need to use extra software  B)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...