Jump to content
Covecube Inc.
  • 0
Wonderwhy

Scanner wakes up my HDD

Question

Hey,

I have the Stablebit Scanner for over a year and I really like it :).

 

Last week I changed my backup HDD to a bigger size when I noticed a strange bug.

The HDD is a Samsung Spinpoint M8 1TB and it has a standby time of a few seconds (when I check "automatic stanby" in the disk control menu).

The normal standy timer seams to have no effect.

 

Although I checked "Do not query if the disk has spun down", I heard the starting of the HDD motor every minute!

The Power option only changes between "Standby" and "Active" when I enable "Query power mode directly from disk", but then there is an access every 10 seconds from the scanner and so the HDD starts every 10 seconds....

 

.Also enabling the option "do not query SMART" for the HDD does not prevent the HDD from starting.

 

 

I can now thottle the SMART queries to 60 minutes and/or make the HDD 24/7 without standby, but because it is just a backup HDD which makes a backup every day for 30min, both things don't seam right.

 

Is there an option I have overseen?

 

Thanks in advance!

 

 

Regards,

 

Wonderwhy

 

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

If you stop the StableBit Scanner service (run "services.msc" to do so, or "net stop ScannerService"), does this behavior continue?

 

if it does, then StableBit Scanner isn't causing this, and something else is accessing the disk and causing it to wake up.

 

If the behavior does stop, then Scanner is at fault here. Setting the SMART queries to be throttled to once every 60 minutes should actually fix this issue, for the most part. 

Share this post


Link to post
Share on other sites
  • 0

Okay, I just wanted to make sure.

 

And this is with the throttling options checked?

 

If so, then could you enable the "NoWmi" option for SMART and see if that helps?

http://wiki.covecube.com/StableBit_Scanner_Advanced_Settings

Find the "Smart" section, check "NoWmi" and reboot the system (or run "services.msc" and find and restart the "StableBit Scanner Service").

 

And yes, please upload the logs.

Go to https://stablebit.com/Contact and submit them there. If it's larger than 10MBs, then use this link:

http://wiki.covecube.com/StableBit_Scanner_for_Windows_Error_Reports

There is a Box.com upload widget at the bottom of the page. This handles large uploads, and should be able to handle it. Include either the ticket number or this link in the description.

Share this post


Link to post
Share on other sites
  • 0

It seams to work now if "NoWmi" is enabled! :)

 

In the log, the 10 second logs still appear (ATA pass-through query succeeded, Command=229), but they do not wake up the backup HDD.

Furthermore, in the log it is stated, that the SMART update is being avoided because of the standby, which was not the case before the change.

 

So I run now SMART updates without throttling (every minute), with the option "do not query SMART" enabled, the HDD stays in standby. (As I mentioned above, it goes to standby after just a few seconds, which does not bother me)

But the "Query power mode directly from disk" must also be activated for this HDD, because otherwise the standby will not be detected and the HDD will start every minute again.

 

 

Thank you very much for your help! :D

 

 

Regards,

 

Wonderwhy

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...