Jump to content
  • 0

No SMART data from HP N40L microserver


HPLovecraft
 Share

Question

Well, I've made a nuisance of myself over on the DrivePool forum, now it's time to do the same over here...

 

Got Drivepool running nicely on my HP N40L Microserver, will be buying a licence shortly. Before I do, I thought I'd also trial Scanner - as it's a good deal to buy them both as a bundle. Installation was straightforward, and Scanner has scanned the 5 disks in the server (and has given me slight heebie-jeebies that my system disk has seen better days). But I don't get any SMART info from the four storage disks.

 

Spec is:

HP Microserver N40L, 2GB RAM, WHS 2011. Running Logitech Media Server, Plex, Lights-Out, DrivePool and now Scanner.

Disks are:

  • 1 x 250GB HP VB0250EAVER - system disk (listed by Scanner as 'ATA'). Connected straight to the spare SATA port on the motherboard (I moved it out of the built-in caddy to free up a slot. The disk now lives in the optical drive bay)
  • 2 x 2TB Seagate ST2000DM001 - for storage (listed by Scanner as 'SCSI'). Connected in the server's drive caddies.
  • 2 x 3TB HGST Deskstar H3IKNAS30003272E (only 2TB of each is in the Pool) - for storage (listed by Scanner as 'SCSI'). Connected in the server's drive caddies.

     

My BIOS is set to 'IDE' mode. Device Manager lists the HDD controller as 'Embedded SATA controller'. Scanner can report SMART info from the system disk, but not the storage disks. Have tried switching Scanner to 'Unsafe IO' with no change. Have also tried the DirectIO test software (in safe & unsafe modes) with no SMART data from the four storage drives.

 

I'm not blaming Scanner - if I install Seagate / Hitachi diagnostic software, they don't get any SMART info either.

 

I appreciate that some hardware doesn't pass this data through (but I am getting it from the system disk). The OP in this post: http://community.covecube.com/index.php?/topic/363-sb-scanner-smart-warning-high-load-cycle-count/?hl=%2Bsmart+%2Bn40l seems to have the same setup as me (right down to the same Seagate disks), but he seems to be getting SMART data through..?

 

Can anyone shed any light on this? Thanks in advance to anyone SMARTer than me (see what I did there..?)

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Well, ideally, you want to use AHCI mode, whenever possible (especially for SSDs). 

 

But barring that, you should be able to use the "Unsafe DirectIO" setting to get SMART data.

To do so, use this link:

http://wiki.covecube.com/StableBit_Scanner_Advanced_Settings

Find the "Direct IO" section, and check the "Unsafe" option.

 

Additionally, you can use the DirectIO Test tool to verify if it gets SMART data or not:

http://community.covecube.com/index.php?/topic/36-how-to-contribute-test-data/

Download the tool to the system and run it. Select one of the disks in question, and it should attempt to get SMART data.

If the "SMART Attributes" section is not lit up in one of the locations (or both), then it's not getting SMART data.

Check the "Unsafe Direct IO" option, to see if that works. If it doesn't... then the driver isn't passing on SMART data at all.

Link to comment
Share on other sites

  • 0

HI Christopher, thanks for your reply. I've already tried both of your suggestions, with no change.

 

'IDE' mode is the Microserver's BIOS default, maybe I'll try to change it to 'AHCI' to see what happens (hopefully this can be done without reinstalling the OS).

 

What's weird is: switching to AHCI won't affect the motherboard SATA port (where my system disk is plugged in) unless I also flash the Microserver's BIOS to a custom version. But that HDD plugged into the motherboard is the only one alreadly reporting SMART data correctly.

 

I have a suspicion the 4 disks in the caddies are connected differently somehow that's blocking the SMART data (nothing to do with Scanner)... I might post over on a N40L speciality forum. If I find out anything worth sharing I'll report back.

Link to comment
Share on other sites

  • 0

Well, that would be why then. The IDE mode probably isn't passing SMART data on to the system correctly.

Switching to AHCI should allow you to get the SMART data (and may get better performance, in fact).

 

As for switching, since the system disk seems to be unaffected, then you shouldn't have any issues. 

Otherwise, there is a hack to swtich it without reinstalling:

http://www.vistax64.com/general-discussion/271218-switch-ahci-ide-tutorial-howto.html

 

 

And to clarify, the IDE mode is probably what is blocking the ability to get SMART data.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...