Jump to content
Covecube Inc.
  • 0

HHD dropping out


Question

Apologies is this may notdirectly be related to Stablebit scanner or drivepool, but i've bought a new hard disk WD red 6tb and installed it into a HP Microserver (I think i can handle the 6tb since they handle 4tbs..i digress) .. Anyway, i noticed that my drivepool wasn't working right, like it couldn't find the files that it showed were there..but when i looked in the hidden folder, the files aren't showing -though i know they're there.

I tried creating a folder on the drive and WIndows (8.1) says it can't find the drive.   Rebooting solves it for a while but it comes back and i've tried reseating the drive in another bay. Same thing, it works for a while and then drops out from windows.  Sometimes i see the D: icon, sometimes not, sometimes i see the drive in disk manager (manage computer, disk management I think).

I did a scan with stable bit scanner and it was ok but then brought up a lot of "cannot read sector" errors, but i wonder if that's cos the drive has disconnected again so it can't read it.

The drive is new..do you think the new drive is faulty or something else?  It's running as a 2nd disk not the primary boot disk.

The drive does work fine for a while but usually drops out when i'm using it after a while.

As i say i tried moving the drive to another slot in the server and same problem.  

Anyone see anything like this before?

Thanks for any advice..

James

 

Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

When this happen, are all the disks visible in the system?

 

And what does DrivePool say about the disks? That they're still there? That their missing?

 

Also, have you checked the event viewer (eventvwr.msc) for disk or controller related issues when this occurs?

Link to post
Share on other sites
  • 0

Thanks for the reply :) Well, it's both.  Sometimes the drive is visible during the scan, while Stablebit is reporting increasing "unable to read sectors" - so at that time i can see the disk, and i can write to it by creating text files or folders as a test.  So that's the drive working and reporting those.

Other times the drive shows up, but cannot be written to. If i try write to it as above windows says "Could not find this item. This is no longer located in this PC", even though i can see the file structure and that the drive shows up in MS "Disk Management".  At this stage, stablebit also continues to show increasing error count - i assume because it thinks the drive is there when it's not.

And the third situation is the D: drive just doesn't show and is not in Disk Management.

So i'm thinking of returning the disk for an exchange.  Or i'm worried if 6tb drives are somehow not compatible with the HP Microserver - but i hear that lots of people use 4Tb drives so i assume it would handle a 6.

 

For Drivepool, this is how i first noticed the problem..because i was copying files to the pooled drive across my network, and it would say either "network error" or "file not found". At first i thought it was a network issue, but then i looked into it and found that DrivePool showed the files exist, but in the hidden folder the files weren't showing (this was the situation where the drive would show but I can't write to it, and some files don't show).  I tried to remove the drive from the pool but i think it said it couldn't because it can't find it..not sure.

 

And event viewer, i haven't checked yet but will do when i get chance.

Thanks for the advice.

Link to post
Share on other sites
  • 0

...and in my event view i get plenty of this:

 

An error was detected on device \Device\Harddisk1\DR1 during a paging operation.

 

And some of this:

 

 The system failed to flush data to the transaction log. Corruption may occur in VolumeId: D:, DeviceName: \Device\HarddiskVolume2.

(A device which does not exist was specified.)
Link to post
Share on other sites
  • 0

Well, based on what you're describing, it sounds like it may be a bad drive, a bad connection or the drive may indeed be incompatible with the system.

 

I've had similar experience with a "reverse breakout" SAS cable (SATA ports to a SAS connector). The drive appeared much the same as what you're describing... but only on one bay. Move the disk and it would work find. Connect a different cable type to it, and it works fine. 

So it may very well be an incompatibility.

 

Try the disk in a different system and see if it works fine. If it works fine, try a different disk in that bay and see what happens. If that works fine as well, then you have your answer. If it doesn't work fine, then you may have a bad connection, cable or even hardware.

 

 

 

 

As for the issue with DrivePool.... any issues with the underlying disk are "amplified" by DrivePool. I would recommend resolving the issue with the disk first, then deal with DrivePool. Because if there is an issue with the disk, then DrivePool WILL have issues, as well.

 

As for removing it... see if you can get it working first. If you can get it working on another system... then all the files are in hidden "PoolPart.xxxx" folders. And you could copy the contents back to the system, if needed.

 

 

As for the event viewer errors you've posted, the first is rather generic, IIRC.

However, the second one is typical of "suddenly removed" disks. Or in this case, ones that "disappear" like that. So this indicates an issue with the disk (though, not necessarily the disk itself, but Windows' ability to communicate with it).

Link to post
Share on other sites
  • 0

Hi there..thanks for your reply - good advice :)

To keep you informed, i took the disk back to the shop and got a replacement as it's a new disk.  So i installed that and i got the same issues roughly.

So then i moved the disk into another computer and run Stablebit scanner on it there and it seemed to work fine without the errors getting reported on the usual machine (though i didn't wait for it to finish it got much further than before without errors).  This means the disk is probably ok.

 

I had a 2TB disk without much data on so i put this into the machine that was getting the errors, formatted it and ran an error check.. this came up all clean with no errors.  So i would guess the PC giving the errors seems ok.

 

So i'm going to work on the assumption that the 6TB disk giving the errors has some kind of incompatibility with my system.  I'll take the big disk back and try to get a refund (wish me luck!).

 

Another thing i'm going to try now is to split the disk into 2 partitions of 3TB (or 3 of 2TB), and see if that makes a difference..i guess it won't but you never know.

 

And regarding drivepool, since i didn't have much data on the problem disk, i managed to clear the disk while it was working and then removed it from the pool (it was only a pool of 1 disk anyway, for the time being).

Link to post
Share on other sites
  • 0

Well, I'm sorry to hear that it does seem to be an issue with the specific hardware.

Before taking the disk back for a refund, do you have any spare SATA cables? Or ones that you know don't have any issues? Sometimes, this is the issue.

 

Additionally, what controller are you using?

An add-in controller card? Or the onboard ports?

If a card, which? If the onboard ports, what motherboard? And are you using the chipset drivers or the generic Windows ones?

 

 

As for repartitioning, no, that won't help. You'd need to use GPT, anyways (which you were most likely). And you will still see  the same issues, most likely.

 

 

And I'm glad to hear that you were able to remove the data without any issues

Link to post
Share on other sites
  • 0

Hi Christopher, I know I've informed you of the following in our support conversation but i'll update this thread too in case anyone else has a similar issue. 


 


Stablebit's software is working great of course, and the issue seems with my config.  I was thinking it's an incompatibility with the 6Tb Red Drive, and my HP Microserver.  But something you said sparked a light in my head, which was about the controller i'm using.  I'd been using the generic windows SATA controller. This is because HP doesn't provide drivers for Windows 8 for the HP Microserver (N54L).  But i saw from other people's configurations that they seemed to be using an AMD Sata Controller driver. So i searched the net and eventually found the AMD driver compatible with windows 8 and installed that. Although the disk disappeared after restarting, a full power down and on again got it back.  And so far i've done a complete scan of the disk, this time without any errors. Since that's the first time the scan has completed without errors for that disk i am now working on the assumption that the SATA driver was the problem.  I'm doing more tests but with a bit of luck i hope it's solved.


 


Thank you so much for suggesting the controller drivers could be an issue as i think i never would have thought of that. Shame HP don't support more systems, though yes i expect Windows 8 isn't the first choice of OS for it.


 


Thanks again for the advice and ideas, it may well have saved the day for me :)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...