Jump to content
  • 0

Drivepool requires online access?



I'm attempting to use drivepool on an airgapped machine.

License activation has a workaround (great!).

It launched the first time (and said all my drives are corrupted - possible, I'm fighting windows).  So shut it down.  Tried starting it again before taking the whole machine down (windows won't unmount external drives) to try again, and it won't start up.


Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

No, you shouldn't need internet access.  The only product that requise it is StableBit CloudDrive. 

As for the corrupted drives, that's unusual, but if you're having issues with your installation, it's possible. 

And do you mean that StableBit DrivePool won't start up?  if so, it sounds like the settings may have gotten corrupted. And in that case: 

Use the "Alternative Steps" to reset the settings. 


Link to comment
Share on other sites

  • 0

Had shut the machine down.  It had been trying services for an hour (was the warning?, iirc).

I restarted.  Windows offered me the option to fix disks (partition, one at a time), and actually allowed me to safely remove the external drives and replug in so I could fix each partition. I did not get the multivolume zip error I'd also started getting (but, maybe because I've not tried that thumbdrive again yet), and Drivepool started right up, no errors.  So I can't get you screenshots of what was going on (but, something working is far better).

Cranked thru the user guide (is there a pdf version I can download, and put on the airgapped / non-networked machine?) - which explains some of the things that weren't readily transparent in the UI.

Additionally, are there some use-cases I can go read?  I think I'm going to need to use some deduplication tools, as the only thing that seems to be integrated when copying files to a drivepool are some file/folder validity checks (and there doesn't appear to be an error log, so figuring out where this one invalid file was located looks like a hair-tearing experience).

To easily make a backup, I should add a drive, turn up file duplication (say x2 to x3), after balancing, I can remove the drive - (the files will still be in the hidden drivepool folder?), and it can chill out offline somewhere?  Or perhaps not, as the removal options don't clearly state that (they want to migrate files off?)

If files get (inadvertently) removed from the pool, when I re-add the chilled-out drive, will they re-populate to the live drives?

Link to comment
Share on other sites

  • 0

Well, I'm glad to hear that it's working fine now. 

Sorry, no we don't have a PDF, unfortunately. 


As for deduplication tools, We don't really support them, because of how tey work.   However, I do know that stuff like Microsofts Data Deduplication feature does work woth the pool, but only on the underlying disks, and not the pool directly.  Other programs are going to be the same way, for the most part. 

As for backups, that depends on how that's set up exactly.  if you want to use the pool, that's fine, but I would recommend a second pool, and using some sort of syncing utility (such as free file sync, microsoft sync toy, always sync, good sync, etc) to manage that instead of using the pool directly. 

As for files removed from the pool, they're gone.  But if you have another pool, it depends. But yeah,  If it was previously pooled, reconnecting would re-add it, if it's on the old pool. 

Link to comment
Share on other sites

  • 0

As above, rebooted, launched drivepool.

Had both externals attached.

Windows allowed me to fix, and dismount the partitions in each.  Took several iterations, as the pop-up disappears.

Made a pool.

Copied 200+ gigs into pool.  Error stopped that process partway thru.  Completed.  (why can't drivepool just log the error, continue, and make me make determinations at the end?  I suspect it's actually windows movement of files causing the issue, but...)

Found 2x in pool management options (had to go looking through the user-guide on an online machine).

Then waited for rebalancing.

And attempted to shutdown.

Now, unable to safely eject drives.  I don't think this is caused by drivepool, as this was the reason I got drivepool - I'm having these types of issues, and can't resolve.

But, it was working before, and now is not.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...