Jump to content
Covecube Inc.
  • 0
insleys

Rebalacing can't move files despite space availlable

Question

Hi

I have a strange issue where Drivepool is unable to move files to meet my file placement rules, despite there being ample free space on all disks.  My configuration is really simple:

  • No duplication
  • Each directory in my root folder is manually set to be placed on 1 or 2 of my 7 disks.  I want to keep related files together (e.g. videos, music, work projects, photo albums, etc)
  • Balancing settings in attachment - no auto balancing (as I use Snapraid and don't want files moving all the time)
  • Only using Ordered File Placement balancer that only controls New file placement.  This is just to catch files that for whatever reason are not placed according to directory rules)
  • About 40-50 folder placement rules
  • All rules allow placement up to 99% full or 12GB free.

All discs have at least 950GB free but every rebalance results in 195GB could not be moved because a suitable destination could not be found.  Not annoying in itself and the bar at the bottom of the main window is green.  However, every night (more or less) I get the icons to show all disks need rebalancing.  Running a rebalance achieves nothing.

I don't see how of my rules can be conflicting, so I'm curious as to what might be causing this.  It feels like a bug.

Thanks,
Steve.

Settings.png

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0
On 3/29/2020 at 12:37 AM, Christopher (Drashna) said:

Sorry for the delay in getting to you!

 

Could you open a ticket at https://stablebit.com/Contact if you haven't already? 

No problem!

Actually, since posting, I've made a few changes and the problem seems to have gone away.  While I'm not sure exactly what solved the problem, I can at least describe the changes in case anyone has a brainwave!

  1. I replaced a disk that seemed to be reallocating a lot of bad sectors (6000+ before I pulled it) according to SMART readings.  I cloned the disk offline and added the new disk back into the pool, which was seamless and has never failed me!  I ran a check -a -d <diskname> and only found one small text file that had an issue.  (Phew!  ...it seems the bad sectors were recoverable from ECC)
  2. I realised there were a few rules under File Placement that were for folders that no longer existed, so I deleted these rules.
  3. There were approx 100GB of read only files in the pool that needn't be read only, so I set them to read/write.  I read another post that suggested Drivepool couldn't balance read-only files - not sure if that's true or not and haven't properly tested it myself.
  4. I deleted a ton of empty folders directly from the PoolPart folders that were left over from files being on the "wrong" disks that had since been moved.

After all of that and another balancing run, I have a full green bar and no warnings that files couldn't be moved.  Hurrah!  As far as I can tell, nothing actually got moved in the process.  I checked each and every folder that directly related to a placement rule and everything is in the same place as it was before.  However, the only thing I now notice is that some of the discs no longer report "Other" files that did previously, only "Unduplicated".  That always bugged me as on most disks I have no files outside the pool and so there should be zero (or near enough).  I've previously re-measured after killing all processes that could be locking files (as I also read that can interfere with measuring and file placement) and it didn't change anything, but now all seems well.

So, I'm not sure which of the things I did above have "fixed it", but everything seems back to normal.

Steve.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...