Jump to content
  • 0

Changing the drivepool Drive letter?



6 answers to this question

Recommended Posts

  • 0

Yeah, the way to change the letter is through disk management. And there is no harm in doing so, aside from shared folders or install/config paths that need to be updated.


(This is meant for WHS2011, but search for "Computer Management" instead, on a client version of Windows)

Link to comment
Share on other sites

  • 0

I did this major flub installing DrivePool. Now my pool is assigned "G:", between the real drives F: and H:... this could be trouble down the line when drives get replaced and/or taken out. Wish I'd known this first.


All I have currently on WHS 2011 is client backups, all in the DrivePool. Unduplicated Shared folders are on D: (same physical drive as C:).


So I'd like to use B: or P: for the pool as others have done. But how do I change the client backup drive reference without losing the client backups? Is it even possible? Thanks!

Link to comment
Share on other sites

  • 0

Seems there's a lot of "ummm"-ing and "maybe..."'s and generalized pussy footing around on this subject! Could it be because it's never a sure thing?


What worked for me, for the record:


WHS 2011 SP1 all patched as of 2014-06-12

DrivePool RC



Note: there were no shared or duplicated folders in the pooled HDDs, just the "Client Computer Backups" folder (G:\ServerFolders\Client Computer Backups). The default shared folders are on D: (2nd partition of the C: disc)


To change the letter to P: (or whatever):


  1. Close any open files open on the server from your clients for safety, and close any open Dashboards.
  2. Via Remote Desktop, change the Pool Drive Letter in the Disk Management Snap-In of the Server Manager (I changed it to P:)
  3. Reboot the machine. You'll get warnings about "file loss": that's what step 1 was for.
  4. Immediately after the reboot, open the Dashboard from one of your clients.
  5. Don't freak out that WHS doesn't know where your Client Backup folder is. ;)
  6. I right clicked on the Client Backup share and selected the only option to restore the connection to another drive.***
  7. In the subsequent dialog, "P:\..." was already preselected.
  8. On the next dialog, there's an option to edit the backup options, or just close. I just closed; didn't want to alter anything.

*** About point 6.: The only option I see now after I did all this is "Move the folder": I don't remember if that was the option or if it was called something else, but it was pretty obvious from the name. BTW, I didn't use the WSSTroubleshooter as Christopher suggested because it was appended with "(OS Reinstall)" and that made me nervous...


After this, I tried restoring files, and everything seems to be fine and connected. I tried restarting to make sure, and everything's good.


Ta-freakin-daa... ;)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...