Jump to content
Covecube Inc.
  • 0
Ultradianguy

Drivepool Down: service gone, installer fails on reinstall

Question

Hi - I've had drivepool running fine for quite some time (other than being slow).  Today I noticed that the UI was stopped looking for the service.  Went into Services to restart and the service was gone. Determined that Bit Defender had quarantined the service executable, which I restored.  Couldn't get it to show in Services panel though.  Tried running the service from command line and it started successfully, but still doesn't show up in the Services panel. 

I've tried restarting the system - no help 

Figured I should reinstall drivepool, but the installer doesn't get past initializing, and eventually says it failed, with an error code about "The pipe is closing".  I'm attaching the log file. 

Strangely, the pooled drive is still accessible despite the service not running - I don't know if that is expected or not. 

I haven't tried uninstalling drivepool yet - wanted to make sure that wouldn't make anything work.

It clearly started with Bitdefender quaranting the service, but  not clear to me why I can't get things reset. 

StableBit_DrivePool_(64_bit)_20191126144326.log

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Just a bit more information - it turned out that although the pool drive folders were all there, they appeared empty, though the files were still on the underlying drives.  However, when I run the service from the command line, it does work, and the pooled drive does become fully accessible.

So - the question is how do I get the service re-registered into the Services panel - and why does the installer fail? 

Is it safe to uninstall and then try reinstalling? (I can never use the phrase "is it safe" without thinking of the movie Marathon Man).

Thanks!

Share this post


Link to post
Share on other sites
  • 0

I have uninstalled StableBit Drivepool  once for that very reason.  One of the antivirus programs had locked it out.

As you have found out your data is still there on the drives but cannot be accessed by Drivepool unless you go under the GUI.

My advice is the one I offer.

1. Goto all of the drives and move your files  from the PoolPart to the Base tree of the drive.  For example...  PoolPart.37ad71b3-16ca-45c4-8c66-34380f727842

Drill Down and you find TV Series on mine  on one of my drives.  I move the TV Series with a simple Right Click to the same directory as the above PoolPart.

I did this with all drives.

2. Deactive your License if you can.  Very important......  If you cant then you have to get your license cleared by Sysop

3.Uninstall Drivepool and run a registry cleaning program.  

4. Reinstall Drivepool and add it to your antivirus program as an exclusion.

5. Create New Drivepools and add the drives you have previously had.

6. Look at each of the new drives and move the files back under the New PoolPart created by your new installation.

7.  Have drive pool remeasure your drives and do its thing for checking your file structure and etc.  I did it this way and got all of my data reset and working with a lot less strain on my heart.  I praise Chris for a great program that I have used for many a years and have 2 machines humming with USB Drives and hardly any problems.  The only time problems happen is when other programs try to screw with Drivepool.

 

Hope this helps.

 

Share this post


Link to post
Share on other sites
  • 0

The one time that I had an issue with drivepool I uninstalled and reinstalled. Worked like a charm. I also migrated the pool to 3 different systems in the time that I have it and it never gave any problems, so yes, it's safe imo to uninstall and reinstall. While installing however you could add it to the exception list of your AV scanner as previous poster recommended. 

Share this post


Link to post
Share on other sites
  • 0

Thanks for the input.  Due to other computer problems unrelated to DP, I ended up having to restore a system image from a few days before the problem with the drivepool service started, so that fixed the issue with no service.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...