Jump to content
Covecube Inc.
  • 0
denywinarto

Reinstall process stuck at spinning logo / bsod after duplicated pool

Question

Specs :

MSI Z390 Pro
Intel i7 8700
32gb ram corsair
HGST 4u60
LSI 9300 8i
Intel i2Ti


Last night there was a power surge, not sure what caused it, and it fried my nvme i think, it became undetected
So i reinstalled a new nvme drive with server 2019.
During installation it went just fine.
But when i try to initialize drive, it freezes. And Got this BSOD screen saying 

Unexpected kernel mode trap 
What failed C1.dll

The thing that bothers me is that it has been working fine for almost a year with server 2016.

What i have tried 

1. Full install all driver > resulting in spinning logo for 1 hour, so i just installed the audio and intel iris driver
2. Change the LSI 9300 8i, i happen to have a backup, but it's still the same thing, so its not sas card issue
3. Change the memory,
4. Remove the intel PCIE nic
5. Move the SAS card to another PCIE

6. Removing the cable plugged to the SAS card  > this allows the windows to load correctly! But i cant access the jbod

I was also wondering if corrupted drive or unfinished drivepool can cause this?

Because on my very first attempt to reinstall, everything actually worked, but i installed an old drive with ntfs mounting in it. And drivepool created 2 pool, i was afraid it might mess my library, so i stopped DP service and i reinstall again, but now im stuck :(

The only thing left is the motherboard and the rack...
And i happen to not have any backup for them..
Been struggling for hours now, any idea?  

 

Edit : i swapped the mobo to lower end spec'ed and it seems to be stable now

Now interestingly, at first i got 2 BSOD, during this time theres a duplicated pool that i mentioned earlier

https://imgur.com/gallery/QPPOjcM

But then after i turn off the drive from duplicated pool, delete poolpart, and it went back to 1 pool. It seems to be stable, no more crash until now, about 5 hours

So its either the motherboard or incorrect drivepool pooling...

 

Edit 2 :

im gonna put this here, this is how i solved duplicated pool and how it was created :

1. Turn off the drive from the pool that i don't want
2. stop DP service
3. Turn on the drive from the pool that i don't want
4. delete poolpart.xxx from that drive
5. start DP service
6. Duplicated pool disappeared

Also in my case, 
i had the old drive with previously NTFS mounted folders installed as secondary drive,
cause i want to copy the old content (emby, radarr, sonarr, etc)
while i want the drives to mount to the new NTFS mounted folders i created on the newly installed drive

And this was a BAD idea, 
The initialized drive went straight mounted to the old drive,
even after i delete the NTFS mounted folders to recycle bin.
and this is how i got the pool initialization mixed up

So lesson learned i guess, i will never use 2 drives if the older one has older NTFS mount folders

 

 

 

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Thought i'd answer this here since my new server's been running stable for almost a month since the issue.

The root of the issue was duplicated pool, as evidenced with whocrashed report showing drivepool's filesystem as one of the trigger.

So the lesson is as i mentioned before, never try to create duplicated pool.

I also learned that mounting hdd to folder is not really necessary if you use drivepool entirely, kinda makes new installation easier since we dont have to re-mount the drives

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...