Jump to content
Covecube Inc.
  • 0
rmahin

SSD Optimizer Emptying too frequently

Question

Hello, I'm having an issue using the SSD Optimizer (and Scanner if it matters) plugin where it seems to be ignoring balancing triggers and is emptying quite frequently. 

I recently reorganized my pool a bit and it was working as expected before. 

My original setup, I had 6 archive drives, and 1 SSD. My archive drives are configured with snapraid and I have no duplication enabled. The goal is to keep everything new on the SSD for a week or two before moving it off to the archives, but as age is not an available trigger I set the trigger ratio to 1% OR if 200GB needs to move. I have one file placement rule to keep 'downloads' on SSD.  This had been working for a couple years without issue. 

However, I recently ran into the issue of my 'downloads' directory exceeding its capacity, so I wanted to repurpose one of my smaller and older archive drives to be a backup "SSD" (even though its a spinning disk). When I changed that to an 'SSD' in the balancer plugin settings however, all new writes to the pool went to this disk, which my assumption is because it had far more free space available. This was not what I wanted, so I made a new pool containing my SSD, and repurposed disk, and set it up using the Ordered File Placement plugin. Then I added SSD pool, to my original pool and flagged it as an SSD. 

So now to the behavior I'm seeing, whenever a balancing occurrs all files other than 'downloads' get moved off to archive drives, regardless of how much data there is. I have it set to balance at 6am every morning, so every morning all data is moved off of the SSD's and into the archive, when my understanding is that it should sit there for a while until the drive needs to move 200GB, as I do not believe I could get the balancing ratio <1%. 

My only thought here is that its doing this because i have more 200GB of data on the SSD, but the calculation of how much data needs to move is done before taking file placement rules into consideration. However, I did try:

  1. increasing the 200GB threshold to 400GB,
  2. writing a new file to the pool
  3. Initiating a balance

And the behavior was the same: I could see the file on the SSD, and after the balance it gets moved to my archive drive. So I am stumped.

The manual balance is still supposed to honor the balancing triggers, correct?

Thank you very much in advance! 

Here are screenshots of my settings: 

image.thumb.png.1c7392b5e80d2f9ee750cf38dc1df2cf.png

image.thumb.png.6c8b16d7c4149ecda46d242a940aa6f7.png

 

image.thumb.png.abff2ae3bd06cec9520f5d0cd020f0b2.png

 

image.thumb.png.dbb1da9b22d6f5bfe690e48894f984ac.png

 

 

image.thumb.png.bd124536f4c703a9c00e055e2d041fed.png

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Thank you for the quick reply! Should this affect the behavior if I manually initiate a re-balance, or only on the schedule? I just tried the same procedure writing a new file, re-balance, and the file was moved to the archive drive. 

Thanks in advance

Share this post


Link to post
Share on other sites
  • 0

Just tried:

  1. Adding a new file
  2. Adjusting the schedule a couple of minutes ahead
  3. Waited to see if a balance was triggered

And it was :( 

The file moved off the SSD and into an archive as before. 

Any other suggestions to try? 

Thanks!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...