Jump to content
Covecube Inc.
  • 0
RG9400

Scanner detecting file system issues with CloudDrive and my SSD

Question

Some background: I typically am constantly moving items to my CloudDrive, so the "To Upload" is always around 500GB. It is mounted on my Intel Optane 905P NVMe SSD. A few days ago, while I was remote, one of my automated programs tried to update the SSD Driver, and upon reboot, the SSD would not boot. At this time, the CloudDrive still had 500GB left to upload. Since I was remote, it got stuck in a restart cycle. When I was able to get to the computer, the only option I had was to reinstall Windows. While mounting the CloudDrive, I had a BSOD related to Memory Management. Long story short, the CloudDrive went through a forced reattach that was cut short, and then a recovery. It has mounted succesfully now.

However, Scanner is obviously picking up the CloudDrive has a damaged file system. It is composed of 20 partitions, and it has found damage in every single one of them. Just for my sanity, I deleted everything I had uploaded to the Drive in the 3 days before the crash, but I am not sure if the drive uploads in a sequential manner, i.e. 3 days would cover the latest 500GB I had uploaded, but I am not sure if the drive was still trying to upload something I had moved a week ago. I also guess that even deleting the corrupt files is not enough. Is there a way to fix the file systems?

On a more serious note, now Scanner is picking up damage to my SSD. It is showing an absurd 154,317 "Media and Data Integrity" issues with this number steadily increasing, and it finds around 250 sectors unreadable. When I run the file recovery, all the files can be recovered. I replace them, rerun the scan, but it finds a different number of unreadable sectors (203) and completely different corrupt files now. I ran the Intel SSD Toolbox. Quick Diagnostics gives 0 problems back, and Full Diagnostic fails instantly on the Read Scan with a statement saying to call Intel -- the Data Integrity portion of the Full Diagnostic passes. Now, I obviously know that I put this SSD through a lot, but I am really hoping that I can repair it. It is fairly stable -- there was only that one initial BSOD right after reinstalling Windows due to "Memory Management." Since then, I think it is running fine? Could this scan possibly be related to the damage on the CloudDrive since it is mounted on this SSD? Is it pending failure? Is there a way to fix this as well?

Sorry for the long message, but I am not very versed in this stuff, so I figured I would give as much detail as I could. The SSD is very new and very expensive, and an idiotic program might have ruined it. I'm really hoping there's a way to fix it that avoids having to reinstall Windows for the (I just got everything set up again). 

 

EDIT/UPDATE: So, after doing a low level format of my SSD and doing a few extra steps as per Intel's instructions, it turns out that I was able to stabilize my Cache Drive. It was not due to the CloudDrive but due to some issue in the specific technology behind the Optane drive that was causing various files to become unreadable for small amounts of time. Now it is stable, and by ignoring the Error Count in Scanner unless there is further increases, everything seems to be going smoothly. I ran CHKDSK on each and every CloudDrive partition a few times using a batch file, and now everything seems to be stable there as well. I will run a file system scan to make sure it does not detect any  more damage. I did lose data, but it was minuscule compared to how much was on the drive to begin with. Overall, it was a frustrating and stressful week, but I was able to get everything back to normal with minimal cost. 

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0
On 6/12/2019 at 2:40 PM, Christopher (Drashna) said:

Would you be opposed to posting the additional steps, for reference sake? 

Sure. I purchased and installed PartedMagic onto a USB. I then booted using this USB to run a Secure Erase, but it was not able to complete successfully. So I ran DD (through PartedMagic as well) on the drive around 5 times. I then converted the disk to GPT using diskpart and installed a fresh copy of Windows. I used CHKDSK, StableBit Scanner, and Intel SSD Toolbox (Full Diagnostic) to confirm that read/writes were functioning as intended. 

Based on what I could understand from Intel, it seems like the Optane drives are fairly unique due to their usage of 3D XPoint technology which caused the specific/strange behavior I was facing. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...