Jump to content
Covecube Inc.
  • 0
MrBlond

3TB Drive showing as 115 PB

Question

I recently installed an Orico 4 bay external hard drive RAID enclosure as JBOD and moved one existing drive from my drive pool from a USB caddy to the first bay in the device.  It sees the drive OK but in StableBit Scanner reports it as 115 PB (nice if true!) rather than 3TB (2.73TB actual in Scanner).

The Disk Sectors showed as unscanned and were clear rather than green. I tried the check but it would not run.  I set File System Health to Good as I had checked it only last week, did a reboot and now the sectors all show green.

The DrivePool has removed all data from the drive and it now shows in Disks as [284MB / 2.73 TB].  It was also showing when hovering over it as Limited Use (or words to that effect) and had a small blue and red triangle above and below it.  It no longer does so but shows the drive is clearly not being used in Disks.

How do I correct the drive size?

Will it start using the drive again for me?

 

Note:

* Current status

* Drive letter O:

image.png.ab318acf0780019d33eca575c1d6b04c.png

image.png.2c2c3bc072cf88d16d324dd008563ae3.png

Share this post


Link to post
Share on other sites

16 answers to this question

Recommended Posts

  • 0

HI,  Thanks for the input.  I installed the version you referred to but the same result.  Also, I lost all the details to my drives such as; "Case where drive is located" and "Drive bay in the case".

Cheers

Share this post


Link to post
Share on other sites
  • 0

For the disk settings, we apologize for that. We changed how the settings are stored, to something more resilient, but in rare cases, it looks like the conversion had issues. 

As for the drive size, could you run the StableBit Troubleshooter, and use "3635" as the contact id? 
http://wiki.covecube.com/StableBit_Troubleshooter

Share this post


Link to post
Share on other sites
  • 0

I have good news and bad news...

The good news is that I've identified the problem.  The bad news is .... the same. 

VDS (the "virtual" disk system) has identified the disk as 115PB.  And that's why StableBit Scanner is reporting that size. 

StableBit DrivePool is reporting 3TBs, because that's the volume size. Which is a different thing.

This is what VDS is reporting as the size:

          Size: 129,986,248,068,418,560

If you open up Disk Management, I'm pretty sure that you'll see something resembling this, as well. (win+x, k). 

It's hooked up to a JMicron controller, which may be part of the problem.  If you can move the disk to a different enclosure, or location, it may fix the issue outright. 

Share this post


Link to post
Share on other sites
  • 0

Also, try this:
 

Click on the "Settings" button in the toolbar and select "Scanner Settings". Enable the "Show advanced settings and information" option, and hit "OK". You will only need to do this once, from now on, it will always display this option.

Click on "Settings", and select the new "Advanced Settings and information" option. Open the Configuration Properties tab. Find the "directIO" section, and make sure the "DoNotCorrectSize" option is unchecked.

If it's checked, uncheck it and click "OK", and see if that helps. 

Share this post


Link to post
Share on other sites
  • 0

OK thanks. I checked Advanced Settings and DoNotCorrectSize was already unticked.

So this is just an issue with my new enclosure then? I don't have an option to use anything else due to the following:

1) My other enclosure is a StarTech 8-Bay USB enclosure and it is not great.  I have to avoid using the only free bays available as they screw my drives.

2) I need to use these multi disk enclosures as I have run out of USB slots on my server.  The Orico had good reviews.  Meh!

3) I am skint and have already thrown too much money at the solution I have in place.

As long as there are no negative effects to my hardware or files I will just take this on the chin.

I do appreciate the help.

Share this post


Link to post
Share on other sites
  • 0

Yeah, sounds like an issue with the enclosure then.  As I mention, VDS is reporting the 115PB size, and that's what StableBit Scanner is using. 
And I'm pretty sure that you open Disk Management, that you'll get the same wrong value... unfortunately. 

For the StarTech, yeah, their hardware is very hit or miss. :(
For the Orico, I've used a couple in the past (friend's actually), and it seemed to work well and play well with StableBit Scanner.  So that may be a good option

As for the money, yeah, I totally understand you there. Unfortunately, if that's what Windows is reporting to us, ....
It may be worth checking the "DoNotCorrectSize" option and see if that helps. Though I doubt it. 

 

Share this post


Link to post
Share on other sites
  • 0

Just a thought - you said you "recently installed" the enclosure.  If *any* part of Windows is reporting the drive size/features incorrectly, you could attempt to either return or exchange it, OR file it under warranty as defective.  

Share this post


Link to post
Share on other sites
  • 0
 

If *any* part of Windows is reporting the drive size/features incorrectly, you could attempt to either return or exchange it, OR file it under warranty as defective.  

This.  Because in this case, it's LITERALLY defective. 

Share this post


Link to post
Share on other sites
  • 0

Thanks for the info.  I had purchased two of the Orico enclosures so have just swapped the unit and disk over and the new one is reporting correctly.  I have just emailed the supplier (via Amazon) to ask for a replacement.

Thanks a lot for your help on this.  Much appreciated.

BTW, Windows was reporting correctly and I had tried the "DoNotCorrectSize" option.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...