Jump to content
Covecube Inc.
  • 1
Makajosch

Disks don't turn off in Windows 10

Question

Hello!

I'm using drivepool for some years now. First in WHS2011 and since a few weeks in Windows 10 which I am using as a Server.

My problem is, that my 10 pooled disks are running all the time and they won't be turned off automatically after beeing in idle for 20 minutes like I've set in Windows control panel and what worked in WHS2011 without problems.

When the Server is in idle, according to the windows taskmanager , there is no access to the drivepool D:, but all 10 pooled disks where simultaneously accessed every two seconds with a small amount of data (4kb or so).

Has anybody an idea to solve this problem?

Greetings

Markus

Share this post


Link to post
Share on other sites

16 answers to this question

Recommended Posts

  • 1

Sorry, no, we know it's definitely not solved.  (or at least, not in a "good" way, that would be acceptable to us).

To make sure, it's definitely the StableBit DrivePool Service that is the cause here, and that you have turned off the BitLocker detection, correct?

And could you make sure that the balancing is set to immediately with the "not more often than every X hours" option checked, or set to "Balance every day at" option.  And disable the "Allow balancing plug-ins to force immediate balancing" option? 

let us know if that helps or not. 

Share this post


Link to post
Share on other sites
  • 0

I have same issue with drivepool and scanner.  I created a task that stops all stablebit services and turns them on at 1am to 5am.   You loose balancing and redundancy of files added while the drivepool  service is off and scanner isn't watching smart and scanning while it's off.  

I have an old thread where this is discussed. 

Share this post


Link to post
Share on other sites
  • 0

@MetalGeek: Thanks for your answer! Do you have a link to that thread?

That sounds, as if the problem would be a fundamental one, but I can't imagine that. And why did it work in WHS2011?

Share this post


Link to post
Share on other sites
  • 0

It doesn't matter if you use bitLocker or not.  The problem is that if BitLocker is queried at all, BitLocker (WMI) causes the disk to be queried, and wakes it up.

As for StableBit Scanner:

Try setting a work window for the drives (in Scanner Settings) and set it to only query the SMART data during the fork window. That may help

Otherwise, running "net stop ScannerService" and "net start ScannerService" will stop and start the service, respectively. 

Share this post


Link to post
Share on other sites
  • 0

I set "BitLocker_PoolPartUnlockDetect" to "False" and rebooted the system. No changes in disk access.

I used StableBit scanner already in WHS2011 and set the smart settings not to query more often than 60 minutes and not to query when disk is asleep. That worked in WHS2011. Now in Windows 10 I even deinstalled the scanner, but without changes in disk access.

Share this post


Link to post
Share on other sites
  • 0

Got it!

I set "BitLocker_PoolPartUnlockDetect" to "false" some time ago, but I didn't recognize that the editor saved the file "settings.json" as "settings.json.txt" so that my changes didn't have any effect. My fault!

Thank you very much for helping me patently!

Greetings

Markus

Share this post


Link to post
Share on other sites
  • 0

I have wanted this to work for so long and it finally works now.  I had to do pretty much every single thing Christopher suggested in this thread, but it works.

Thank you!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...