Jump to content
  • 0

Error adding drive to pool, "can't add the same drive twice". The pool has no drives in it.



I've been having problems for the last many weeks with DP getting seemingly stuck while duplicating. I've done more than one "clean install". Tried a beta from Chris. Nothing is working. 


I just did another clean install of the release version. I've also un-hidden and renamed all the poolpart folders from the old pool, so when DP started it didn't see any existing pool. All of the drives show up as non-pooled. Every drive I try to add to the new pool I get the error "Cannot add the same disk to the pool twice". 


I want to create a new pool and repopulate it with the existing files from the old pool, but I can't add any of the drives. I removed the Hidden property on all the old poolpart folders and added ".old" to the folder name. I thought that would be enough. But there seems to be some other marker/file or something on each drive making them look like they're still in a pool. But there is no pool.



Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Renaming the folder isn't enough.  It may still get picked up, due to some of the hidden data we have attached to it. 


Empty the PoolPart folder, and then DELETE it. Make sure it's not in the recycle bin, but fully deleted from the drive. 


That should fix the issue you're seeing then. 

Also, this isn't exactly the same, but the "merge pools" guide should work for this.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...