Jump to content
Covecube Inc.
  • 0
Freppa

429.....

Question

Hi friends,

 

Today I had my Fiber upgraded (changed vendor) to 1000/1000 which meant that I lost connection to my drives. I only get the dreaded HTTP Status 429. Now, I have probably missed what I can do to not incur the wrath of the throttling Gods over at Amazon, but could I get some guidance (I am just about to migrate from amazon to Google Drive since Amazon doesn't seem to end up on the positive list - go figure on the timing.....)

 

This is what the logs tell me.

 

0:22:06.0: Warning: 0 : [ApiAmazonCloudDrive] Server is throttling us, waiting 1,000ms and retrying.
0:22:07.2: Warning: 0 : [ApiAmazonCloudDrive] Server is throttling us, waiting 2,000ms and retrying.
0:22:09.3: Warning: 0 : [ApiAmazonCloudDrive] Server is throttling us, waiting 3,000ms and retrying.
0:22:12.4: Warning: 0 : [ApiAmazonCloudDrive] Server is throttling us, waiting 4,000ms and retrying.
0:22:16.5: Warning: 0 : [ApiAmazonCloudDrive] Server is throttling us, waiting 5,000ms and retrying.
0:22:21.7: Warning: 0 : [ApiAmazonCloudDrive] Server is throttling us, waiting 6,000ms and retrying.
0:22:27.8: Warning: 0 : [ApiAmazonCloudDrive] Server is throttling us, waiting 7,000ms and retrying.
0:22:35.0: Warning: 0 : [ApiAmazonCloudDrive] Server is throttling us, waiting 8,000ms and retrying.
0:22:43.2: Warning: 0 : [ApiAmazonCloudDrive] Server is throttling us, waiting 9,000ms and retrying.
0:22:52.3: Warning: 0 : [ValidateLogins] Error instantiating management provider. HTTP Status 429

 

Tips/tricks?

 

/F
 


PS: Perhaps should add that I have upgraded to .858 a couple of days ago if that makes any difference.

Share this post


Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 0

429 error codes are throttling requests, from the server. 

 

Specifically, there isn't a lot that we can do here. The software automatically retries, but backs off more and more.  

 

That said, we are seeing this ... more frequently, and from a number of users. 

 

Basically, Amazon is throttling the connections, increasingly.

 

And to be blunt, it's because they don't have the infrastructure to support Amazon Cloud Drive, and don't want to drop the money/resources into it, to properly support it.  Which is ironic, as this is the same company that runs S3 and AWS.

ACD's viability as a cloud provider is becoming more and more questionable, as time goes on.  And we HIGHLY recommend moving your data away from this provider.

Share this post


Link to post
Share on other sites
  • 0

And to be blunt, it's because they don't have the infrastructure to support Amazon Cloud Drive, and don't want to drop the money/resources into it, to properly support it.  Which is ironic, as this is the same company that runs S3 and AWS.

ACD's viability as a cloud provider is becoming more and more questionable, as time goes on.  And we HIGHLY recommend moving your data away from this provider.

 

That's actually what I was doing when the errors started occuring.... :) 

 

That was about 12 hours ago, and it looks like Amazon still has not fixed it. Ironic indeed. 

 

Share this post


Link to post
Share on other sites
  • 0

I have the same issue. StableBit CloudeDrive is just telling me that "This drive cannot be mounted" "There was an error communication with the storage provider. HTTP Status 429"

I can't even press "retry..." :( That means I can't access my 3TB og encrypted files now... 

Share this post


Link to post
Share on other sites
  • 0

The service seems to have been restored now, although it's still a bit "shaky".

 

EDIT: make that "VERY shaky"  ;)

My drive keeps unmounting. but at least it looks like Amazon is making some progress. 

 

Yup, that's what I'm seeing mentioned elsewhere, as well. 

 

There is an advanced config file that can help with that, but it does increase the possibility of locking the system up temporarily. 

 

Looks like it's working as normal for me at this point. 

 

Yup.  Usually doens't last longer than a day or so... but still.... That's waay too long. :(

 

Yeah but my StableBit is downloading constantly with max download speed.. I don't know why

 

Are you throttling the connection?  

And what's your download speed? 

Share this post


Link to post
Share on other sites
  • 0

Are you throttling the connection?  

And what's your download speed? 

 

How can I see if it throttling? 

It was downloading with 128Mbit for almost 24 hours and my cache is only 25 GB

Share this post


Link to post
Share on other sites
  • 0

For the throttling, there is a bandwidth setting under "Drive Options" -> Performance -> "I/O Performance".  

 

ALso, if you're getting throttled by the provider, where the upload/download information is, there will be a tortoise icon that shows up to indicate that the connection is being throttled on the provider end. 

Share this post


Link to post
Share on other sites
  • 0

For the throttling, there is a bandwidth setting under "Drive Options" -> Performance -> "I/O Performance".  

 

ALso, if you're getting throttled by the provider, where the upload/download information is, there will be a tortoise icon that shows up to indicate that the connection is being throttled on the provider end. 

 

Thx for the answer

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...